aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard-Rogalski <rrogalski@tutanota.com>2023-07-14 11:37:38 -0500
committerRichard-Rogalski <rrogalski@tutanota.com>2023-07-14 11:41:58 -0500
commit2102e708b159171ea2c137dff6faf94cca79d1f2 (patch)
tree89feaa147b0acc210fde04b24fd23997215cd96c /app-emulation
parentapp-emulation/LookingGlass: fix error compiling (diff)
downloadguru-2102e708b159171ea2c137dff6faf94cca79d1f2.tar.gz
guru-2102e708b159171ea2c137dff6faf94cca79d1f2.tar.bz2
guru-2102e708b159171ea2c137dff6faf94cca79d1f2.zip
app-emulation/box64: new package, add 0.2.2
Signed-off-by: Richard-Rogalski <rrogalski@tutanota.com>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/box64/Manifest1
-rw-r--r--app-emulation/box64/box64-0.2.2.ebuild39
-rw-r--r--app-emulation/box64/metadata.xml15
3 files changed, 55 insertions, 0 deletions
diff --git a/app-emulation/box64/Manifest b/app-emulation/box64/Manifest
new file mode 100644
index 000000000..ab6823137
--- /dev/null
+++ b/app-emulation/box64/Manifest
@@ -0,0 +1 @@
+DIST box64-0.2.2.tar.gz 3359829 BLAKE2B 52e4be1daadaffa16ed494d06441252dc27e68a82dbe13b1f3b0deeac59cc91a6f3c23e52fa9a574e5a1475fd38c8e41f05c3349b501cc1c6f338e70c7ad5c50 SHA512 3213e112aad44118209733960523d459bf74a07b7a1cc1b1b86d5938af2052fc298c8d2b28237cd7186751bdfcf791741a82fdf461c02b58f7e98461b794ef95
diff --git a/app-emulation/box64/box64-0.2.2.ebuild b/app-emulation/box64/box64-0.2.2.ebuild
new file mode 100644
index 000000000..cab0a0b2a
--- /dev/null
+++ b/app-emulation/box64/box64-0.2.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake optfeature
+
+DESCRIPTION="Linux Userspace x86_64 Emulator with a twist"
+HOMEPAGE="https://box86.org"
+SRC_URI="https://github.com/ptitSeb/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~arm64 ~ppc64"
+IUSE="aot"
+REQUIRED_USE="aot? ( arm64 )"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_configure() {
+ local -a mycmakeargs=(
+ -DNOGIT=1
+ -DARM_DYNAREC=$(usex jit)
+ )
+
+ use ppc64 && mycmakeargs+=( -DPPC64LE=1 )
+ use riscv && mycmakeargs+=( -DRV64=1 )
+ use loong && mycmakeargs+=( -DLARCH64=1 )
+ use amd64 && mycmakeargs+=( -DLD80BITS=1 -DNOALIGN=1 )
+
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ optfeature "OpenGL for GLES devices" \
+ "media-libs/gl4es"
+}
diff --git a/app-emulation/box64/metadata.xml b/app-emulation/box64/metadata.xml
new file mode 100644
index 000000000..a14dd74f9
--- /dev/null
+++ b/app-emulation/box64/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>rrogalski@tutanota.com</email>
+ <name>Richard Rogalski</name>
+ </maintainer>
+
+ <use>
+ <flag name="aot">Enables the dynamic ahead of time recompiler for increased performance on ARM</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">ptitSeb/box64</remote-id>
+ </upstream>
+</pkgmetadata>