aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac.paragon@gmail.com>2022-04-29 09:03:33 +0300
committerViorel Munteanu <ceamac.paragon@gmail.com>2022-04-29 09:03:33 +0300
commit90639e9f90528ffab930e19eda56a7fbd69de763 (patch)
tree83f3ec98a1fd1eb72a40b63a1d9ebe095be76762 /app-misc
parentapp-misc/fastfetch: add 1.3.4 (diff)
downloadguru-90639e9f90528ffab930e19eda56a7fbd69de763.tar.gz
guru-90639e9f90528ffab930e19eda56a7fbd69de763.tar.bz2
guru-90639e9f90528ffab930e19eda56a7fbd69de763.zip
app-misc/fastfetch: Add USE chafa for upcoming release
Signed-off-by: Viorel Munteanu <ceamac.paragon@gmail.com>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/fastfetch/fastfetch-9999.ebuild5
-rw-r--r--app-misc/fastfetch/metadata.xml1
2 files changed, 5 insertions, 1 deletions
diff --git a/app-misc/fastfetch/fastfetch-9999.ebuild b/app-misc/fastfetch/fastfetch-9999.ebuild
index e7a1378dd..2b3681930 100644
--- a/app-misc/fastfetch/fastfetch-9999.ebuild
+++ b/app-misc/fastfetch/fastfetch-9999.ebuild
@@ -16,12 +16,13 @@ fi
LICENSE="MIT"
SLOT="0"
-IUSE="X gnome imagemagick pci vulkan wayland xcb xfce xrandr"
+IUSE="X chafa gnome imagemagick pci vulkan wayland xcb xfce xrandr"
# note - qa-vdb will always report errors because fastfetch loads the libs dynamically
RDEPEND="
sys-libs/zlib
X? ( x11-libs/libX11 )
+ chafa? ( media-gfx/chafa )
gnome? (
dev-libs/glib
gnome-base/dconf
@@ -42,6 +43,7 @@ REQUIRED_USE="xrandr? ( X )"
src_configure() {
local mycmakeargs=(
-DENABLE_RPM=no
+ -DENABLE_LIBPCI=$(usex pci)
-DENABLE_VULKAN=$(usex vulkan)
-DENABLE_WAYLAND=$(usex wayland)
-DENABLE_XCB_RANDR=$(usex xcb)
@@ -54,6 +56,7 @@ src_configure() {
-DENABLE_IMAGEMAGICK7=$(use imagemagick && has_version '>=media-gfx/imagemagick-7.0.0' && echo yes || echo no)
-DENABLE_IMAGEMAGICK6=$(use imagemagick && has_version '<media-gfx/imagemagick-7.0.0' && echo yes || echo no)
-DENABLE_ZLIB=yes
+ -DENABLE_CHAFA=$(usex chafa)
)
cmake_src_configure
diff --git a/app-misc/fastfetch/metadata.xml b/app-misc/fastfetch/metadata.xml
index d5e16ecbd..755fc0bac 100644
--- a/app-misc/fastfetch/metadata.xml
+++ b/app-misc/fastfetch/metadata.xml
@@ -9,6 +9,7 @@
<remote-id type="github">LinusDierheimer/fastfetch</remote-id>
</upstream>
<use>
+ <flag name="chafa">Enables text/graphics renderer with <pkg>media-gfx/chafa</pkg></flag>
<flag name="pci">Enables reading GPU via <pkg>sys-apps/pciutils</pkg></flag>
<flag name="vulkan">Enables reading GPU via <pkg>media-libs/vulkan-loader</pkg></flag>
<flag name="xfce">Enables support for XFCE config</flag>