aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAliaksei Urbanski <aliaksei.urbanski@gmail.com>2024-04-30 23:50:22 +0300
committerJulien Roy <julien@jroy.ca>2024-04-30 17:07:05 -0400
commit988ed923fff15772802289ce29a9b24c284d114e (patch)
tree8cbc0eee405e7c19749813a9dae8b8087840bc7e /app-text
parent*/*: Inline mirror://sourceforge (diff)
downloadguru-988ed923fff15772802289ce29a9b24c284d114e.tar.gz
guru-988ed923fff15772802289ce29a9b24c284d114e.tar.bz2
guru-988ed923fff15772802289ce29a9b24c284d114e.zip
app-text/vale: add 3.4.1
Release: - https://github.com/errata-ai/vale/releases/tag/v3.4.1 These changes also: - update metadata.xml Closes: https://bugs.gentoo.org/930521 Signed-off-by: Aliaksei Urbanski <aliaksei.urbanski@gmail.com> Closes: https://github.com/gentoo/guru/pull/174 Signed-off-by: Julien Roy <julien@jroy.ca>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/vale/Manifest2
-rw-r--r--app-text/vale/metadata.xml7
-rw-r--r--app-text/vale/vale-3.4.1.ebuild45
3 files changed, 54 insertions, 0 deletions
diff --git a/app-text/vale/Manifest b/app-text/vale/Manifest
index 9368460c2..c72a53531 100644
--- a/app-text/vale/Manifest
+++ b/app-text/vale/Manifest
@@ -1,2 +1,4 @@
DIST vale-2.28.3-gentoo-deps.tar.xz 138351324 BLAKE2B b457e78e8a5d4911abfd8e531097a5edf26bd7b86269736af04d96fe93ff6ebddb333ef276d89980d952d42c5bd173e3ea1b594976c3b12e781d3497743cfda2 SHA512 a20becf9051622f8d9df01e99bb5daea3ff6494d219ffd1bb6693b7a275124cd51f7a0cc4105fdc166de8f4e4c6f856cb940f6e49391f2a8d255c539fc4300bc
DIST vale-2.28.3.tar.gz 9657963 BLAKE2B 0a8487b80b0da10eedb28ce3df11da296136250d4b275f97802a10bd3ee3f9d920e80253da6ce4cc3cab5314033439dfaceb286de366cf0c0c6658b569b92358 SHA512 e638fbddd6738c56739f9425ff2c63d9afe1c329d96bf18876a8f188ce5064bc30833a3ac046654a38211996d7f8865266d70241a9d5c5f9577c46331a93d4ec
+DIST vale-3.4.1-deps.tar.xz 151263460 BLAKE2B 828348dc5e0447ba54cf9b4e369c4e2c63c50a6e72ff79c5a8fd0e8112241296d222e44943a9c5fcc34a4ea0807e7aebb0136a2a02c11bfc96303292d718fc2f SHA512 110a805b61084cbedd604550d5fe757d4df04cd89b1136a43d23b1bdf660c59bc4ad5d692174742aa7984e635ed50a30d43fb22480b01371152a77ea94c7bd67
+DIST vale-3.4.1.tar.gz 10528911 BLAKE2B 1975806a212c9bf61f92ec5b4a12f625a7a1d0242ead91b602e57500126c8e635b725ed1072b5cb2907838d73822d8fa66266cf40df1f62f0dd50b678f083423 SHA512 93a70954fa67e8f1a7c3c3c8681784b06c32388c70eb6c75ae90292ae3a913dbb89a0539361b689470ee6a77fd9e0419312a98f64af4d1236d32dc436e3a4d9d
diff --git a/app-text/vale/metadata.xml b/app-text/vale/metadata.xml
index 794aefbe4..ed1112a59 100644
--- a/app-text/vale/metadata.xml
+++ b/app-text/vale/metadata.xml
@@ -6,6 +6,13 @@
<name>Ferenc Erki</name>
</maintainer>
<upstream>
+ <maintainer status="active">
+ <email>joseph@jdkato.io</email>
+ <name>Joseph Kato</name>
+ </maintainer>
+ <changelog>https://github.com/errata-ai/vale/releases</changelog>
+ <doc>https://vale.sh/docs/</doc>
+ <bugs-to>https://github.com/errata-ai/vale/issues</bugs-to>
<remote-id type="github">errata-ai/vale</remote-id>
</upstream>
</pkgmetadata>
diff --git a/app-text/vale/vale-3.4.1.ebuild b/app-text/vale/vale-3.4.1.ebuild
new file mode 100644
index 000000000..7df0413b9
--- /dev/null
+++ b/app-text/vale/vale-3.4.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module optfeature
+
+DESCRIPTION="A syntax-aware linter for prose built with speed and extensibility in mind"
+HOMEPAGE="https://vale.sh/docs/"
+
+SRC_URI="
+ https://github.com/errata-ai/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://gentoo.aur.im/distfiles/${P}-deps.tar.xz
+"
+
+LICENSE="Apache-2.0 BSD BSD-2 MIT public-domain"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# tests require:
+# - various ruby gems: see testdata/Gemfile
+# - packaged optional runtime dependencies: asciidoctor, rst2html, xsltproc
+# - unpackaged optional runtime dependency: dita (may be removed in a patch)
+# - network access: sync subcommand tests (may be removed in a patch)
+RESTRICT="test"
+
+src_prepare() {
+ sed -i "s/\$(LAST_TAG)/v${PV}/" Makefile || die 'sed failed'
+ default
+}
+
+src_compile() {
+ emake build os=linux
+}
+
+src_install() {
+ dobin bin/vale
+ default_src_install
+}
+
+pkg_postinst() {
+ optfeature "AsciiDoc support" dev-ruby/asciidoctor
+ optfeature "reStructuredText support" dev-python/docutils
+ optfeature "XML support" dev-libs/libxslt
+}