aboutsummaryrefslogtreecommitdiff
path: root/dev-R
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2022-02-14 23:14:46 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2022-02-18 02:11:16 +0500
commitbb877d15ee0102500c2b36da74b05215c783b510 (patch)
tree78f5e93513353525911c84c1a615ceb117342610 /dev-R
parentdev-R/RcppArmadillo: remove illegal dosym usage (diff)
downloadguru-bb877d15ee0102500c2b36da74b05215c783b510.tar.gz
guru-bb877d15ee0102500c2b36da74b05215c783b510.tar.bz2
guru-bb877d15ee0102500c2b36da74b05215c783b510.zip
dev-R/RcppEnsmallen: fix illegal dosym usage
Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
Diffstat (limited to 'dev-R')
-rw-r--r--dev-R/RcppEnsmallen/RcppEnsmallen-0.2.17.0.1.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/dev-R/RcppEnsmallen/RcppEnsmallen-0.2.17.0.1.ebuild b/dev-R/RcppEnsmallen/RcppEnsmallen-0.2.17.0.1.ebuild
index 08436d0db..3914b1ab7 100644
--- a/dev-R/RcppEnsmallen/RcppEnsmallen-0.2.17.0.1.ebuild
+++ b/dev-R/RcppEnsmallen/RcppEnsmallen-0.2.17.0.1.ebuild
@@ -35,6 +35,11 @@ src_prepare() {
src_install() {
R-packages_src_install
- dosym8 -r /usr/include/ensmallen_bits "/usr/$(get_libdir)/R/site-library/${PN}/include/ensmallen_bits"
- dosym8 -r /usr/include/ensmallen.hpp "/usr/$(get_libdir)/R/site-library/${PN}/include/ensmallen.hpp"
+ R_includedir="/usr/$(get_libdir)/R/site-library/${PN}/include"
+ dosym8 -r /usr/include/ensmallen.hpp "${R_includedir}/ensmallen.hpp"
+
+ for file in "${ED}/${R_includedir}"/ensmallen_bits/*; do
+ filename=$(basename "${file}")
+ dosym8 -r /usr/include/ensmallen_bits/${file} "${R_includedir}/ensmallen_bits/${file}"
+ done
}