aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOliver Freyermuth <o.freyermuth@googlemail.com>2023-06-09 10:31:44 +0200
committerOliver Freyermuth <o.freyermuth@googlemail.com>2023-06-09 10:32:48 +0200
commit6d4aabcc3db31ff84cfd650453584850cc940220 (patch)
tree57848a9f86798bc5b252abfef4dfd8b3c3fd3d09 /dev-cpp
parentwww-apps/code-server-bin: add OpenRC init script (diff)
downloadguru-6d4aabcc3db31ff84cfd650453584850cc940220.tar.gz
guru-6d4aabcc3db31ff84cfd650453584850cc940220.tar.bz2
guru-6d4aabcc3db31ff84cfd650453584850cc940220.zip
dev-cpp/jwt-cpp: treeclean
This was a dependency solely of dev-cpp/scitokens-cpp, which is now in gentoo proper. See https://github.com/gentoo/gentoo/pull/31364 for unbundling PR. Signed-off-by: Oliver Freyermuth <o.freyermuth@googlemail.com>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/jwt-cpp/Manifest2
-rw-r--r--dev-cpp/jwt-cpp/jwt-cpp-0.4.0.ebuild72
-rw-r--r--dev-cpp/jwt-cpp/jwt-cpp-0.6.0.ebuild76
-rw-r--r--dev-cpp/jwt-cpp/metadata.xml15
4 files changed, 0 insertions, 165 deletions
diff --git a/dev-cpp/jwt-cpp/Manifest b/dev-cpp/jwt-cpp/Manifest
deleted file mode 100644
index 7ed5fadf1..000000000
--- a/dev-cpp/jwt-cpp/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST jwt-cpp-0.4.0.tar.gz 64383 BLAKE2B 48de501a1fff851ada5ffc0554309f6f05943d6b6a459c8f002f8bcebb9be40d878fc7f39c2f4da7031b784421dd0530d8e50d5eadbdb924c5485fdcd2f04b85 SHA512 8a82accb396db8fb2f1a32b14459f6ff3f5d4c6dcb54dfe1a10751da093381c2dcfb92c6e1f4f2ae42ca0f25c96c02ea35f37b723afaaf6b2d458c1a6f4e6b62
-DIST jwt-cpp-0.6.0.tar.gz 275126 BLAKE2B 4bf9bed9b2aa9584b497b2ab4d1d2582d9b5e4ded402200ea3f70b0e6752338fd4e2ef9c5836c728a6907a0190209c7baeaecd26032ce64dc6bf12a23594f27b SHA512 b6d5ebb3a7eeb6fef9a1d41c707251d1ab05bf47920c280d5203f1b9ee5bf6f8e914cd2ffaed66550cfa6d78c34465d4cf86517a759d5f8739b429faf1c2c0ef
diff --git a/dev-cpp/jwt-cpp/jwt-cpp-0.4.0.ebuild b/dev-cpp/jwt-cpp/jwt-cpp-0.4.0.ebuild
deleted file mode 100644
index 611f754fd..000000000
--- a/dev-cpp/jwt-cpp/jwt-cpp-0.4.0.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-if [[ ${PV} == *9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/Thalhammer/jwt-cpp.git"
-else
- SRC_URI="https://github.com/Thalhammer/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64"
-fi
-
-DESCRIPTION="header only library for creating and validating JSON Web Tokens in C++11"
-HOMEPAGE="https://thalhammer.github.io/jwt-cpp/"
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="doc +picojson test"
-
-DEPEND="${RDEPEND}
- dev-libs/openssl
- picojson? ( dev-cpp/picojson )"
-BDEPEND="
- doc? ( app-doc/doxygen[dot] )
- test? ( dev-cpp/gtest )
-"
-RESTRICT="
- !picojson? ( test )
- !test? ( test )"
-
-src_prepare() {
- # Unbundle dev-cpp/picojson and fix include paths.
- # See also: https://github.com/Thalhammer/jwt-cpp/issues/213
- rm -vrf include/picojson || die
- find -name '*.h' -type f -print0 | xargs -0 sed -r -e "s:picojson/picojson\.h:picojson.h:g" -i || die
- # Prevent installation of bundled dev-cpp/picojson.
- sed -i -e 's:^\s*install.*include/picojson.*$::' CMakeLists.txt || die
- # Fix installation paths for .cmake files.
- sed -i -e 's:DESTINATION ${CMAKE_INSTALL_PREFIX}/jwt-cpp:DESTINATION ${CMAKE_INSTALL_PREFIX}/share/jwt-cpp:' CMakeLists.txt || die
- sed -i -e 's:DESTINATION jwt-cpp:DESTINATION ${CMAKE_INSTALL_PREFIX}/share/jwt-cpp:' CMakeLists.txt || die
- cmake_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- # Not useful for now, asks for non-existent CMake module.
- #-DJWT_EXTERNAL_PICOJSON="$(usex picojson)"
- # Examples are not installed and for development only.
- -DBUILD_TESTS="$(usex test)"
- )
- cmake_src_configure
-}
-
-src_compile() {
- cmake_src_compile
- if use doc; then
- doxygen || die
- fi
-}
-
-src_install() {
- cmake_src_install
- use doc && local HTML_DOCS=(docs/html/.)
- einstalldocs
-}
-
-src_test() {
- "${BUILD_DIR}"/tests/jwt-cpp-test || die
-}
diff --git a/dev-cpp/jwt-cpp/jwt-cpp-0.6.0.ebuild b/dev-cpp/jwt-cpp/jwt-cpp-0.6.0.ebuild
deleted file mode 100644
index 29d69816b..000000000
--- a/dev-cpp/jwt-cpp/jwt-cpp-0.6.0.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-if [[ ${PV} == *9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/Thalhammer/jwt-cpp.git"
-else
- SRC_URI="https://github.com/Thalhammer/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64"
-fi
-
-DESCRIPTION="header only library for creating and validating JSON Web Tokens in C++11"
-HOMEPAGE="https://thalhammer.github.io/jwt-cpp/"
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="doc +picojson test"
-
-DEPEND="${RDEPEND}
- dev-cpp/nlohmann_json
- dev-libs/openssl
- picojson? ( dev-cpp/picojson )"
-BDEPEND="
- doc? ( app-doc/doxygen[dot] )
- test? ( dev-cpp/gtest )
-"
-RESTRICT="
- !picojson? ( test )
- !test? ( test )"
-DOCS=( README.md docs/{faqs,ssl,traits}.md )
-
-src_prepare() {
- # Unbundle dev-cpp/nlohmann_json.
- rm -vrf include/nhlomann || die
- # Unbundle dev-cpp/picojson and fix include paths.
- # See also: https://github.com/Thalhammer/jwt-cpp/issues/213
- rm -vrf include/picojson || die
- find -name '*.h' -type f -print0 | xargs -0 sed -r -e "s:picojson/picojson\.h:picojson.h:g" -i || die
- # Prevent installation of bundled dev-cpp/picojson.
- sed -i -e 's:^\s*install.*picojson/picojson\.h.*$::' CMakeLists.txt || die
- cmake_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- -DJWT_DISABLE_PICOJSON="$(usex picojson OFF ON)"
- # Not useful for now, asks for non-existent CMake module.
- #-DJWT_EXTERNAL_PICOJSON="$(usex picojson)"
- # Examples are not installed and for development only.
- -DJWT_BUILD_EXAMPLES=NO
- -DJWT_BUILD_TESTS="$(usex test)"
- -DJWT_CMAKE_FILES_INSTALL_DIR="${EPREFIX}"/usr/share/cmake
- )
- cmake_src_configure
-}
-
-src_compile() {
- cmake_src_compile
- if use doc; then
- doxygen || die
- fi
-}
-
-src_install() {
- cmake_src_install
- use doc && local HTML_DOCS=(doxy/html/.)
- einstalldocs
-}
-
-src_test() {
- "${BUILD_DIR}"/tests/jwt-cpp-test || die
-}
diff --git a/dev-cpp/jwt-cpp/metadata.xml b/dev-cpp/jwt-cpp/metadata.xml
deleted file mode 100644
index e17af4f35..000000000
--- a/dev-cpp/jwt-cpp/metadata.xml
+++ /dev/null
@@ -1,15 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>o.freyermuth@googlemail.com</email>
- <name>Oliver Freyermuth</name>
- </maintainer>
- <upstream>
- <bugs-to>https://github.com/Thalhammer/jwt-cpp/issues</bugs-to>
- <remote-id type="github">Thalhammer/jwt-cpp</remote-id>
- </upstream>
- <use>
- <flag name="picojson">Enable use of <pkg>dev-cpp/picojson</pkg></flag>
- </use>
-</pkgmetadata>