aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNRK <nrk@disroot.org>2024-09-12 10:16:21 +0000
committerNRK <nrk@disroot.org>2024-09-12 10:16:21 +0000
commit387eb9cbd86d28907708d561dc11c39c24c90f98 (patch)
tree8ab92191e6853256c88fd8c5e84f65669c8c7d07 /dev-debug
parentdev-vcs/jj: require libgit2-1.8.1 or better (diff)
downloadguru-387eb9cbd86d28907708d561dc11c39c24c90f98.tar.gz
guru-387eb9cbd86d28907708d561dc11c39c24c90f98.tar.bz2
guru-387eb9cbd86d28907708d561dc11c39c24c90f98.zip
dev-debug/gdb-dashboard: add v0.17.3
Signed-off-by: NRK <nrk@disroot.org>
Diffstat (limited to 'dev-debug')
-rw-r--r--dev-debug/gdb-dashboard/Manifest1
-rw-r--r--dev-debug/gdb-dashboard/gdb-dashboard-0.17.3.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-debug/gdb-dashboard/Manifest b/dev-debug/gdb-dashboard/Manifest
index b38215757..8f769f1f8 100644
--- a/dev-debug/gdb-dashboard/Manifest
+++ b/dev-debug/gdb-dashboard/Manifest
@@ -1 +1,2 @@
DIST gdb-dashboard-0.17.2.tar.gz 23275 BLAKE2B 6c7cfd2ac5ffa686629bbfa628bfcf1b383e44d632c3acf1205a7e0e01192f167744e54f2e145644c1e2f8479f9021ca05a39481a4f4c07f0ca2db75946392cd SHA512 caa723479b8539f01e9c46e2c95731fed2fe16087d495aa9eddacf93ffbf5f61f59166a106157ea099e0e2d90d1d0e97b7d2b6b3addb776506ce809438871006
+DIST gdb-dashboard-0.17.3.tar.gz 23288 BLAKE2B d7118e356d0c71dd77b887013eed42f31aa990ccef8c64caf351ace5c367031dd16e0b17116c89ff06d347907328b85199009ce0d66e4c338740da0378abe7c4 SHA512 7def8a8a0549397f1cc89f03e7c818d82d7ac02c0e81f535d061c6bca1b88708fb94c985261d0b5f3f7eeb22a89c0b42cb127efc0b1fb6338b9751b18cb03ebe
diff --git a/dev-debug/gdb-dashboard/gdb-dashboard-0.17.3.ebuild b/dev-debug/gdb-dashboard/gdb-dashboard-0.17.3.ebuild
new file mode 100644
index 000000000..54a66c050
--- /dev/null
+++ b/dev-debug/gdb-dashboard/gdb-dashboard-0.17.3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit python-single-r1 optfeature wrapper
+
+DESCRIPTION="Modular visual interface for GDB in Python"
+HOMEPAGE="https://github.com/cyrus-and/gdb-dashboard"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/cyrus-and/gdb-dashboard"
+else
+ SRC_URI="https://github.com/cyrus-and/gdb-dashboard/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ dev-debug/gdb[python]
+ ${PYTHON_DEPS}
+"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_install() {
+ insinto "/usr/share/${PN}"
+ newins .gdbinit "${PN}"
+
+ # install a convenient wrapper. disables any typical .gdbinit (-nh) to
+ # get a clean state without interference. -q to disable annoying
+ # copyright message at startup.
+ make_wrapper "$PN" "gdb -q -nh -iex 'source /usr/share/${PN}/${PN}'"
+
+ dodoc README.md
+}
+
+pkg_postinst() {
+ einfo "To use ${PN}:"
+ einfo " Either use the installed '${PN}' wrapper script directly."
+ einfo " Or put 'source /usr/share/${PN}/${PN}' in your .gdbinit file."
+ einfo ""
+
+ optfeature "syntax highlighting" "dev-python/pygments"
+}