aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2020-03-05 03:06:20 +0100
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2020-03-05 03:06:20 +0100
commit7212ba79c230f831e617b18a4e24d4d0782fae11 (patch)
tree22e1732bec6ced19caf506e0390aeef9aba03df9 /dev-lang
parentdev-python/tekore: depend on spotify (diff)
downloadguru-7212ba79c230f831e617b18a4e24d4d0782fae11.tar.gz
guru-7212ba79c230f831e617b18a4e24d4d0782fae11.tar.bz2
guru-7212ba79c230f831e617b18a4e24d4d0782fae11.zip
dev-lang/aldor: respect flags, link gc
Package-Manager: Portage-2.3.91, Repoman-2.3.20 Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/aldor/aldor-1.2.0_p20190730.ebuild10
-rw-r--r--dev-lang/aldor/files/respect-flags.diff47
2 files changed, 54 insertions, 3 deletions
diff --git a/dev-lang/aldor/aldor-1.2.0_p20190730.ebuild b/dev-lang/aldor/aldor-1.2.0_p20190730.ebuild
index c58df7e45..24016c735 100644
--- a/dev-lang/aldor/aldor-1.2.0_p20190730.ebuild
+++ b/dev-lang/aldor/aldor-1.2.0_p20190730.ebuild
@@ -20,7 +20,10 @@ LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64"
-IUSE="boehm-gc doc emacs java"
+#force boehm-gc for now, without it won't build ...
+IUSE="+boehm-gc doc emacs java"
+
+PATCHES=( "${FILESDIR}/respect-flags.diff" )
#is junit dep. only for test?
#TODO: choose a slot for junit
@@ -58,8 +61,9 @@ src_unpack() {
}
src_prepare() {
- #TODO: respect CFLAGS and remove Werror
- eapply_user
+ use boehm-gc && sed -i 's|-L /usr/X11/lib|-L /usr/X11/lib -lgc|' aldor/src/aldor.conf || die
+
+ default
eautoreconf
}
diff --git a/dev-lang/aldor/files/respect-flags.diff b/dev-lang/aldor/files/respect-flags.diff
new file mode 100644
index 000000000..4aec753e3
--- /dev/null
+++ b/dev-lang/aldor/files/respect-flags.diff
@@ -0,0 +1,47 @@
+diff -ur a/aldor/src/Makefile.am b/aldor/src/Makefile.am
+--- a/aldor/src/Makefile.am 2019-07-30 01:13:14.000000000 +0200
++++ b/aldor/src/Makefile.am 2020-03-04 21:14:57.582054633 +0100
+@@ -40,12 +40,12 @@
+
+ javagen_LDADD = libphase.a libstruct.a libgen.a libport.a -lm
+ javagen_LDFLAGS =
+-javagen_CFLAGS = -g $(STRICTCFLAGS)
++javagen_CFLAGS = $(STRICTCFLAGS)
+
+ showexp_SOURCES = showexports.c
+ showexp_LDADD = libphase.a libstruct.a libgen.a libport.a -lm
+ showexp_LDFLAGS =
+-showexp_CFLAGS = -g $(STRICTCFLAGS)
++showexp_CFLAGS = $(STRICTCFLAGS)
+
+ aldor_SOURCES = \
+ axlcomp.c \
+@@ -53,7 +53,7 @@
+ main.c
+ aldor_LDADD = libphase.a libstruct.a libgen.a libport.a -lm
+ aldor_LDFLAGS = $(build_id)
+-aldor_CFLAGS = -g $(STRICTCFLAGS)
++aldor_CFLAGS = $(STRICTCFLAGS)
+
+ #aldortest_CFLAGS = -DTEST_STAND_ALONE -DTEST_ALL -save-temps $(STRICTCFLAGS)
+ aldortest_CFLAGS = -DTEST_STAND_ALONE -DTEST_ALL -save-temps $(STRICTCFLAGS)
+@@ -316,7 +316,6 @@
+ testall_LDFLAGS =
+ testall_CFLAGS = -save-temps $(STRICTCFLAGS)
+
+-CFLAGS=-O0 -g
+
+ #
+ # Special rules
+diff -ur a/m4/strict_compile.m4 b/m4/strict_compile.m4
+--- a/m4/strict_compile.m4 2019-07-30 01:13:14.000000000 +0200
++++ b/m4/strict_compile.m4 2020-03-04 21:17:33.394968306 +0100
+@@ -12,7 +12,7 @@
+ ALDOR_CC_OPTION(-Wno-sign-compare,cfg_no_sign_compare)
+ AC_MSG_CHECKING(Strict options for C compiler)
+
+- cfgSTRICTCFLAGS="-pedantic -std=c99 -Wall -Wextra -Werror -Wno-empty-body -Wno-enum-compare \
++ cfgSTRICTCFLAGS="-pedantic -std=c99 -Wall -Wextra -Wno-empty-body -Wno-enum-compare \
+ -Wno-missing-field-initializers -Wno-unused -Wno-unused-parameter \
+ -Wno-error=format -Wno-error=type-limits -Wno-error=strict-aliasing \
+ $cfg_no_sign_compare $cfg_no_shift_negative_value"