aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Roman <davidroman96@gmail.com>2023-12-12 16:01:11 +0100
committerDavid Roman <davidroman96@gmail.com>2023-12-12 16:01:31 +0100
commit0eaa08824bb70907ae286b757b7da14fd2d3966d (patch)
treed776d80ac4aebd487ab3d17657f9f97889490634 /dev-python/PyQt5-stubs
parentmedia-sound/spotify-player: (diff)
downloadguru-0eaa08824bb70907ae286b757b7da14fd2d3966d.tar.gz
guru-0eaa08824bb70907ae286b757b7da14fd2d3966d.tar.bz2
guru-0eaa08824bb70907ae286b757b7da14fd2d3966d.zip
dev-python/PyQt5-stubs: add 5.15.6.0
Signed-off-by: David Roman <davidroman96@gmail.com>
Diffstat (limited to 'dev-python/PyQt5-stubs')
-rw-r--r--dev-python/PyQt5-stubs/Manifest1
-rw-r--r--dev-python/PyQt5-stubs/PyQt5-stubs-5.15.6.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/PyQt5-stubs/Manifest b/dev-python/PyQt5-stubs/Manifest
index c5ff5ea262..ad56a471a4 100644
--- a/dev-python/PyQt5-stubs/Manifest
+++ b/dev-python/PyQt5-stubs/Manifest
@@ -1 +1,2 @@
DIST PyQt5-stubs-5.15.2.0.gh.tar.gz 344714 BLAKE2B 67e07fd5851748fb0f3161f82ccf699a69399da004f16daae3a3bd28c0a5ef49c91d14dfccc9b49d2071a727e3b7cff9540ffdb3c9751a341ed628dbea295010 SHA512 9b33a8f999b12e6cf73277835f72f303b243e33638c4f751ce5f6d5c8c50e30326b505f4235ea2cb09e46004186b92bc3ab320f5143a9899d99767cc0f173314
+DIST PyQt5-stubs-5.15.6.0.gh.tar.gz 496888 BLAKE2B 01c0d8478783fe7ef4e460cb5b5823315dbb389ef29213ce77444fa021b43508a30c125e66d59bd28b017ee0798e7815dd2a8eff86a6ce9bf25fbe0f4274771a SHA512 76c7a94f9f949dd4d9c67fedb74aab2c9246834a6ad99fb28003e35bdad6a262b26051c17180b9a2b511e228a038e5c64ccc9885095c4239740cda339e91801e
diff --git a/dev-python/PyQt5-stubs/PyQt5-stubs-5.15.6.0.ebuild b/dev-python/PyQt5-stubs/PyQt5-stubs-5.15.6.0.ebuild
new file mode 100644
index 0000000000..cd625375de
--- /dev/null
+++ b/dev-python/PyQt5-stubs/PyQt5-stubs-5.15.6.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{11,12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Stubs for PyQt5"
+HOMEPAGE="
+ https://pypi.org/project/PyQt5-stubs/
+ https://github.com/python-qt-tools/PyQt5-stubs
+
+"
+
+# no tests on pypi
+SRC_URI="https://github.com/python-qt-tools/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="test? (
+ dev-python/mypy[${PYTHON_USEDEP}]
+ dev-python/PyQtWebEngine[${PYTHON_USEDEP}]
+ dev-python/PyQt5[${PYTHON_USEDEP},bluetooth,dbus,declarative,designer,location,multimedia,network,opengl,positioning,serialport,sql,svg,widgets]
+ )
+"
+
+distutils_enable_tests pytest