aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMazunki Hoksaas <rolferen@gmail.com>2024-05-14 13:00:21 +0200
committerMazunki Hoksaas <rolferen@gmail.com>2024-05-14 13:00:21 +0200
commitb84bc79ccfc6e835f6fbc220550acc58218c2dbd (patch)
tree0fda65e27d52829025c5baa1be0b3fa1d208f0de /dev-python/latexify-py
parentdev-util/webgpu-headers: add missing dev-lang/go (diff)
downloadguru-b84bc79ccfc6e835f6fbc220550acc58218c2dbd.tar.gz
guru-b84bc79ccfc6e835f6fbc220550acc58218c2dbd.tar.bz2
guru-b84bc79ccfc6e835f6fbc220550acc58218c2dbd.zip
dev-python/*: rename latexify to latexify-py
also addressed some QA issues Signed-off-by: Mazunki Hoksaas <rolferen@gmail.com>
Diffstat (limited to 'dev-python/latexify-py')
-rw-r--r--dev-python/latexify-py/Manifest1
-rw-r--r--dev-python/latexify-py/latexify-py-0.4.3.1.ebuild36
-rw-r--r--dev-python/latexify-py/metadata.xml12
3 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/latexify-py/Manifest b/dev-python/latexify-py/Manifest
new file mode 100644
index 000000000..a570fb803
--- /dev/null
+++ b/dev-python/latexify-py/Manifest
@@ -0,0 +1 @@
+DIST latexify_py-0.4.3-post1.gh.tar.gz 78199 BLAKE2B 2292131c5f9eec51c8cf16812d72823076e61ac66320688ba891dea822bcad240a69e932aa7f6f5af54508b1e770a12bf19ac01c29ccee930e1b976670500ef5 SHA512 0c534368827b9776132a6ff7e2bedd6ca70a097ff6abbb22b87399ae17b3b2f04c171e9fae8ecc00103e0f90e367b57c4e832ecbeffad44a9e82a09495ffbaaa
diff --git a/dev-python/latexify-py/latexify-py-0.4.3.1.ebuild b/dev-python/latexify-py/latexify-py-0.4.3.1.ebuild
new file mode 100644
index 000000000..0233d970c
--- /dev/null
+++ b/dev-python/latexify-py/latexify-py-0.4.3.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} pypy3 ) # upstream supports >=3.7 to <3.12
+DISTUTILS_USE_PEP517=hatchling
+
+inherit distutils-r1
+
+DESCRIPTION="Annotate Python source code to get LaTeX expressions"
+HOMEPAGE="
+ https://pypi.org/project/latexify-py/
+ https://github.com/google/latexify_py
+"
+
+# upstream package is called latexify-py (on pypi), but their filename is called latexify_py
+# we're using $(ver_cut 1-3) because of this specific postfix version, akin to -r1. remove in next versions
+SRC_URI="https://github.com/google/latexify_py/archive/refs/tags/v$(ver_cut 1-3)-post1.tar.gz -> ${PN/-/_}-$(ver_cut 1-3)-post1.gh.tar.gz"
+S="${WORKDIR}/${PN/-/_}-$(ver_cut 1-3)-post1"
+
+LICENSE="Apache-2.0"
+SLOT=0
+KEYWORDS="~amd64"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-python/dill[${PYTHON_USEDEP}]
+"
+DEPEND="${PYTHON_DEPS}"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+}
diff --git a/dev-python/latexify-py/metadata.xml b/dev-python/latexify-py/metadata.xml
new file mode 100644
index 000000000..47da14ac9
--- /dev/null
+++ b/dev-python/latexify-py/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>rolferen@gmail.com</email>
+ <name>Mazunki Hoksaas</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">google/latexify_py</remote-id>
+ <remote-id type="pypi">latexify-py</remote-id>
+ </upstream>
+</pkgmetadata>