aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-05-07 13:33:50 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-05-07 13:33:50 +0200
commit337ce667063fde6e4c8d56879de57721301cf080 (patch)
tree8b90d1e2ff14cb08281c564880dc2782f3f28fe9 /dev-python/pytest-celery
parentdev-python/sphinx-click: fix doc build (diff)
downloadguru-337ce667063fde6e4c8d56879de57721301cf080.tar.gz
guru-337ce667063fde6e4c8d56879de57721301cf080.tar.bz2
guru-337ce667063fde6e4c8d56879de57721301cf080.zip
dev-python/pytest-celery: initial import
Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
Diffstat (limited to 'dev-python/pytest-celery')
-rw-r--r--dev-python/pytest-celery/Manifest1
-rw-r--r--dev-python/pytest-celery/metadata.xml12
-rw-r--r--dev-python/pytest-celery/pytest-celery-0.0.0_alpha1.ebuild27
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/pytest-celery/Manifest b/dev-python/pytest-celery/Manifest
new file mode 100644
index 000000000..a9af4a3bd
--- /dev/null
+++ b/dev-python/pytest-celery/Manifest
@@ -0,0 +1 @@
+DIST pytest-celery-0.0.0a1.tar.gz 3005 BLAKE2B 31c2c825f8821eb56eff92d709cde20d306f673b0760326953de141321af7a040dce849728f8556059e438622d2b0969cbcf14f33e4d28bfa213a9babc92d997 SHA512 ea8ef26aaa5dd5c04608cb01bedb4946bb6712d08203e5f9b1b9b2b1a9e49e7a550466d7a9dd896fb5d813960cee35eed139099952589cdf21e03dadd7e2a20f
diff --git a/dev-python/pytest-celery/metadata.xml b/dev-python/pytest-celery/metadata.xml
new file mode 100644
index 000000000..96e702a5b
--- /dev/null
+++ b/dev-python/pytest-celery/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>lssndrbarbieri@gmail.com</email>
+ <name>Alessandro Barbieri</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">celery/pytest-celery</remote-id>
+ <remote-id type="pypi">celery</remote-id>
+ </upstream>
+</pkgmetadata> \ No newline at end of file
diff --git a/dev-python/pytest-celery/pytest-celery-0.0.0_alpha1.ebuild b/dev-python/pytest-celery/pytest-celery-0.0.0_alpha1.ebuild
new file mode 100644
index 000000000..9bb2a3b80
--- /dev/null
+++ b/dev-python/pytest-celery/pytest-celery-0.0.0_alpha1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+MYPV="${PV/_alpha/a}"
+MYP="${PN}-${MYPV}"
+
+PYTHON_COMPAT=( python3_{7,8} )
+DISTUTILS_USE_SETUPTOOLS=no
+
+inherit distutils-r1
+
+DESCRIPTION="a shim pytest plugin to enable celery.contrib.pytest"
+HOMEPAGE="
+ https://github.com/celery/pytest-celery
+ https://pypi.org/project/pytest-celery
+"
+SRC_URI="mirror://pypi/${MYP:0:1}/${PN}/${MYP}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND=">=dev-python/celery-4.4.0[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MYP}"