aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTakuya Wakazono <pastalian46@gmail.com>2024-09-07 21:54:55 +0900
committerTakuya Wakazono <pastalian46@gmail.com>2024-09-07 21:54:55 +0900
commita9bd6dc925352f3f098c4db102d0697780de8cd7 (patch)
tree08b428e681d17fcbaeea2373a77a4c6048b41051 /dev-python
parentapp-containers/nvidia-container-toolkit: fix 9999 ebuild (diff)
downloadguru-a9bd6dc925352f3f098c4db102d0697780de8cd7.tar.gz
guru-a9bd6dc925352f3f098c4db102d0697780de8cd7.tar.bz2
guru-a9bd6dc925352f3f098c4db102d0697780de8cd7.zip
dev-python/http-ece: enable py3.13
Signed-off-by: Takuya Wakazono <pastalian46@gmail.com>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/http-ece/http-ece-1.2.1.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/dev-python/http-ece/http-ece-1.2.1.ebuild b/dev-python/http-ece/http-ece-1.2.1.ebuild
index e121e8bc5..1c1d35790 100644
--- a/dev-python/http-ece/http-ece-1.2.1.ebuild
+++ b/dev-python/http-ece/http-ece-1.2.1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( python3_{10..13} )
DISTUTILS_USE_PEP517=setuptools
# TODO re-enable pypi when it is available on there
# <https://github.com/web-push-libs/encrypted-content-encoding/issues/79>
@@ -24,6 +24,8 @@ KEYWORDS="~amd64"
RDEPEND="dev-python/cryptography[${PYTHON_USEDEP}]"
-RESTRICT="test" # tests seem to be broken, further investigation advised
-
distutils_enable_tests pytest
+
+python_test() {
+ epytest -o addopts=
+}