aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLucio Sauer <watermanpaint@posteo.net>2024-04-28 01:18:34 +0200
committerJulien Roy <julien@jroy.ca>2024-05-13 18:18:20 -0400
commitd6ae7d0c076c6f3e25baddcc28d31b6e7b05f5cc (patch)
tree33de9196b9bf108bf4da7606b99327ba2c5f1af9 /games-engines
parentdev-vcs/*: fix variable order (diff)
downloadguru-d6ae7d0c076c6f3e25baddcc28d31b6e7b05f5cc.tar.gz
guru-d6ae7d0c076c6f3e25baddcc28d31b6e7b05f5cc.tar.bz2
guru-d6ae7d0c076c6f3e25baddcc28d31b6e7b05f5cc.zip
games-*/*: fix variable order
I manually went through some entries for `pkgcheck scan -c VariableOrderCheck`. Misc updates: UnusedEclassesCheck RESTRICT+=" .." -> RESTRICT=".." Signed-off-by: Lucio Sauer <watermanpaint@posteo.net> Signed-off-by: Julien Roy <julien@jroy.ca>
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/fs2_open/fs2_open-23.0.0.ebuild9
-rw-r--r--games-engines/fs2_open/fs2_open-23.2.1-r1.ebuild9
-rw-r--r--games-engines/luxtorpeda/luxtorpeda-25.0.0.ebuild12
-rw-r--r--games-engines/nxengine-evo/nxengine-evo-2.6.4.ebuild2
-rw-r--r--games-engines/nxengine-evo/nxengine-evo-2.6.5_p1.ebuild7
5 files changed, 19 insertions, 20 deletions
diff --git a/games-engines/fs2_open/fs2_open-23.0.0.ebuild b/games-engines/fs2_open/fs2_open-23.0.0.ebuild
index 582e2abab..35e94af61 100644
--- a/games-engines/fs2_open/fs2_open-23.0.0.ebuild
+++ b/games-engines/fs2_open/fs2_open-23.0.0.ebuild
@@ -5,9 +5,6 @@ EAPI=8
inherit cmake
-DESCRIPTION="FreeSpace2 Source Code Project game engine"
-HOMEPAGE="https://github.com/scp-fs2open/fs2open.github.com/"
-
# Replace "." with "_" in version
_PV=${PV//./_}
@@ -15,12 +12,16 @@ _PV=${PV//./_}
HASH_LIBROCKET="ecd648a43aff8a9f3daf064d75ca5725237d5b38"
HASH_CMAKE_MODULES="7cef9577d6fc35057ea57f46b4986a8a28aeff50"
+DESCRIPTION="FreeSpace2 Source Code Project game engine"
+HOMEPAGE="https://github.com/scp-fs2open/fs2open.github.com/"
SRC_URI="
https://github.com/scp-fs2open/fs2open.github.com/archive/refs/tags/release_${_PV}.tar.gz -> ${P}.tar.gz
https://github.com/asarium/libRocket/archive/${HASH_LIBROCKET}.tar.gz -> ${P}-ext_libRocket.tar.gz
https://github.com/asarium/cmake-modules/archive/${HASH_CMAKE_MODULES}.tar.gz -> ${P}-ext_rpavlik-cmake-modules.tar.gz
"
+S="${WORKDIR}/fs2open.github.com-release_${_PV}"
+
LICENSE="Unlicense MIT Boost-1.0"
SLOT="0"
KEYWORDS="~amd64"
@@ -50,8 +51,6 @@ PATCHES=(
CMAKE_BUILD_TYPE=Release
-S="${WORKDIR}/fs2open.github.com-release_${_PV}"
-
src_unpack() {
unpack ${A}
mv libRocket-${HASH_LIBROCKET}/* "${S}/lib/libRocket/" || die
diff --git a/games-engines/fs2_open/fs2_open-23.2.1-r1.ebuild b/games-engines/fs2_open/fs2_open-23.2.1-r1.ebuild
index 4b10b9698..0b437cf5b 100644
--- a/games-engines/fs2_open/fs2_open-23.2.1-r1.ebuild
+++ b/games-engines/fs2_open/fs2_open-23.2.1-r1.ebuild
@@ -5,9 +5,6 @@ EAPI=8
inherit cmake
-DESCRIPTION="FreeSpace2 Source Code Project game engine"
-HOMEPAGE="https://github.com/scp-fs2open/fs2open.github.com/"
-
# Replace "." with "_" in version
_PV=${PV//./_}
@@ -15,12 +12,16 @@ _PV=${PV//./_}
HASH_LIBROCKET="ecd648a43aff8a9f3daf064d75ca5725237d5b38"
HASH_CMAKE_MODULES="7cef9577d6fc35057ea57f46b4986a8a28aeff50"
+DESCRIPTION="FreeSpace2 Source Code Project game engine"
+HOMEPAGE="https://github.com/scp-fs2open/fs2open.github.com/"
SRC_URI="
https://github.com/scp-fs2open/fs2open.github.com/archive/refs/tags/release_${_PV}.tar.gz -> ${P}.tar.gz
https://github.com/asarium/libRocket/archive/${HASH_LIBROCKET}.tar.gz -> ${P}-ext_libRocket.tar.gz
https://github.com/asarium/cmake-modules/archive/${HASH_CMAKE_MODULES}.tar.gz -> ${P}-ext_rpavlik-cmake-modules.tar.gz
"
+S="${WORKDIR}/fs2open.github.com-release_${_PV}"
+
LICENSE="Unlicense MIT Boost-1.0"
SLOT="0"
KEYWORDS="~amd64"
@@ -51,8 +52,6 @@ PATCHES=(
CMAKE_BUILD_TYPE=Release
-S="${WORKDIR}/fs2open.github.com-release_${_PV}"
-
src_unpack() {
unpack ${A}
mv libRocket-${HASH_LIBROCKET}/* "${S}/lib/libRocket/" || die
diff --git a/games-engines/luxtorpeda/luxtorpeda-25.0.0.ebuild b/games-engines/luxtorpeda/luxtorpeda-25.0.0.ebuild
index 76840c8e8..d492da17a 100644
--- a/games-engines/luxtorpeda/luxtorpeda-25.0.0.ebuild
+++ b/games-engines/luxtorpeda/luxtorpeda-25.0.0.ebuild
@@ -199,26 +199,26 @@ zip-0.5.6
inherit cargo
-DESCRIPTION="Steam Play compatibility tool to run games using native Linux engines"
-HOMEPAGE="https://luxtorpeda.gitlab.io"
-
MY_PV=$(ver_cut 1)
MY_P="${PN}-${MY_PV}"
+DESCRIPTION="Steam Play compatibility tool to run games using native Linux engines"
+HOMEPAGE="https://luxtorpeda.gitlab.io"
SRC_URI="
https://github.com/luxtorpeda-dev/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz
$(cargo_crate_uris ${CRATES})"
-RESTRICT="mirror"
+
+S="${WORKDIR}/${MY_P}"
LICENSE="GPL-2 BSD Apache-2.0 BSD-2 ISC MIT MPL-2.0 Unlicense"
SLOT="0"
KEYWORDS="~amd64"
+RESTRICT="mirror"
+
BEPEND=">=dev-libs/openssl-1.1.1g"
RDEPEND="${BDEPEND}"
-S="${WORKDIR}/${MY_P}"
-
src_prepare(){
default
sed "s/%name%/${PN}/; s/%display_name%/${PN}/" compatibilitytool.template \
diff --git a/games-engines/nxengine-evo/nxengine-evo-2.6.4.ebuild b/games-engines/nxengine-evo/nxengine-evo-2.6.4.ebuild
index 0018a9e62..d5786e1ab 100644
--- a/games-engines/nxengine-evo/nxengine-evo-2.6.4.ebuild
+++ b/games-engines/nxengine-evo/nxengine-evo-2.6.4.ebuild
@@ -11,8 +11,8 @@ SRC_URI="
https://github.com/nxengine/nxengine-evo/archive/v${PV}.tar.gz -> ${P}.tar.gz
https://www.cavestory.org/downloads/cavestoryen.zip
"
-SLOT="0"
LICENSE="GPL-3"
+SLOT="0"
KEYWORDS="~amd64"
DEPEND="
diff --git a/games-engines/nxengine-evo/nxengine-evo-2.6.5_p1.ebuild b/games-engines/nxengine-evo/nxengine-evo-2.6.5_p1.ebuild
index 428137e71..b92d95978 100644
--- a/games-engines/nxengine-evo/nxengine-evo-2.6.5_p1.ebuild
+++ b/games-engines/nxengine-evo/nxengine-evo-2.6.5_p1.ebuild
@@ -5,18 +5,19 @@ EAPI=8
inherit xdg cmake
+MY_PV="${PV/_p/-}"
+
DESCRIPTION="rewrite of the jump-and-run platformer Doukutsu Monogatari(Cave Story)"
HOMEPAGE="https://github.com/nxengine/nxengine-evo http://nxengine.sourceforge.net/"
-
-MY_PV="${PV/_p/-}"
SRC_URI="
https://github.com/nxengine/nxengine-evo/archive/v${MY_PV}.tar.gz -> ${PN}-${MY_PV}.tar.gz
https://www.cavestory.org/downloads/cavestoryen.zip
"
+
S="${WORKDIR}/${PN}-${MY_PV}"
-SLOT="0"
LICENSE="GPL-3 freedist"
+SLOT="0"
KEYWORDS="~amd64"
DEPEND="