aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPascal Jäger <pascal.jaeger@leimstift.de>2022-05-07 15:12:00 +0200
committerPascal Jäger <pascal.jaeger@leimstift.de>2022-05-07 15:12:00 +0200
commit90ca7ccbd80071e11a37350222c17c7dbd1f4b65 (patch)
treec97a4d1e47b1fa0095368fdcee1ddaa0cb87137e /games-misc
parentdev-hare/hare-iobus: initial import (diff)
downloadguru-90ca7ccbd80071e11a37350222c17c7dbd1f4b65.tar.gz
guru-90ca7ccbd80071e11a37350222c17c7dbd1f4b65.tar.bz2
guru-90ca7ccbd80071e11a37350222c17c7dbd1f4b65.zip
games-misc/an-anime-game-launcher-bin: add 2.3.2
Signed-off-by: Pascal Jäger <pascal.jaeger@leimstift.de>
Diffstat (limited to 'games-misc')
-rw-r--r--games-misc/an-anime-game-launcher-bin/Manifest1
-rw-r--r--games-misc/an-anime-game-launcher-bin/an-anime-game-launcher-bin-2.3.2.ebuild70
-rw-r--r--games-misc/an-anime-game-launcher-bin/files/an-anime-game-launcher-bin-desktop.patch17
-rw-r--r--games-misc/an-anime-game-launcher-bin/files/an-anime-game-launcher-bin-launcher.patch26
-rw-r--r--games-misc/an-anime-game-launcher-bin/files/an-anime-game-launcher-bin.pngbin0 -> 77748 bytes
5 files changed, 114 insertions, 0 deletions
diff --git a/games-misc/an-anime-game-launcher-bin/Manifest b/games-misc/an-anime-game-launcher-bin/Manifest
index 229274391..c784aac81 100644
--- a/games-misc/an-anime-game-launcher-bin/Manifest
+++ b/games-misc/an-anime-game-launcher-bin/Manifest
@@ -1 +1,2 @@
+DIST An_Anime_Game_Launcher.AppImage 4383936 BLAKE2B 978be58595b90be13407275527651a2e9154978337e3b618796247fc402643165222b2e5a0d937ab231c15a943ae6e36469a176ca4d6a43dd4995bb98a2b3fb2 SHA512 63be6095af44f760da982a087a8105cba9f792ffc1af3e363e689ec27038507f92e4bc56a7ec2be92b446dbc3cc8164ceb6183e0b104bee555c7570143532304
DIST aagl-ebuilds-2.3.1.tar.gz 4343632 BLAKE2B ba0f8733328469ad531dd8717f230e9e2f723cc12f185fe0f7035b2308e1f41dc92b9af0112a7787ddaf7ab01ae3c0fd12b2998ca09e1215aa11443a4254d08c SHA512 79672a1e0f0f0e0648db5910a33fc7b33d19c3666eb7eba81741f1d2849f0bdf9c76f0533f881a1ad0408b4b6a17eedf5a78c9c5da894c2c971b8d3a48d72928
diff --git a/games-misc/an-anime-game-launcher-bin/an-anime-game-launcher-bin-2.3.2.ebuild b/games-misc/an-anime-game-launcher-bin/an-anime-game-launcher-bin-2.3.2.ebuild
new file mode 100644
index 000000000..f84e2e347
--- /dev/null
+++ b/games-misc/an-anime-game-launcher-bin/an-anime-game-launcher-bin-2.3.2.ebuild
@@ -0,0 +1,70 @@
+# copyright 1999-2022 gentoo authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils optfeature
+
+DESCRIPTION="Open Source An Anime Game launcher for Linux with automatic anti-cheat patching and telemetry disabling, binary package"
+HOMEPAGE="https://gitlab.com/an-anime-team/an-anime-game-launcher"
+SRC_URI="https://gitlab.com/an-anime-team/an-anime-game-launcher/uploads/003620e21b2d8d70385bac8f2a862846/An_Anime_Game_Launcher.AppImage"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+PATCHES=( "${FILESDIR}/${PN}-launcher.patch" "${FILESDIR}/${PN}-desktop.patch" )
+
+DEPEND="
+ net-libs/webkit-gtk \
+ dev-util/xdelta[lzma] \
+ app-arch/tar \
+ dev-vcs/git \
+ app-arch/unzip \
+ net-misc/curl \
+ app-arch/cabextract \
+ x11-libs/libnotify \
+ sys-auth/polkit \
+ dev-libs/libdbusmenu \
+ app-emulation/dxvk-bin \
+ app-emulation/winetricks \
+ virtual/wine \
+ "
+
+RDEPEND="${DEPEND}"
+
+BDEPEND="app-admin/chrpath"
+
+src_unpack() {
+ mkdir ${WORKDIR}/${P} || die
+ cp ${DISTDIR}/An_Anime_Game_Launcher.AppImage ${WORKDIR}/${P} || die
+}
+
+src_prepare(){
+ chmod +x An_Anime_Game_Launcher.AppImage
+ ./An_Anime_Game_Launcher.AppImage --appimage-extract || die "Extraction Failed"
+ chrpath -d "squashfs-root/public/discord-rpc/discord-rpc" || die "Patching Library Failed"
+ default
+ mv "squashfs-root/AppRun" "${PN}" || die
+ mv "squashfs-root/an-anime-game-launcher.desktop" "${PN}.desktop" || die
+}
+
+src_install(){
+ insinto "/usr/lib/${PN}"
+ doins "squashfs-root/resources.neu"
+ exeinto "/usr/lib/${PN}"
+ doexe "squashfs-root/an-anime-game-launcher"
+ doins -r "squashfs-root/public"
+ insinto "/usr/share/pixmaps"
+ doins "${FILESDIR}/${PN}.png"
+ exeinto "/usr/bin"
+ doexe "${PN}"
+ insinto "/usr/share/applications/"
+ doins "${PN}.desktop"
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ optfeature "Appindicator support" dev-libs/libayatana-appindicator dev-libs/libayatana-appindicator-bin
+}
+pkg_postrm() {
+ xdg_desktop_database_update
+}
diff --git a/games-misc/an-anime-game-launcher-bin/files/an-anime-game-launcher-bin-desktop.patch b/games-misc/an-anime-game-launcher-bin/files/an-anime-game-launcher-bin-desktop.patch
new file mode 100644
index 000000000..229a2acd3
--- /dev/null
+++ b/games-misc/an-anime-game-launcher-bin/files/an-anime-game-launcher-bin-desktop.patch
@@ -0,0 +1,17 @@
+--- a/squashfs-root/an-anime-game-launcher.desktop
++++ b/squashfs-root/an-anime-game-launcher.desktop
+
+3,6c3,4
+< Icon=64x64
+< Exec=AppRun
+< Type=Application
+< Categories=Game;
+---
+> Comment=An Launcher for a specific anime game with auto-patching, discord rpc and time tracking
+> Exec=an-anime-game-launcher-bin
+8c6,8
+< X-AppImage-Version=2.3.2
+---
+> Type=Application
+> Icon=an-anime-game-launcher-bin
+> Categories=Game
diff --git a/games-misc/an-anime-game-launcher-bin/files/an-anime-game-launcher-bin-launcher.patch b/games-misc/an-anime-game-launcher-bin/files/an-anime-game-launcher-bin-launcher.patch
new file mode 100644
index 000000000..046d2f0b1
--- /dev/null
+++ b/games-misc/an-anime-game-launcher-bin/files/an-anime-game-launcher-bin-launcher.patch
@@ -0,0 +1,26 @@
+--- a/squashfs-root/AppRun
++++ b/squashfs-root/AppRun
+
+4,10c4
+< if [ -z "$APPDIR" ] ; then
+< path="$(dirname "$(readlink -f "${THIS}")")"
+< while [[ "$path" != "" && ! -e "$path/$1" ]]; do
+< path=${path%/*}
+< done
+< APPDIR="$path"
+< fi
+---
+> APPDIR="/usr/lib/an-anime-game-launcher-bin"
+14c8
+< export LD_LIBRARY_PATH="${APPDIR}/usr/lib:${LD_LIBRARY_PATH}"
+---
+> export LD_LIBRARY_PATH="/usr/lib:${LD_LIBRARY_PATH}"
+18c12
+< cd "$APPDIR"
+---
+> cd "${APPDIR}"
+20c14
+< exec "$APPDIR/an-anime-game-launcher" $@
+\ No newline at end of file
+---
+> exec "${APPDIR}/an-anime-game-launcher" $@
diff --git a/games-misc/an-anime-game-launcher-bin/files/an-anime-game-launcher-bin.png b/games-misc/an-anime-game-launcher-bin/files/an-anime-game-launcher-bin.png
new file mode 100644
index 000000000..89738cd27
--- /dev/null
+++ b/games-misc/an-anime-game-launcher-bin/files/an-anime-game-launcher-bin.png
Binary files differ