aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Coppens <coppens.matthias.abc@gmail.com>2021-05-15 16:16:31 +0200
committerMatthias Coppens <coppens.matthias.abc@gmail.com>2021-05-15 16:18:23 +0200
commitdaa38a51f459b6f219cea859541fd90533d03eec (patch)
tree9823f29d634dd1fe12cd136673e9ee8e600b45eb /gui-apps/wdisplays
parentapp-editors/visual-studio-code-bin: version bump to 1.56.2 (diff)
downloadguru-daa38a51f459b6f219cea859541fd90533d03eec.tar.gz
guru-daa38a51f459b6f219cea859541fd90533d03eec.tar.bz2
guru-daa38a51f459b6f219cea859541fd90533d03eec.zip
gui-apps/wdisplays: Change upstream developer and version bump to 1.1
The GitHub user account cyclopsian does no longer exist. As pointed out in the referenced bug, there seem to be 2 main forks: one by luispabon and one by artizirk. luispabon stated that they might not want to maintain wdisplays, the artizirk fork has seen some commits and a bug fix release. Closes: https://bugs.gentoo.org/788163 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Matthias Coppens <coppens.matthias.abc@gmail.com>
Diffstat (limited to 'gui-apps/wdisplays')
-rw-r--r--gui-apps/wdisplays/Manifest1
-rw-r--r--gui-apps/wdisplays/metadata.xml4
-rw-r--r--gui-apps/wdisplays/wdisplays-1.0-r3.ebuild8
-rw-r--r--gui-apps/wdisplays/wdisplays-1.1.ebuild35
-rw-r--r--gui-apps/wdisplays/wdisplays-9999.ebuild10
5 files changed, 48 insertions, 10 deletions
diff --git a/gui-apps/wdisplays/Manifest b/gui-apps/wdisplays/Manifest
index 0cb2a7b59..d262b7fd5 100644
--- a/gui-apps/wdisplays/Manifest
+++ b/gui-apps/wdisplays/Manifest
@@ -1 +1,2 @@
DIST wdisplays-1.0.tar.gz 106819 BLAKE2B d8a34ea82b88f99e27b5c42dc2e8bfed2bf69db719617d81d5f2c994e9020d206937e940f57452c99b534ceda241cea570899c7bdc74377009f7aa013e78b638 SHA512 876e883747331cf67d351b7afec963d6d52b6fa3870a57ed147acf898a662fb41407b3e835acc167d32de969d4001dbe8429340849ad09a7f7b8bfdabee61e3e
+DIST wdisplays-1.1.tar.gz 108410 BLAKE2B 438030d835a0b01dc65c9e69ef0019ce53741aa3be63624ffd73d7cd44e37ccb102cbc4aedaa303d7f47267353640072b3de76437f45637abfd2192b612b23ad SHA512 1aabcb4fef1bde1b8f6bb9254804bba39fe5ebdd57ecc62894aca432527be54ead39ece4008f48ddf96a28111fc409fa5a093905c8017b79bb3f6495a0dc264d
diff --git a/gui-apps/wdisplays/metadata.xml b/gui-apps/wdisplays/metadata.xml
index 87001ec02..fe5b065b1 100644
--- a/gui-apps/wdisplays/metadata.xml
+++ b/gui-apps/wdisplays/metadata.xml
@@ -6,7 +6,7 @@
<email>coppens.matthias.abc@gmail.com</email>
</maintainer>
<upstream>
- <bugs-to>https://github.com/cyclopsian/wdisplays/issues</bugs-to>
- <remote-id type="github">cyclopian/wdisplays</remote-id>
+ <bugs-to>https://github.com/artizirk/wdisplays/issues</bugs-to>
+ <remote-id type="github">artizirk/wdisplays</remote-id>
</upstream>
</pkgmetadata>
diff --git a/gui-apps/wdisplays/wdisplays-1.0-r3.ebuild b/gui-apps/wdisplays/wdisplays-1.0-r3.ebuild
index e9c017e2e..a5ac286ac 100644
--- a/gui-apps/wdisplays/wdisplays-1.0-r3.ebuild
+++ b/gui-apps/wdisplays/wdisplays-1.0-r3.ebuild
@@ -6,17 +6,19 @@ EAPI=7
inherit meson xdg
DESCRIPTION="GUI display configurator for wlroots compositors"
-HOMEPAGE="https://cyclopsian.github.io/wdisplays https://github.com/cyclopsian/wdisplays"
+HOMEPAGE="https://github.com/artizirk/wdisplays"
if [[ "${PV}" == 9999 ]]
then
inherit git-r3
- EGIT_REPO_URI="https://github.com/cyclopsian/wdisplays.git"
+ EGIT_REPO_URI="https://github.com/artizirk/wdisplays.git"
else
- SRC_URI="https://github.com/cyclopsian/wdisplays/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/artizirk/wdisplays/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm64 ~x86"
fi
+RESTRICT="mirror test"
+
RDEPEND="
dev-libs/glib
media-libs/libepoxy
diff --git a/gui-apps/wdisplays/wdisplays-1.1.ebuild b/gui-apps/wdisplays/wdisplays-1.1.ebuild
new file mode 100644
index 000000000..030499155
--- /dev/null
+++ b/gui-apps/wdisplays/wdisplays-1.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson xdg
+
+DESCRIPTION="GUI display configurator for wlroots compositors"
+HOMEPAGE="https://github.com/artizirk/wdisplays"
+
+if [[ "${PV}" == 9999 ]]
+then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/artizirk/wdisplays.git"
+else
+ SRC_URI="https://github.com/artizirk/wdisplays/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+RESTRICT="mirror test"
+
+RDEPEND="
+ dev-libs/glib
+ media-libs/libepoxy
+ x11-libs/gtk+:3[wayland]
+ x11-libs/cairo
+ x11-libs/pango
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/wayland-protocols
+"
+
+LICENSE="GPL-3+"
+SLOT="0"
diff --git a/gui-apps/wdisplays/wdisplays-9999.ebuild b/gui-apps/wdisplays/wdisplays-9999.ebuild
index e9c017e2e..030499155 100644
--- a/gui-apps/wdisplays/wdisplays-9999.ebuild
+++ b/gui-apps/wdisplays/wdisplays-9999.ebuild
@@ -6,17 +6,19 @@ EAPI=7
inherit meson xdg
DESCRIPTION="GUI display configurator for wlroots compositors"
-HOMEPAGE="https://cyclopsian.github.io/wdisplays https://github.com/cyclopsian/wdisplays"
+HOMEPAGE="https://github.com/artizirk/wdisplays"
if [[ "${PV}" == 9999 ]]
then
inherit git-r3
- EGIT_REPO_URI="https://github.com/cyclopsian/wdisplays.git"
+ EGIT_REPO_URI="https://github.com/artizirk/wdisplays.git"
else
- SRC_URI="https://github.com/cyclopsian/wdisplays/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/artizirk/wdisplays/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm64 ~x86"
fi
+RESTRICT="mirror test"
+
RDEPEND="
dev-libs/glib
media-libs/libepoxy
@@ -31,5 +33,3 @@ BDEPEND="
LICENSE="GPL-3+"
SLOT="0"
-
-PATCHES=( "${FILESDIR}/${PN}-1.0-pull20.patch" )