aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPascal Jäger <pascal.jaeger@leimstift.de>2024-11-10 16:10:55 +0100
committerPascal Jäger <pascal.jaeger@leimstift.de>2024-11-10 16:17:44 +0100
commit300cd36723d4709a7815b9127c54eda4e9ac0f93 (patch)
tree5b12ddfd9472103df999ed450a2992949a637c8b /gui-apps
parentgui-apps/nwg-dock-hyprland: add 0.3.2 (diff)
downloadguru-300cd36723d4709a7815b9127c54eda4e9ac0f93.tar.gz
guru-300cd36723d4709a7815b9127c54eda4e9ac0f93.tar.bz2
guru-300cd36723d4709a7815b9127c54eda4e9ac0f93.zip
gui-apps/nwg-shell: add 0.5.39
Signed-off-by: Pascal Jäger <pascal.jaeger@leimstift.de>
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/nwg-shell/Manifest1
-rw-r--r--gui-apps/nwg-shell/nwg-shell-0.5.39.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/gui-apps/nwg-shell/Manifest b/gui-apps/nwg-shell/Manifest
index f9df4b84a..2b014d5e1 100644
--- a/gui-apps/nwg-shell/Manifest
+++ b/gui-apps/nwg-shell/Manifest
@@ -1,3 +1,4 @@
DIST nwg-shell-0.5.35.tar.gz 2181827 BLAKE2B cd2969e0deecee1f43bdf25218203cd86a4ce828c24ad3a931d26d191a003c47093c5e919f3bd27ae85f4899ddea316596b066227c7c1edb978a03aae7076ada SHA512 b9a9dea24d8d0b7d1eb77d69fd33a70868de49113a25d79be45411862375ef0968083738b3081496580661997c9793af66bfa09b622b0fab4b90ac68b6d8c04b
DIST nwg-shell-0.5.36.tar.gz 2181809 BLAKE2B d540bf948c9a02a3b880738d04ff7a9581e706bb071c618a0f3a86a4d00c607eb9fe32dba7de0f7338f531c8e600e6a89ddb9ffc5ed9e5ae1ffe9561e2165baf SHA512 2eb5745f70048ce02b5c6e3b08848f0d030e5a8ff16fc3b16caa8fd59b09ccf5009796d4550d2f3dec96339625528e5f5d7dbb5198d529ababef8e37569f5071
DIST nwg-shell-0.5.38.tar.gz 2181241 BLAKE2B 82b6df94cffa324450fb44ab4c9a92dfc3c8bc06d595ff966ee2d6c626215ed87dd1836dc7570af83695aee42a111ddedaa68276b0028c32dccaf9c0becae79c SHA512 b1481c9350cea9c8b51a758e09dff96158eb66e60045866c961b212038ba14f100c1c2547a508df949421b8201ad44c0b4ad2aa4e18d3b751d39a52b561dbe29
+DIST nwg-shell-0.5.39.tar.gz 2181588 BLAKE2B 6ecf866f485aa52dcd58e4655bbc17d2fb542514e53e04684afafd2d3285cec9cd6662de83346cfe3ffabbe54f90f1c8ebd1c718c71a37d704f18b8fcbf898cd SHA512 47a62f18f08cd22f4373cf9d5ef0b8e5df36db43ca767220e50944fc04e2567de054ffbce18ce7af6a16c0af1f40349cddbe7b9bbbfe268d07ea82084b1d309b
diff --git a/gui-apps/nwg-shell/nwg-shell-0.5.39.ebuild b/gui-apps/nwg-shell/nwg-shell-0.5.39.ebuild
new file mode 100644
index 000000000..b2a468557
--- /dev/null
+++ b/gui-apps/nwg-shell/nwg-shell-0.5.39.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{11..12} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="libraries an common functions for the nwg-shell project"
+HOMEPAGE="https://github.com/nwg-piotr/nwg-shell"
+SRC_URI="https://github.com/nwg-piotr/nwg-shell/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ gui-apps/grim
+ gui-apps/swappy
+ gui-apps/slurp
+"
+DEPEND="${RDEPEND}"
+
+python_install_all() {
+ default
+ dobin scripts/*
+}
+
+pkg_postinst() {
+ elog "To install nwg-shell for the current user, run"
+ elog "nwg-shell-installer -w (for sway) or"
+ elog "nwg-shell-installer -w -hypr (for hyprland)"
+}