aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPascal Jäger <pascal.jaeger@leimstift.de>2024-01-12 13:20:14 +0100
committerPascal Jäger <pascal.jaeger@leimstift.de>2024-01-12 13:21:02 +0100
commitf083716f3568017c1330289184b32835e8e88768 (patch)
tree3e2606639ca511f372b0eda89d21c18951ebcb49 /gui-apps
parentgui-apps/nwg-panel: drop 0.9.19 (diff)
downloadguru-f083716f3568017c1330289184b32835e8e88768.tar.gz
guru-f083716f3568017c1330289184b32835e8e88768.tar.bz2
guru-f083716f3568017c1330289184b32835e8e88768.zip
gui-apps/nwg-shell: add 0.5.28
Signed-off-by: Pascal Jäger <pascal.jaeger@leimstift.de>
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/nwg-shell/Manifest1
-rw-r--r--gui-apps/nwg-shell/nwg-shell-0.5.28.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/gui-apps/nwg-shell/Manifest b/gui-apps/nwg-shell/Manifest
index aa1297d2d..0f6a852d6 100644
--- a/gui-apps/nwg-shell/Manifest
+++ b/gui-apps/nwg-shell/Manifest
@@ -1,2 +1,3 @@
DIST nwg-shell-0.5.25.tar.gz 2180844 BLAKE2B defb10b29dbded91603772c91523455028e25241248d7897cdab831504fa4a2fbf176bce38a0d068db8419001bfe91c1f451e5354a7ff9b491265184680b605b SHA512 e5dc2cb919bd29f5b62d01d34b036b3c4efd89c01d07c4012cdb5e7e1b5c4cc1e890444d398093728f4b2c76f55bae6164334da707c5ac623b0a2952599534c6
DIST nwg-shell-0.5.26.tar.gz 2180999 BLAKE2B 1008e34e663875754302c7631573d0d0a5b82a786204739a77744640d5bd2b3dc880b144f39c39b2a90686c6b19b91dcfc072825e5b29bd4c8e631aba486af7d SHA512 aaf9acc0082aa9bb33f92d860c42eb0ce0d78aa3405bfc8bae1180ea0890926f0f348b4a4d6fcfb01812fe947d21deac65a2d2bec7eddf5e895a4b4535bf20ba
+DIST nwg-shell-0.5.28.tar.gz 2180994 BLAKE2B c54e1568846d8bdf44391be0195393ca8d58a2191a0b572d9da2b4f766e91dcf04efd49916afd57df25b9457709a03e1b44d67183faa82d5b3f27a58241784a2 SHA512 4833e0adf43e86e763a44583e09574cf591dee67145f43e96aba833d35dde371387183b8468090aa4521e1f968ab1e9950381ac43a38463d7bb6b609fd8cf308
diff --git a/gui-apps/nwg-shell/nwg-shell-0.5.28.ebuild b/gui-apps/nwg-shell/nwg-shell-0.5.28.ebuild
new file mode 100644
index 000000000..1beb080d1
--- /dev/null
+++ b/gui-apps/nwg-shell/nwg-shell-0.5.28.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+SRC_URI="https://github.com/nwg-piotr/nwg-shell/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="libraries an common functions for the nwg-shell project"
+HOMEPAGE="https://github.com/nwg-piotr/nwg-shell"
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ gui-apps/grim
+ gui-apps/swappy
+ gui-apps/slurp
+"
+DEPEND="${RDEPEND}"
+
+python_install_all() {
+ default
+ dobin scripts/*
+}
+
+pkg_postinst() {
+ elog "To install nwg-shell for the current user, run"
+ elog "nwg-shell-installer -w (for sway) or"
+ elog "nwg-shell-installer -w -hypr (for hyprland)"
+}