aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRemigiusz Micielski <remigiusz.micielski@gmail.com>2023-04-22 11:42:18 +0200
committerRemigiusz Micielski <remigiusz.micielski@gmail.com>2023-04-22 11:45:20 +0200
commit31f45d67fc498ab207fa834219f78c9ed2df97ed (patch)
treef7dacd900967fafac22f6e76d630af41137db45f /gui-libs
parentnet-p2p/feather: version bump (diff)
downloadguru-31f45d67fc498ab207fa834219f78c9ed2df97ed.tar.gz
guru-31f45d67fc498ab207fa834219f78c9ed2df97ed.tar.bz2
guru-31f45d67fc498ab207fa834219f78c9ed2df97ed.zip
gui-libs/xdg-desktop-portal-hyprland: add 0.3.0, update 9999
Signed-off-by: Remigiusz Micielski <remigiusz.micielski@gmail.com>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/xdg-desktop-portal-hyprland/Manifest1
-rw-r--r--gui-libs/xdg-desktop-portal-hyprland/xdg-desktop-portal-hyprland-0.3.0.ebuild73
-rw-r--r--gui-libs/xdg-desktop-portal-hyprland/xdg-desktop-portal-hyprland-9999.ebuild13
3 files changed, 76 insertions, 11 deletions
diff --git a/gui-libs/xdg-desktop-portal-hyprland/Manifest b/gui-libs/xdg-desktop-portal-hyprland/Manifest
index cd38d3838..e161380ae 100644
--- a/gui-libs/xdg-desktop-portal-hyprland/Manifest
+++ b/gui-libs/xdg-desktop-portal-hyprland/Manifest
@@ -2,3 +2,4 @@ DIST hyprland-protocol-0.1.0.tar.gz 6343 BLAKE2B cffa25c1fbac992db9aee57956615c2
DIST hyprland-protocol-0.2.1.tar.gz 6343 BLAKE2B cffa25c1fbac992db9aee57956615c2a5f8a6e90150d86246218e6d346e566a43527f56cab08b07359bd2f56b1e02b741fb0dbb37ec35fbadd22dfdb2006d3b0 SHA512 f8534c0f6562ce3c770ed9c79b8b78504d6f3aa75001c74ecfa5418af939e88a020ca1cef08d20c62e73c764d66452b5ce212a0f0d2e9a3aaba635ee80b142c5
DIST xdg-desktop-hyprland-0.1.0.tar.gz 45350 BLAKE2B 7b0349f3d0ff4708df3068d71deecb675109c905e0cea6fa0724a2645267a70038a54e2a9eb536e6dbc0d0a138071ceb91527e0df91c83cda0b57e3cf3b519d2 SHA512 b8cfda484d5d50c7fae33eb020c101990ceb244bdfebac46c9820267697eae76bb1e6261c1b03d8fb0148eb81c64f01c59eb94171cb87407541d20117fa48f18
DIST xdg-desktop-hyprland-0.2.1.tar.gz 49895 BLAKE2B 2823133cf0253e36b5a8777184ac220e9b7800d8bf2307599b764cb20f9eb5b3600adaf9d29e6b5707eb99aa3d75719c246b95eca30ef261a90c8d82d675a5ae SHA512 38cfae4736f7016cc3bf998963f42ec5e8e61a1954a4509152834fa2ba33fbc88723af9833881f5ab6e89e92edb0f6840b8ca645b7fa3162220864e9a9aa2725
+DIST xdg-desktop-hyprland-0.3.0.tar.gz 50728 BLAKE2B ea139dd5d1f51e004494cdd5eb80b154a95d64dc40100e9f7da99808e9f24018dc1de4e4572906521beb850d22b7fcc4967c63993c274d2c8e550b11e7eb4367 SHA512 f303fd0fb5ea09c7e12b6435f4113d7d5d9bbe0a785f2da9beaf7a6f9184954a53a1ad5be2c865e9e7071f5079223e512038328598ac5a64238c307741aad974
diff --git a/gui-libs/xdg-desktop-portal-hyprland/xdg-desktop-portal-hyprland-0.3.0.ebuild b/gui-libs/xdg-desktop-portal-hyprland/xdg-desktop-portal-hyprland-0.3.0.ebuild
new file mode 100644
index 000000000..2db31ff4d
--- /dev/null
+++ b/gui-libs/xdg-desktop-portal-hyprland/xdg-desktop-portal-hyprland-0.3.0.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="xdg-desktop-portal backend for hyprland"
+HOMEPAGE="https://github.com/hyprwm/xdg-desktop-portal-hyprland"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/hyprwm/xdg-desktop-portal-hyprland.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/hyprwm/xdg-desktop-portal-hyprland/archive/refs/tags/v${PV}.tar.gz \
+ -> xdg-desktop-hyprland-${PV}.tar.gz"
+fi
+
+LICENSE="MIT"
+SLOT="0/9999"
+IUSE="elogind systemd"
+REQUIRED_USE="?? ( elogind systemd )"
+
+DEPEND="
+ >=media-video/pipewire-0.3.41:=
+ dev-libs/inih
+ dev-libs/wayland
+ dev-qt/qtbase
+ dev-qt/qtcore
+ dev-qt/qtgui
+ dev-qt/qtwayland:6
+ dev-qt/qtwidgets
+ media-libs/mesa
+ sys-apps/util-linux
+ x11-libs/libdrm
+ || (
+ systemd? ( >=sys-apps/systemd-237 )
+ elogind? ( >=sys-auth/elogind-237 )
+ sys-libs/basu
+ )
+"
+RDEPEND="
+ ${DEPEND}
+ sys-apps/xdg-desktop-portal
+"
+BDEPEND="
+ >=dev-libs/wayland-protocols-1.24
+ dev-libs/hyprland-protocols
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emasonargs=()
+ if use systemd; then
+ emasonargs+=(-Dsd-bus-provider=libsystemd)
+ elif use elogind; then
+ emasonargs+=(-Dsd-bus-provider=libelogind)
+ else
+ emasonargs+=(-Dsd-bus-provider=basu)
+ fi
+ meson_src_configure
+}
+
+src_compile() {
+ meson_src_compile
+ emake -C hyprland-share-picker all
+}
+
+src_install() {
+ meson_src_install
+ dobin "${S}/hyprland-share-picker/build/hyprland-share-picker"
+}
diff --git a/gui-libs/xdg-desktop-portal-hyprland/xdg-desktop-portal-hyprland-9999.ebuild b/gui-libs/xdg-desktop-portal-hyprland/xdg-desktop-portal-hyprland-9999.ebuild
index 10b789489..2db31ff4d 100644
--- a/gui-libs/xdg-desktop-portal-hyprland/xdg-desktop-portal-hyprland-9999.ebuild
+++ b/gui-libs/xdg-desktop-portal-hyprland/xdg-desktop-portal-hyprland-9999.ebuild
@@ -13,11 +13,8 @@ if [[ ${PV} == 9999 ]]; then
inherit git-r3
else
KEYWORDS="~amd64"
- PROTOCOMMIT=4d29e48433270a2af06b8bc711ca1fe5109746cd
SRC_URI="https://github.com/hyprwm/xdg-desktop-portal-hyprland/archive/refs/tags/v${PV}.tar.gz \
- -> xdg-desktop-hyprland-${PV}.tar.gz
- https://github.com/hyprwm/hyprland-protocols/archive/${PROTOCOMMIT}.tar.gz \
- -> hyprland-protocol-${PV}.tar.gz"
+ -> xdg-desktop-hyprland-${PV}.tar.gz"
fi
LICENSE="MIT"
@@ -49,16 +46,10 @@ RDEPEND="
"
BDEPEND="
>=dev-libs/wayland-protocols-1.24
+ dev-libs/hyprland-protocols
virtual/pkgconfig
"
-src_unpack() {
- default
-
- rmdir "${S}/subprojects/hyprland-protocols"
- mv "${WORKDIR}/hyprland-protocols-${PROTOCOMMIT}" "${S}/subprojects/hyprland-protocols" || die
-}
-
src_configure() {
local emasonargs=()
if use systemd; then