aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Reed <david-gentoo@reedfam.email>2024-04-05 11:19:42 -0700
committerDavid Reed <david-gentoo@reedfam.email>2024-04-05 11:19:42 -0700
commit698c126fd4cadc09472648f82054c2c5ea7e8575 (patch)
treeff294108db174832d65a7bd8e2e712f819ab7a19 /mail-client
parentx11-themes/catppuccin-gtk: add 0.7.2 (diff)
downloadguru-698c126fd4cadc09472648f82054c2c5ea7e8575.tar.gz
guru-698c126fd4cadc09472648f82054c2c5ea7e8575.tar.bz2
guru-698c126fd4cadc09472648f82054c2c5ea7e8575.zip
mail-client/proton-mail-bin: new package, add 5.0.108.1
Signed-off-by: David Reed <david-gentoo@reedfam.email>
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/proton-mail-bin/Manifest1
-rw-r--r--mail-client/proton-mail-bin/proton-mail-bin-5.0.108.1.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/mail-client/proton-mail-bin/Manifest b/mail-client/proton-mail-bin/Manifest
new file mode 100644
index 000000000..1c5947667
--- /dev/null
+++ b/mail-client/proton-mail-bin/Manifest
@@ -0,0 +1 @@
+DIST proton-mail-bin-5.0.108.1.rpm 83046821 BLAKE2B 23f59d4cdd30d1f97a042b058fa79936d1696c37b6b9742f2ce8f838787fc3e048954c1af07387e1f3d920c43666b9edda336ee7d861e8024b77004d8599d641 SHA512 de38e6f11b91ab3ff5e987fe6b14d430a8911ec45b94ed7f95b758cb3d542b73cc0551142e4f94950209fa445bc8fdfd9ac3d13d50aafc183be829a0c01298e2
diff --git a/mail-client/proton-mail-bin/proton-mail-bin-5.0.108.1.ebuild b/mail-client/proton-mail-bin/proton-mail-bin-5.0.108.1.ebuild
new file mode 100644
index 000000000..a497251ac
--- /dev/null
+++ b/mail-client/proton-mail-bin/proton-mail-bin-5.0.108.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit rpm
+
+DESCRIPTION="Beta Client for Proton Mail"
+HOMEPAGE="https://proton.me/mail"
+SRC_URI="https://proton.me/download/mail/linux/ProtonMail-desktop-beta.rpm -> ${P}.rpm"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}"
+
+QA_PREBUILT="opt/lib/.*"
+
+src_install() {
+ into /opt
+ cp -r "${S}"/usr/lib/* "${D}"/opt/proton-mail || die "Failed to copy files to destination directory"
+
+ dosym "../../opt/proton-mail/Proton Mail Beta" "/usr/bin/proton-mail"
+
+ insinto /usr/share
+ doins -r "${S}/usr/share/pixmaps"
+ doins -r "${S}/usr/share/applications"
+
+}