aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYahor Berdnikau <egorr.berd@gmail.com>2022-02-06 21:12:58 +0100
committerYahor Berdnikau <egorr.berd@gmail.com>2022-02-06 21:12:58 +0100
commit0dde665c76279e34423c63e0920b9a8aac492c91 (patch)
tree25adc38c41638dab43d910387065aa4213af0e03 /media-gfx/superslicer
parentmedia-gfx/superslicer: Fix app name for 2.3.57.7 (diff)
downloadguru-0dde665c76279e34423c63e0920b9a8aac492c91.tar.gz
guru-0dde665c76279e34423c63e0920b9a8aac492c91.tar.bz2
guru-0dde665c76279e34423c63e0920b9a8aac492c91.zip
media-gfx/superslicer: Fix app name for 2.3.57.9
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Yahor Berdnikau <egorr.berd@gmail.com>
Diffstat (limited to 'media-gfx/superslicer')
-rw-r--r--media-gfx/superslicer/files/version-suffix-2.3.57.9.patch31
-rw-r--r--media-gfx/superslicer/superslicer-2.3.57.9-r1.ebuild (renamed from media-gfx/superslicer/superslicer-2.3.57.9.ebuild)6
2 files changed, 27 insertions, 10 deletions
diff --git a/media-gfx/superslicer/files/version-suffix-2.3.57.9.patch b/media-gfx/superslicer/files/version-suffix-2.3.57.9.patch
index 0daae037f..bd41db684 100644
--- a/media-gfx/superslicer/files/version-suffix-2.3.57.9.patch
+++ b/media-gfx/superslicer/files/version-suffix-2.3.57.9.patch
@@ -1,11 +1,8 @@
--- a/version.inc
+++ b/version.inc
-@@ -2,11 +2,11 @@
- # (the version numbers are generated by the build script from the git current label)
-
+@@ -4,9 +4,9 @@
# name of the slicer
--set(SLIC3R_APP_NAME "SuperSlicer")
-+set(SLIC3R_APP_NAME "SuperSlicer2.3")
+ set(SLIC3R_APP_NAME "SuperSlicer")
# Key fo the slicer, must only contains ascii chars and no spaces (be valid in all filesystems)
-set(SLIC3R_APP_KEY "SuperSlicer")
+set(SLIC3R_APP_KEY "SuperSlicer2.3")
@@ -15,3 +12,27 @@
# versions
set(SLIC3R_VERSION "2.3.57")
set(SLIC3R_VERSION_FULL "2.3.57.9")
+--- a/src/platform/unix/Gcodeviewer.desktop.in
++++ b/src/platform/unix/Gcodeviewer.desktop.in
+@@ -1,5 +1,5 @@
+ [Desktop Entry]
+-Name=@GCODEVIEWER_APP_NAME@
++Name=@GCODEVIEWER_APP_KEY@
+ Comment=G-code viewer of Slic3r
+ Exec=@SLIC3R_APP_CMD@ --gcodeviewer %F
+ Icon=@GCODEVIEWER_APP_KEY@
+--- a/src/platform/unix/Slic3r.desktop.in
++++ b/src/platform/unix/Slic3r.desktop.in
+@@ -1,5 +1,5 @@
+ [Desktop Entry]
+-Name=@SLIC3R_APP_NAME@
++Name=@SLIC3R_APP_KEY@
+ GenericName=3D Printing Software
+ Comment=G-code generator for 3D printers
+ Icon=@SLIC3R_APP_KEY@
+@@ -10,4 +10,4 @@ MimeType=model/stl;application/vnd.ms-3mfdocument;application/prs.wavefront-obj;
+ Categories=Graphics;3DGraphics;Engineering;
+ Keywords=3D;Printing;Slicer;slice;3D;printer;convert;gcode;stl;obj;amf;SLA
+ StartupNotify=false
+-StartupWMClass=@SLIC3R_APP_KEY@
++StartupWMClass=@SLIC3R_APP_NAME@
diff --git a/media-gfx/superslicer/superslicer-2.3.57.9.ebuild b/media-gfx/superslicer/superslicer-2.3.57.9-r1.ebuild
index 00ff86a24..c16a1f5c7 100644
--- a/media-gfx/superslicer/superslicer-2.3.57.9.ebuild
+++ b/media-gfx/superslicer/superslicer-2.3.57.9-r1.ebuild
@@ -103,11 +103,7 @@ src_install() {
cmake_src_install
if use gui; then
- newicon -s 128 resources/icons/Slic3r_128px.png SuperSli3er_2.3.png
+ newicon -s 128 resources/icons/SuperSlicer2.3_128px.png SuperSlicer2.3.png
dosym superslicer-2.3 /usr/bin/superslicer-2.3-gcodeviewer
- make_desktop_entry superslicer "SuperSlicer 2.3" "SuperSli3er_2.3" "Graphics;3DGraphics;Engineering;" \
- "MimeType=model/stl;application/vnd.ms-3mfdocument;application/prs.wavefront-obj;application/x-amf;" \
- "GenericName=3D Printing Software" \
- "Keywords=3D;Printing;Slicer;slice;3D;printer;convert;gcode;stl;obj;amf;SLA"
fi
}