aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLucio Sauer <watermanpaint@posteo.net>2024-02-25 10:33:33 +0100
committerLucio Sauer <watermanpaint@posteo.net>2024-02-25 10:33:33 +0100
commitd08f6e3b5829120638159c966be2b3fa39420241 (patch)
treec352846d01e6e2fb86a63e14ff81f44e3fe74547 /media-libs
parentmedia-libs/dr_wav: use the edo eclass (diff)
downloadguru-d08f6e3b5829120638159c966be2b3fa39420241.tar.gz
guru-d08f6e3b5829120638159c966be2b3fa39420241.tar.bz2
guru-d08f6e3b5829120638159c966be2b3fa39420241.zip
media-libs/dr_mp3: use the edo eclass
Signed-off-by: Lucio Sauer <watermanpaint@posteo.net>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/dr_mp3/dr_mp3-0.6.38.ebuild10
1 files changed, 4 insertions, 6 deletions
diff --git a/media-libs/dr_mp3/dr_mp3-0.6.38.ebuild b/media-libs/dr_mp3/dr_mp3-0.6.38.ebuild
index 2c7f798e0..224d735f0 100644
--- a/media-libs/dr_mp3/dr_mp3-0.6.38.ebuild
+++ b/media-libs/dr_mp3/dr_mp3-0.6.38.ebuild
@@ -1,9 +1,9 @@
-# Copyright 2023 Gentoo Authors
+# Copyright 2023-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit toolchain-funcs
+inherit edo toolchain-funcs
DESCRIPTION="Single-header MP3 audio decoder library"
HOMEPAGE="https://github.com/mackron/dr_libs/"
@@ -36,9 +36,8 @@ src_compile() {
pushd tests > /dev/null || die
for tcase in ${TESTCASES[@]}; do
- einfo "Compiling test case ${tcase}."
MY_BUILD="${MY_CC} mp3/${tcase} -o bin/${tcase} ${CFLAGS} ${CPPFLAGS}"
- ${MY_BUILD} || die "Build failed: ${MY_BUILD}"
+ edo ${MY_BUILD}
done
popd || die
fi
@@ -47,8 +46,7 @@ src_compile() {
src_test() {
pushd tests > /dev/null || die
for tcase in ${TESTCASES[@]}; do
- einfo "Running test case ${tcase}."
- ./bin/${tcase} || die "Test case ${tcase} failed."
+ edo bin/${tcase}
done
popd || die
}