aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Torokhov <torokhov-s-a@yandex.ru>2020-05-16 20:59:13 +0300
committerSergey Torokhov <torokhov-s-a@yandex.ru>2020-05-16 20:59:13 +0300
commite3317753ad4b7ed0dad425511ec342c12232be01 (patch)
tree502af75cbb4c1e1cd570dabcbe5b00dd245bd840 /media-plugins/qt-heif-image-plugin
parentapp-emulation/dxvk-bin: Version bump 1.7. (diff)
downloadguru-e3317753ad4b7ed0dad425511ec342c12232be01.tar.gz
guru-e3317753ad4b7ed0dad425511ec342c12232be01.tar.bz2
guru-e3317753ad4b7ed0dad425511ec342c12232be01.zip
media-plugins/qt-heif-image-plugin: new package
Informatin from project page: Any application that (directly or indirectly) uses QImageReader to open image files should automatically be able to use this plugin. This has been successfully used with the following: LXImage-Qt nomacs Signed-off-by: Sergey Torokhov <torokhov-s-a@yandex.ru>
Diffstat (limited to 'media-plugins/qt-heif-image-plugin')
-rw-r--r--media-plugins/qt-heif-image-plugin/Manifest1
-rw-r--r--media-plugins/qt-heif-image-plugin/metadata.xml21
-rw-r--r--media-plugins/qt-heif-image-plugin/qt-heif-image-plugin-0.3.3.ebuild22
3 files changed, 44 insertions, 0 deletions
diff --git a/media-plugins/qt-heif-image-plugin/Manifest b/media-plugins/qt-heif-image-plugin/Manifest
new file mode 100644
index 000000000..d0ee8e788
--- /dev/null
+++ b/media-plugins/qt-heif-image-plugin/Manifest
@@ -0,0 +1 @@
+DIST qt-heif-image-plugin-0.3.3.tar.gz 16449 BLAKE2B f304e26ff60d0fbe840a40c3782543f9db17e7f8fd429b93b0de6663d85110cceff1b67bab996ae63cad12ee06608c74ce9c5e180f154e3df8fee2ccdcd849a9 SHA512 ba617d11e73d73dee5220b668918e313b6d856cabc1567b9221ddb2b3d35c4bfefadcd9e4485bdc7c280be104d09c3580e245d9a8f72c9fac397ebe84fe55e2f
diff --git a/media-plugins/qt-heif-image-plugin/metadata.xml b/media-plugins/qt-heif-image-plugin/metadata.xml
new file mode 100644
index 000000000..bcbf5a060
--- /dev/null
+++ b/media-plugins/qt-heif-image-plugin/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>torokhov-s-a@yandex.ru</email>
+ <name>Sergey Torokhov</name>
+ </maintainer>
+ <longdescription>
+ This is a Qt image plugin for HEIF images, wrapping libheif.
+ It enables existing Qt applications to open and save .heic files.
+
+ Any application that (directly or indirectly) uses QImageReader
+ to open image files should automatically be able to use this plugin.
+
+ This has been successfully used with the following:
+ <pkg>media-gfx/lximage-qt</pkg>, <pkg>media-gfx/nomacs</pkg>
+ </longdescription>
+ <upstream>
+ <remote-id type="github">jakar/qt-heif-image-plugin</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-plugins/qt-heif-image-plugin/qt-heif-image-plugin-0.3.3.ebuild b/media-plugins/qt-heif-image-plugin/qt-heif-image-plugin-0.3.3.ebuild
new file mode 100644
index 000000000..a7e32f3cc
--- /dev/null
+++ b/media-plugins/qt-heif-image-plugin/qt-heif-image-plugin-0.3.3.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Qt plugin for HEIF images"
+HOMEPAGE="https://github.com/jakar/qt-heif-image-plugin"
+SRC_URI="https://github.com/jakar/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-qt/qtcore
+ dev-qt/qtgui
+ media-libs/libheif:0/1.6
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"