aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Reva <denis7774@gmail.com>2020-04-26 19:42:08 +0500
committerDenis Reva <denis7774@gmail.com>2020-04-26 19:42:08 +0500
commitc4443419dc57b37ad8373614ef2374f14f8c9a01 (patch)
tree62f79a8a8425c65132f80e2659515d86eab25548 /media-plugins
parentdev-python/pykeepass: implement tests (diff)
downloadguru-c4443419dc57b37ad8373614ef2374f14f8c9a01.tar.gz
guru-c4443419dc57b37ad8373614ef2374f14f8c9a01.tar.bz2
guru-c4443419dc57b37ad8373614ef2374f14f8c9a01.zip
media-plugins/argotlunar-bin: new pkg; VST grane synth
New package Binary version of argotlunar plugin http://mourednik.github.io/argotlunar/ VST grane (re-)synthesizer. Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Denis Reva <denis7774@gmail.com>
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/argotlunar-bin/Manifest1
-rw-r--r--media-plugins/argotlunar-bin/argotlunar-bin-2.06.ebuild40
-rw-r--r--media-plugins/argotlunar-bin/metadata.xml32
3 files changed, 73 insertions, 0 deletions
diff --git a/media-plugins/argotlunar-bin/Manifest b/media-plugins/argotlunar-bin/Manifest
new file mode 100644
index 000000000..0ab39d259
--- /dev/null
+++ b/media-plugins/argotlunar-bin/Manifest
@@ -0,0 +1 @@
+DIST argotlunar-bin-2.06.tar.gz 1942815 BLAKE2B 8466bf708273783b8250ae5a0d2ab676c41d695d97d4cbfada9b6caa4a89bbd1e1f431efe70854e8760839fbc69d9dcf0ad0802679d8ad28202e35e72be322a7 SHA512 bae4ace66573d6bbdc50ae27ab4756cbd2c16afe5269dfe33b72d8de76c7a978895c80fc7c1521834dd8015013bdaeaa3de94fadb2e55d8885be5a0c3dd302cb
diff --git a/media-plugins/argotlunar-bin/argotlunar-bin-2.06.ebuild b/media-plugins/argotlunar-bin/argotlunar-bin-2.06.ebuild
new file mode 100644
index 000000000..9bd74d538
--- /dev/null
+++ b/media-plugins/argotlunar-bin/argotlunar-bin-2.06.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Argotlunar is a sound granulator. Binary Linux VST"
+HOMEPAGE="http://mourednik.github.io/argotlunar/"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+QA_PRESTRIPPED="/usr/lib64/vst/${PN}/argotlunar.so"
+SRC_URI="https://gentoodistfiles.imperium.org.ru/guru/argotlunar-bin-2.06-linux_amd64.tar.gz -> ${P}.tar.gz"
+#It's impossible to obtain package directly from DROPBOX, so I've just uploaded it to my own webserver
+LICENSE="GPL-2"
+
+RDEPEND="sys-libs/glibc
+ x11-libs/libXext
+ x11-libs/libXinerama
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ media-libs/freetype:2
+ media-libs/alsa-lib
+ app-arch/bzip2
+ x11-libs/libxcb
+ sys-libs/zlib
+ media-libs/libpng:0/16
+ dev-libs/libbsd"
+DEPEND="${RDEPEND}"
+S="${WORKDIR}/argotlunar-${PV}-linux_64"
+src_install(){
+ exeinto "/usr/$(get_libdir)/vst/${PN}"
+ doexe argotlunar.so
+ insinto "/usr/$(get_libdir)/vst/${PN}"
+ doins presets.bank
+ if use doc; then
+ dodoc 'argotlunar2-reference.pdf'
+ einfo "Check argotlunar2-reference.pdf into package doc folder"
+ fi
+}
diff --git a/media-plugins/argotlunar-bin/metadata.xml b/media-plugins/argotlunar-bin/metadata.xml
new file mode 100644
index 000000000..a01dd406c
--- /dev/null
+++ b/media-plugins/argotlunar-bin/metadata.xml
@@ -0,0 +1,32 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM 'http://www.gentoo.org/dtd/metadata.dtd'>
+<pkgmetadata>
+ <maintainer type="person">
+ <email>denis7774@gmail.com</email>
+ <name>Denis Reva</name>
+ <description>RarogCmex</description>
+ </maintainer>
+ <longdescription>
+ Argotlunar is a tool for creating surreal transformations of audio streams.
+ Specifically, it is a real-time delay-line granulator.
+ It disintegrates an audio stream into short samples (grains).
+ Each grain can have random settings of amplitude, panning,
+ duration, delay, pitch, glissando, filter and envelope.
+ The output of all grains is mixed together into
+ a stream which can be fed back into the main input.
+
+ Time-related parameters can be synced to the host tempo,
+ for rhythmic and pulsing textures.
+ Pitch-related parameters can be quantized for harmonic and melodic effects.
+ Feedback can create chaotic, densely layered, and distorted sounds.
+
+ Most of the parameters can be correlated. Examples:
+ Filter cut-off correlated with pitch:
+ Higher filter cut-off for grains with higher pitch, and vice versa.
+
+ Grain duration correlated with panning:
+ Grains with shorter duration panned to the center of the stereo
+ field, and grains with longer duration panned wide in the stereo field.
+ Argotlunar is free software. Licensed under the GPL v2.
+ </longdescription>
+</pkgmetadata>