aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonas Frei <freijon@pm.me>2023-09-18 21:06:22 +0200
committerJonas Frei <freijon@pm.me>2023-09-18 21:07:20 +0200
commite719884ad5a0d4c90eed65bf72556b2fa48a2d05 (patch)
tree08b10d3c598811f72ff01886b03cf0cea50fd5e2 /media-sound
parentnet-im/Quaternion: add 0.0.96_beta4. (diff)
downloadguru-e719884ad5a0d4c90eed65bf72556b2fa48a2d05.tar.gz
guru-e719884ad5a0d4c90eed65bf72556b2fa48a2d05.tar.bz2
guru-e719884ad5a0d4c90eed65bf72556b2fa48a2d05.zip
media-sound/dzr: add 230912
Signed-off-by: Jonas Frei <freijon@pm.me>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/dzr/Manifest1
-rw-r--r--media-sound/dzr/dzr-230912.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/media-sound/dzr/Manifest b/media-sound/dzr/Manifest
index 37b8584dd..be0b06685 100644
--- a/media-sound/dzr/Manifest
+++ b/media-sound/dzr/Manifest
@@ -1 +1,2 @@
DIST dzr-230730.tar.gz 8848 BLAKE2B 7551fb961167031f926de6559fca7eb48dae69c40ac1e896cdcdeadd03c4cf3c19ca514a65f77d00a7cfbc52972489baf557f927358fe61947831e2026877264 SHA512 7f011838da380abc736b861abf2d665ba29b1d0f97f9a234d6a3a5b28638494ac7f0a8544af963ce463c5b37f171e1927d45fc453d2bb323599dcd71c4bb3744
+DIST dzr-230912.tar.gz 16813 BLAKE2B 245c04e47625bf6eb2d12c72c89f4af26d8e629081f08b7757b59700b04130a7fe17b80d0e4bcb7c16725ff4c475c5665b7f764f49ebfea604e7b04f8d330205 SHA512 a626d63f38caabb3b8acecdc161b4538c637090fda6facb9464ca1930788700b351119ff26b769a948ab02e7e7263a9bbfa359d40d113749ed7e322f23211189
diff --git a/media-sound/dzr/dzr-230912.ebuild b/media-sound/dzr/dzr-230912.ebuild
new file mode 100644
index 000000000..94371499e
--- /dev/null
+++ b/media-sound/dzr/dzr-230912.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="DZR: the command line deezer.com player"
+HOMEPAGE="https://github.com/yne/dzr"
+SRC_URI="https://github.com/yne/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ app-misc/jq[oniguruma]
+ dev-libs/openssl
+ dev-util/dialog
+ media-video/mpv
+ net-misc/curl
+"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_install() {
+ exeinto /usr/bin
+ doexe dzr
+ doexe dzr-dec
+ doexe dzr-id3
+ doexe dzr-srt
+ doexe dzr-url
+ default
+}
+
+pkg_postinst() {
+ einfo "WARNING: For legal reasons this project"
+ einfo "does not contain the track decryption key."
+ einfo "Please read the following guide first:"
+ einfo "https://github.com/yne/dzr/wiki#find-the-dzr_cbc-key"
+}