aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonas Frei <freijon@pm.me>2023-09-22 05:30:42 +0200
committerJonas Frei <freijon@pm.me>2023-09-22 05:31:13 +0200
commiteb6dbf358b367f009c085a8b754480de6d9aff78 (patch)
tree922d8c450b0c4b86f9258de552c957fc4b1c670c /media-sound
parentnet-im/mautrix-telegram: drop 0.14.0 (diff)
downloadguru-eb6dbf358b367f009c085a8b754480de6d9aff78.tar.gz
guru-eb6dbf358b367f009c085a8b754480de6d9aff78.tar.bz2
guru-eb6dbf358b367f009c085a8b754480de6d9aff78.zip
media-sound/dzr: add 230919
Signed-off-by: Jonas Frei <freijon@pm.me>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/dzr/Manifest1
-rw-r--r--media-sound/dzr/dzr-230919.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/media-sound/dzr/Manifest b/media-sound/dzr/Manifest
index 5d21745b5..036cafafc 100644
--- a/media-sound/dzr/Manifest
+++ b/media-sound/dzr/Manifest
@@ -1 +1,2 @@
DIST dzr-230912.tar.gz 16813 BLAKE2B 245c04e47625bf6eb2d12c72c89f4af26d8e629081f08b7757b59700b04130a7fe17b80d0e4bcb7c16725ff4c475c5665b7f764f49ebfea604e7b04f8d330205 SHA512 a626d63f38caabb3b8acecdc161b4538c637090fda6facb9464ca1930788700b351119ff26b769a948ab02e7e7263a9bbfa359d40d113749ed7e322f23211189
+DIST dzr-230919.tar.gz 16842 BLAKE2B f94c792d6fae8c97ca53388ee555f1648e9b0bd1aa71759068446a11c8a6714131174813bfdf773e98ca6455fbee392610eef74293bb2429a1faa6e888a9c7bc SHA512 5aa6a3eb0d77d20d6d531cd677b980761a9d19e92fa8054079a562a96e0e97d9b8bbff76090de4d3799764a213b83b501aad20da81d372c26b85e0412707e945
diff --git a/media-sound/dzr/dzr-230919.ebuild b/media-sound/dzr/dzr-230919.ebuild
new file mode 100644
index 000000000..94371499e
--- /dev/null
+++ b/media-sound/dzr/dzr-230919.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="DZR: the command line deezer.com player"
+HOMEPAGE="https://github.com/yne/dzr"
+SRC_URI="https://github.com/yne/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ app-misc/jq[oniguruma]
+ dev-libs/openssl
+ dev-util/dialog
+ media-video/mpv
+ net-misc/curl
+"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_install() {
+ exeinto /usr/bin
+ doexe dzr
+ doexe dzr-dec
+ doexe dzr-id3
+ doexe dzr-srt
+ doexe dzr-url
+ default
+}
+
+pkg_postinst() {
+ einfo "WARNING: For legal reasons this project"
+ einfo "does not contain the track decryption key."
+ einfo "Please read the following guide first:"
+ einfo "https://github.com/yne/dzr/wiki#find-the-dzr_cbc-key"
+}