aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorRonny (tastytea) Gutbrod <gentoo@tastytea.de>2021-11-19 19:26:57 +0100
committerRonny (tastytea) Gutbrod <gentoo@tastytea.de>2021-11-19 19:38:14 +0100
commitf9c264eb7581261b266b5d7c69cc142588e20438 (patch)
tree08a147439963be4e651860763144da23039c2057 /net-im
parentsys-apps/fselect: Version bump to 0.7.8 (diff)
downloadguru-f9c264eb7581261b266b5d7c69cc142588e20438.tar.gz
guru-f9c264eb7581261b266b5d7c69cc142588e20438.tar.bz2
guru-f9c264eb7581261b266b5d7c69cc142588e20438.zip
net-im/nheko: Fix dependencies.
Not revbumping because ebuild is not in master yet. Signed-off-by: Ronny (tastytea) Gutbrod <gentoo@tastytea.de>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/nheko/nheko-0.9.0.ebuild15
1 files changed, 11 insertions, 4 deletions
diff --git a/net-im/nheko/nheko-0.9.0.ebuild b/net-im/nheko/nheko-0.9.0.ebuild
index aaff5f4d0..5ab9102a4 100644
--- a/net-im/nheko/nheko-0.9.0.ebuild
+++ b/net-im/nheko/nheko-0.9.0.ebuild
@@ -12,7 +12,7 @@ SRC_URI="https://github.com/Nheko-Reborn/${PN}/archive/v${PV}.tar.gz -> ${P}.tar
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64"
-IUSE="video voip"
+IUSE="X video voip"
REQUIRED_USE="video? ( voip )"
MY_GST_V="1.18"
@@ -26,6 +26,7 @@ RDEPEND="
dev-qt/qtconcurrent:5
dev-qt/qtgraphicaleffects:5
dev-qt/qtgui:5[gif,jpeg,png]
+ dev-qt/qtimageformats
dev-qt/qtmultimedia:5[gstreamer,qml]
dev-qt/qtquickcontrols2:5
dev-qt/qtsvg:5
@@ -39,8 +40,10 @@ RDEPEND="
>=media-libs/gst-plugins-base-${MY_GST_V}[opengl]
>=media-plugins/gst-plugins-meta-${MY_GST_V}[v4l,vpx]
>=media-plugins/gst-plugins-qt5-${MY_GST_V}
- >=media-plugins/gst-plugins-ximagesrc-${MY_GST_V}
- x11-libs/xcb-util-wm
+ X? (
+ >=media-plugins/gst-plugins-ximagesrc-${MY_GST_V}
+ x11-libs/xcb-util-wm
+ )
)
)
"
@@ -53,8 +56,12 @@ BDEPEND="dev-qt/linguist-tools:5"
src_configure() {
local -a mycmakeargs=(
"-DVOIP=$(usex voip)"
- "-DSCREENSHARE_X11=$(usex video)"
)
+ if use video && use X; then
+ mycmakeargs+=("-DSCREENSHARE_X11=yes")
+ else
+ mycmakeargs+=("-DSCREENSHARE_X11=no")
+ fi
cmake_src_configure
}