aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbrettalcox <brettalcox@gmail.com>2024-03-23 20:05:50 -0500
committerbrettalcox <brettalcox@gmail.com>2024-03-23 20:05:50 -0500
commite6477015d3611c3c39c96c2bcd376f7342e98e8f (patch)
treea1f63e6c67b34d875908f62ca7fb26f3eba2ab45 /net-libs/syndication-domination/syndication-domination-1.0-r1.ebuild
parentapp-editors/pulsar-bin: add 1.115.0, drop 1.113.0 (diff)
downloadguru-e6477015d3611c3c39c96c2bcd376f7342e98e8f.tar.gz
guru-e6477015d3611c3c39c96c2bcd376f7342e98e8f.tar.bz2
guru-e6477015d3611c3c39c96c2bcd376f7342e98e8f.zip
net-libs/syndication-domination: 1.0 / 9999 fixup
Signed-off-by: brettalcox <brettalcox@gmail.com>
Diffstat (limited to 'net-libs/syndication-domination/syndication-domination-1.0-r1.ebuild')
-rw-r--r--net-libs/syndication-domination/syndication-domination-1.0-r1.ebuild65
1 files changed, 65 insertions, 0 deletions
diff --git a/net-libs/syndication-domination/syndication-domination-1.0-r1.ebuild b/net-libs/syndication-domination/syndication-domination-1.0-r1.ebuild
new file mode 100644
index 000000000..caaa6164f
--- /dev/null
+++ b/net-libs/syndication-domination/syndication-domination-1.0-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_11 python3_12 )
+
+inherit meson python-single-r1
+
+DESCRIPTION="An RSS/Atom parser, because there's nothing else out there."
+HOMEPAGE="https://gitlab.com/gabmus/syndication-domination"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/gabmus/syndication-domination.git"
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://gitlab.com/gabmus/syndication-domination/-/archive/${PV}/${P}.tar.bz2"
+ #required for gfeeds
+ PATCHES="${FILESDIR}/gfeeds-2.2.0-blueprint-compiler-fix.patch"
+fi
+
+LICENSE="AGPL-3"
+SLOT="0"
+IUSE="debug json-binary +python"
+REQUIRED_USE="
+ python? ( ${PYTHON_REQUIRED_USE} )
+ !python? ( json-binary )
+"
+DEPEND="
+ app-text/htmltidy
+ dev-libs/libfmt
+ dev-libs/pugixml
+ python? (
+ $(python_gen_cond_dep '
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/pybind11[${PYTHON_USEDEP}]
+ ')
+ )
+
+"
+RDEPEND="
+ ${DEPEND}
+ python? ( ${PYTHON_DEPS} )
+"
+BDEPEND=""
+
+src_configure() {
+ EMESON_BUILDTYPE=$(usex debug debug release)
+ local emesonarge=(
+ --prefix=/usr
+ -DHTML_SUPPORT=true
+ $(meson_use python PYTHON_BINDINGS)
+ $(meson_use json-binary TO_JSON_BINARY)
+ )
+ meson_src_configure
+}
+
+src_compile() {
+ meson_src_compile
+}
+
+src_install() {
+ meson_src_install
+}