aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbrettalcox <brettalcox@gmail.com>2023-10-05 11:59:06 -0500
committerbrettalcox <brettalcox@gmail.com>2023-10-05 11:59:06 -0500
commit7db4fe8999d59beb815feb4bc58c5694c0fbe690 (patch)
tree0e06cb6f4beae09963b747625338dab6f1e742b4 /net-libs/syndication-domination/syndication-domination-9999.ebuild
parentprofiles: mask app-misc/pup for removal (diff)
downloadguru-7db4fe8999d59beb815feb4bc58c5694c0fbe690.tar.gz
guru-7db4fe8999d59beb815feb4bc58c5694c0fbe690.tar.bz2
guru-7db4fe8999d59beb815feb4bc58c5694c0fbe690.zip
net-libs/syndication-domination: adding 1.0
additionally, cleaned up the existing ebuild to properly (and conditionally) pull in python, and simplifying existing USE flags Signed-off-by: brettalcox <brettalcox@gmail.com>
Diffstat (limited to 'net-libs/syndication-domination/syndication-domination-9999.ebuild')
-rw-r--r--net-libs/syndication-domination/syndication-domination-9999.ebuild25
1 files changed, 19 insertions, 6 deletions
diff --git a/net-libs/syndication-domination/syndication-domination-9999.ebuild b/net-libs/syndication-domination/syndication-domination-9999.ebuild
index 92791e1b5..8e62e74f7 100644
--- a/net-libs/syndication-domination/syndication-domination-9999.ebuild
+++ b/net-libs/syndication-domination/syndication-domination-9999.ebuild
@@ -3,7 +3,9 @@
EAPI=8
-inherit meson
+PYTHON_COMPAT=( python3_11 )
+
+inherit meson python-single-r1
DESCRIPTION="An RSS/Atom parser, because there's nothing else out there."
HOMEPAGE="https://gitlab.com/gabmus/syndication-domination"
@@ -13,25 +15,36 @@ if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://gitlab.com/gabmus/syndication-domination.git"
else
KEYWORDS="~amd64"
- SRC_URI="https://gitlab.com/gabmus/syndication-domination/-/archive/${PV}/${P}.tar.bz2"
+ SRC_URI="
+ https://gitlab.com/gabmus/syndication-domination/-/archive/${PV}/${P}.tar.bz2
+ https://gitlab.com/gabmus/syndication-domination/-/commit/75920321.patch
+ "
+ #required for gfeeds
+ PATCHES="${DISTDIR}/75920321.patch"
fi
LICENSE="AGPL-3"
SLOT="0"
IUSE="debug json-binary +python"
REQUIRED_USE="
- ^^ ( python json-binary )
+ python? ( ${PYTHON_REQUIRED_USE} )
+ !python? ( json-binary )
"
DEPEND="
app-text/htmltidy
dev-libs/libfmt
dev-libs/pugixml
python? (
- >=dev-lang/python-3.11
- dev-python/pybind11
+ $(python_gen_cond_dep '
+ dev-python/cython[${PYTHON_USEDEP}]
+ ')
)
+
+"
+RDEPEND="
+ ${DEPEND}
+ python? ( ${PYTHON_DEPS} )
"
-RDEPEND="${DEPEND}"
BDEPEND=""
src_configure() {