aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2021-05-09 07:58:16 -0400
committerAisha Tammy <gentoo@aisha.cc>2021-05-09 08:09:34 -0400
commit835fcaa403c4a2d86d4fac4a3b312d87b1049bfa (patch)
treea36a8c9a374265d0e9ef1e332ed2971f5dc0e0d8 /net-libs
parentdev-lang/gleam: Bump to 0.15.1 (diff)
downloadguru-835fcaa403c4a2d86d4fac4a3b312d87b1049bfa.tar.gz
guru-835fcaa403c4a2d86d4fac4a3b312d87b1049bfa.tar.bz2
guru-835fcaa403c4a2d86d4fac4a3b312d87b1049bfa.zip
net-libs/usockets: rename pkgconfig file
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Aisha Tammy <gentoo@aisha.cc>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/usockets/files/usockets-0.7.1-Makefile.patch10
-rw-r--r--net-libs/usockets/usockets-0.7.1_p20210214-r1.ebuild (renamed from net-libs/usockets/usockets-0.7.1_p20210214.ebuild)0
2 files changed, 5 insertions, 5 deletions
diff --git a/net-libs/usockets/files/usockets-0.7.1-Makefile.patch b/net-libs/usockets/files/usockets-0.7.1-Makefile.patch
index 4d3d2045e..f1ed03b5a 100644
--- a/net-libs/usockets/files/usockets-0.7.1-Makefile.patch
+++ b/net-libs/usockets/files/usockets-0.7.1-Makefile.patch
@@ -1,5 +1,5 @@
diff --git a/Makefile b/Makefile
-index 9b54cac..c31e575 100644
+index 9b54cac..a610bcc 100644
--- a/Makefile
+++ b/Makefile
@@ -1,60 +1,59 @@
@@ -86,7 +86,7 @@ index 9b54cac..c31e575 100644
+ $(AR) rvs libusockets.a *.o
+ $(CC) -shared -o $(LIBTARGET) *.o -Wl,-soname,$(LIBTARGET) `$(PKG_CONFIG) --libs $(REQUIRES)` $(LDFLAGS)
+ sed -e "s:@PREFIX@:$(prefix):" -e "s:@REQUIRES@:$(REQUIRES):" \
-+ -e "s:@LIB@:$(LIB):" -e "s:@VERSION@:$(VERSION):" libusockets.pc.in > libusockets.pc
++ -e "s:@LIB@:$(LIB):" -e "s:@VERSION@:$(VERSION):" usockets.pc.in > usockets.pc
+
+install:
+ install -d "$(DESTDIR)$(libdir)/pkgconfig" "$(DESTDIR)$(includedir)"
@@ -94,7 +94,7 @@ index 9b54cac..c31e575 100644
+ install -m 755 $(LIBTARGET) "$(DESTDIR)$(libdir)"
+ ln -sf $(LIBTARGET) "$(DESTDIR)$(libdir)/libusockets.so"
+ install -m 755 libusockets.a "$(DESTDIR)$(libdir)/"
-+ install -m 644 libusockets.pc "$(DESTDIR)$(libdir)/pkgconfig/"
++ install -m 644 usockets.pc "$(DESTDIR)$(libdir)/pkgconfig/"
clean:
rm -f *.o
@@ -104,11 +104,11 @@ index 9b54cac..c31e575 100644
+ rm -f libusockets.pc
+
+.PHONY: default install clean
-diff --git a/libusockets.pc.in b/libusockets.pc.in
+diff --git a/usockets.pc.in b/usockets.pc.in
new file mode 100644
index 0000000..b818020
--- /dev/null
-+++ b/libusockets.pc.in
++++ b/usockets.pc.in
@@ -0,0 +1,12 @@
+prefix=@PREFIX@
+libdir=${prefix}/@LIB@
diff --git a/net-libs/usockets/usockets-0.7.1_p20210214.ebuild b/net-libs/usockets/usockets-0.7.1_p20210214-r1.ebuild
index d7d107c8c..d7d107c8c 100644
--- a/net-libs/usockets/usockets-0.7.1_p20210214.ebuild
+++ b/net-libs/usockets/usockets-0.7.1_p20210214-r1.ebuild