aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2024-05-10 00:42:10 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2024-05-10 00:42:14 +0500
commitd7b9ce2b9a6dcb2a413110664de1d08bbf4f3bfe (patch)
treee2dcf1d66c40f208a15ab80dc35a83c401666b20 /net-libs
parentvirtual/MASS: treeclean (diff)
downloadguru-d7b9ce2b9a6dcb2a413110664de1d08bbf4f3bfe.tar.gz
guru-d7b9ce2b9a6dcb2a413110664de1d08bbf4f3bfe.tar.bz2
guru-d7b9ce2b9a6dcb2a413110664de1d08bbf4f3bfe.zip
net-libs/sofia-sip: new package, add 1.13.17
Removed from ::gentoo but we need it here for GNOME Calls. SeeAlso: https://github.com/gentoo/gentoo/pull/35243 Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/sofia-sip/Manifest1
-rw-r--r--net-libs/sofia-sip/metadata.xml17
-rw-r--r--net-libs/sofia-sip/sofia-sip-1.13.17.ebuild114
3 files changed, 132 insertions, 0 deletions
diff --git a/net-libs/sofia-sip/Manifest b/net-libs/sofia-sip/Manifest
new file mode 100644
index 000000000..3c4c7f036
--- /dev/null
+++ b/net-libs/sofia-sip/Manifest
@@ -0,0 +1 @@
+DIST sofia-sip-1.13.17.tar.gz 2553674 BLAKE2B 4a59ac3be32b9d22d930ab98f5079d18edf3cae62095f11efebefc84ca22c15a0f02d0a436a62db6292c796b51c661e988b60f55cbd5084c7682b1f8cd34891a SHA512 356577d415d6dc4191f0f49f7fa1d6f33fafdb9e455556f83e091159055a215fc1ebfa9c7dc23b5f5e533b85e23afa7b1444170419fdf137aeb2ea048de77e08
diff --git a/net-libs/sofia-sip/metadata.xml b/net-libs/sofia-sip/metadata.xml
new file mode 100644
index 000000000..b88e46e07
--- /dev/null
+++ b/net-libs/sofia-sip/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>cyber+gentoo@sysrq.in</email>
+ <name>Anna</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">freeswitch/sofia-sip</remote-id>
+ </upstream>
+ <use>
+ <flag name="glib">
+ Add support to <pkg>dev-libs/glib</pkg>-based mainloop, to allow
+ using Sofia-SIP on glib-based programs.
+ </flag>
+ </use>
+</pkgmetadata>
diff --git a/net-libs/sofia-sip/sofia-sip-1.13.17.ebuild b/net-libs/sofia-sip/sofia-sip-1.13.17.ebuild
new file mode 100644
index 000000000..d0bcba438
--- /dev/null
+++ b/net-libs/sofia-sip/sofia-sip-1.13.17.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="RFC3261 compliant SIP User-Agent library"
+HOMEPAGE="https://github.com/freeswitch/sofia-sip"
+SRC_URI="https://github.com/freeswitch/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1+ BSD public-domain" # See COPYRIGHT
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-linux"
+IUSE="debug doc +glib test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/openssl:=
+ sys-libs/zlib:=
+ glib? ( dev-libs/glib:2 )
+"
+DEPEND="${RDEPEND}
+ test? ( dev-libs/check )
+"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-text/doxygen[dot] )
+"
+
+DOCS=(
+ AUTHORS
+ ChangeLog{,.ext-trees}
+ README{,.developers}
+ RELEASE
+ SECURITY.md
+ TODO
+ docs/.
+)
+
+src_prepare() {
+ local -a TESTS_DESELECT=(
+ # Avoid tests that make too many assumptions about the
+ # networking environment, bug 915904
+ libsofia-sip-ua/sresolv:run_test_sresolv
+ libsofia-sip-ua/nta:run_test_nta
+ libsofia-sip-ua/nta:run_check_nta
+ libsofia-sip-ua/nua:check_nua
+ libsofia-sip-ua-glib/su-glib:torture_su_glib_timer
+ libsofia-sip-ua-glib/su-glib:su_source_test
+ tests:check_sofia
+ tests:test_nua
+ )
+
+ local testname filename
+ for deselect in "${TESTS_DESELECT[@]}"; do
+ filename="${deselect%%:*}/Makefile.am"
+ testname=${deselect#*:}
+ sed -i -e "/TESTS/,$ s/\<${testname:?}\>//" "${filename:?}" || die
+ done
+
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ # Makes otherwise working tests fail.
+ ac_cv_tagstack=no
+
+ # 'nth' depends on openssl (bug 851546, 880451) and can't be flipped off
+ # without breaking API and ABI, so it should always be enabled.
+ --enable-nth
+ --with-openssl
+
+ # ABI-breaking, cannot be controlled via USE-flags
+ --disable-experimental
+ --disable-sctp
+
+ $(use_enable !debug ndebug)
+ $(use_with doc doxygen)
+ $(use_with glib)
+ )
+ econf "${myeconfargs[@]}"
+
+ SOFIA_MAKEARGS=(
+ # Make build logs verbose
+ SOFIA_SILENT=
+ VERBOSE=1
+ # Prevent "/bin/sh /bin/sh" (bug 920903)
+ TESTS_ENVIRONMENT=
+ )
+}
+
+src_compile() {
+ emake "${SOFIA_MAKEARGS[@]}"
+
+ if use doc; then
+ emake -C libsofia-sip-ua "${SOFIA_MAKEARGS[@]}" doxygen
+ HTML_DOCS=( libsofia-sip-ua/docs/html/. )
+ fi
+}
+
+src_test() {
+ local -x SOFIA_DEBUG=9
+ emake "${SOFIA_MAKEARGS[@]}" check
+}
+
+src_install() {
+ emake DESTDIR="${D}" "${SOFIA_MAKEARGS[@]}" install
+ einstalldocs
+
+ find "${ED}" -name '*.la' -delete || die
+}