aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilippe Chaintreuil <gentoo_bugs_peep@parallaxshift.com>2024-04-01 08:57:48 -0400
committerPhilippe Chaintreuil <gentoo_bugs_peep@parallaxshift.com>2024-04-01 08:57:48 -0400
commit60d8beba1786953d017e01d21662832a2880ab8b (patch)
tree0c56b0310c12349ab7cd619a7f07ec6f52f3cecc /net-mail/dovecot-fts-xapian
parentdev-python/tweepy: disable tests (diff)
downloadguru-60d8beba1786953d017e01d21662832a2880ab8b.tar.gz
guru-60d8beba1786953d017e01d21662832a2880ab8b.tar.bz2
guru-60d8beba1786953d017e01d21662832a2880ab8b.zip
net-mail/dovecot-fts-xapian: add 1.7.10
Signed-off-by: Philippe Chaintreuil <gentoo_bugs_peep@parallaxshift.com>
Diffstat (limited to 'net-mail/dovecot-fts-xapian')
-rw-r--r--net-mail/dovecot-fts-xapian/Manifest1
-rw-r--r--net-mail/dovecot-fts-xapian/dovecot-fts-xapian-1.7.10.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/net-mail/dovecot-fts-xapian/Manifest b/net-mail/dovecot-fts-xapian/Manifest
index d85ca5a3b..1397d7031 100644
--- a/net-mail/dovecot-fts-xapian/Manifest
+++ b/net-mail/dovecot-fts-xapian/Manifest
@@ -1,3 +1,4 @@
DIST dovecot-fts-xapian-1.5.9.tar.gz 34220 BLAKE2B 8cf0772122d5dd8cf25fa2e8a5c02c8a315fdf4fbd346db3d01e78aa3e1116d42fbf30c155a364e064bd2ea4e9b67a48a69b3a3dada2c471c550f1d4fabbc8bd SHA512 e5961e5f6aeed6efabf456487307dfd09e255077e8c2c3af6c390b73b48dd2613f09ad4dfcd64974a91463a05a55078edfb7368d8c01ce0a839847823507b91f
+DIST dovecot-fts-xapian-1.7.10.tar.gz 36886 BLAKE2B 0e4800f276fc9e8284e54e530127ff06ee1b086d0710042d0e8622034ee7b03f900f8a02be50ab2a31b184cbea9bb22224a3c585a13d67abd7606c26e6819329 SHA512 3844233fd6c0de6d1b7c13e116fc82157324dfc799fcabc766b860c270448a624263533f142566748a4bab2aa1043b3030d7f4795afd4046f10c2a41970cf250
DIST dovecot-fts-xapian-1.7.6.tar.gz 36626 BLAKE2B 4112204e78fce042a4db5e6d3bd5d12e2ca6be8199ded4f7b3b7e0ff9977268491aa7e524f00103e1ee07d5ce0b59dcea171c5be19c7857dbeae9416c4fe984e SHA512 83b25bae097fceb56b62355cd8e10788bea850c2f312eb15fca72fb9c1d033d54e56c251eb27eeb971fe405da9d6a3509a3a700bbd0602d785949548ac15ba1f
DIST dovecot-fts-xapian-1.7.9.tar.gz 36884 BLAKE2B 6e2520a7b8a8250caa2a92af15e6eecdfbdbb542ff439e91baa0c084b3a6f6b02918decd0e0f0d888aba4db54b9566d63a796385a4d56970b69035845e20f84a SHA512 9df23186648902c9ca38f861496bff3e00005096be960a138b7d20eb3baff2734e16949614d1207cce34f2d6626634f58b35ea2c0500e2981f05eea1ad9da718
diff --git a/net-mail/dovecot-fts-xapian/dovecot-fts-xapian-1.7.10.ebuild b/net-mail/dovecot-fts-xapian/dovecot-fts-xapian-1.7.10.ebuild
new file mode 100644
index 000000000..9e8a22927
--- /dev/null
+++ b/net-mail/dovecot-fts-xapian/dovecot-fts-xapian-1.7.10.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Dovecot FTS plugin backed by Xapian"
+HOMEPAGE="https://github.com/grosjo/fts-xapian"
+SRC_URI="https://github.com/grosjo/fts-xapian/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/fts-xapian-${PV}"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="static-libs"
+
+RDEPEND="
+ dev-libs/icu:=
+ >=dev-libs/xapian-1.4:=
+ net-mail/dovecot:=
+ "
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ ${FILESDIR}/bug-887887_allow-O2-override.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # Disable hardening so CFLAGS are left up to the Gentoo user
+ # https://bugs.gentoo.org/888751
+ econf \
+ --enable-hardening=no \
+ --with-dovecot="${EPREFIX}/usr/$(get_libdir)/dovecot" \
+ $( use_enable static-libs static )
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}