aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2023-03-14 07:57:09 +0200
committerViorel Munteanu <ceamac@gentoo.org>2023-03-14 07:57:09 +0200
commit5ed9507b7df4b3c2ffc5346699f7bbc362053e65 (patch)
treeb094313ff6424fecb5393fdf5aaa01cb4497d38a /net-misc/maestral
parentnet-wireless/rtl8192eu: Add support 6.2 kernel (diff)
downloadguru-5ed9507b7df4b3c2ffc5346699f7bbc362053e65.tar.gz
guru-5ed9507b7df4b3c2ffc5346699f7bbc362053e65.tar.bz2
guru-5ed9507b7df4b3c2ffc5346699f7bbc362053e65.zip
net-misc/maestral: add 1.7.2_rc0
Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'net-misc/maestral')
-rw-r--r--net-misc/maestral/Manifest1
-rw-r--r--net-misc/maestral/maestral-1.7.2_rc0.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/net-misc/maestral/Manifest b/net-misc/maestral/Manifest
index e1c66abea..8eb6b280b 100644
--- a/net-misc/maestral/Manifest
+++ b/net-misc/maestral/Manifest
@@ -1,2 +1,3 @@
DIST maestral-1.5.3.gh.tar.gz 8280040 BLAKE2B dcda43880cea3fb00098b6bf87e43318a523a7c9d83886efff58be715cde17f67504b31735a006b951963e5cf0ef70b4b6431cb84200722cae186053a01edd63 SHA512 aa21277623f4e6f3283cd989be910eeb1caa3a842abca595b27a551c1c9bd1e7ef083e495ee0f096190accd91835939cb2f4a26624feae0046d8770d53aaac2f
DIST maestral-1.7.1.gh.tar.gz 7986892 BLAKE2B 684600d8833ba1b04e32d2f56fdf9e348f3de58af9adbbbd52e2a490ccebc10e5b519c7d4795b1d7f07c4ae95806e9fed6fe5fa898352d8105572a8d2b6d2da9 SHA512 9369e72a3a044c1e985aa85980baca1c44f754eea788991d993868408ba886fcb2671fe1098865a3d10cced84793f74e36446f9cd882db968285525643c0b606
+DIST maestral-1.7.2_rc0.gh.tar.gz 7987730 BLAKE2B 9476b4b6e1cdc4de361e62478b23b630c430a50ba465331844fa6e41da7dc3043d7e552b2f4e095a1825166a4f9a43c59b3d8e739f4b6837a6cab8f410a3a640 SHA512 67595efa76e593602d6d969e05439c7416ad8730d26b92033cb9feb2367ab4e89038e90f68982ee3476309fd568276e8b97392e461d2138d86573ee1f91a83b4
diff --git a/net-misc/maestral/maestral-1.7.2_rc0.ebuild b/net-misc/maestral/maestral-1.7.2_rc0.ebuild
new file mode 100644
index 000000000..33e31a844
--- /dev/null
+++ b/net-misc/maestral/maestral-1.7.2_rc0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1 xdg
+
+MY_PV=${PV/_rc/.dev}
+DESCRIPTION="Maestral is an open-source Dropbox client written in Python"
+HOMEPAGE="https://maestral.app"
+SRC_URI="https://github.com/samschott/maestral/archive/refs/tags/v${MY_PV}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}"/${PN}-${MY_PV}
+
+LICENSE="MIT"
+SLOT="0"
+if [[ ${PV} != *_rc* ]]; then
+ KEYWORDS="~amd64"
+fi
+
+RDEPEND="
+ >=dev-python/click-8.0.2[${PYTHON_USEDEP}]
+ >=dev-python/desktop-notifier-3.3.0[${PYTHON_USEDEP}]
+ =dev-python/dropbox-11*[${PYTHON_USEDEP}]
+ >=dev-python/fasteners-0.15[${PYTHON_USEDEP}]
+ dev-python/importlib_metadata[${PYTHON_USEDEP}]
+ >=dev-python/keyring-22.0.0[${PYTHON_USEDEP}]
+ >=dev-python/keyrings-alt-3.1.0[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/pathspec-0.5.8[${PYTHON_USEDEP}]
+ >=dev-python/Pyro5-5.10[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.16.2[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+ =dev-python/survey-3*[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ >=dev-python/watchdog-2.0.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/build[${PYTHON_USEDEP}]
+"
+
+EPYTEST_DESELECT=(
+ # requires dev-python/pytest-benchmark not available for py3.11
+ tests/offline/test_clean_local_events.py::test_performance
+
+ # requires systemd
+ tests/offline/test_cli.py::test_autostart
+
+ # requires network
+ tests/offline/test_main.py::test_check_for_updates
+)
+
+distutils_enable_tests pytest