aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2023-07-25 10:39:18 +0300
committerViorel Munteanu <ceamac@gentoo.org>2023-07-25 10:48:30 +0300
commitb3d0eec4748d3a2ff3c83f075a603b24a694766a (patch)
tree159b5b6a1a4fbc81e85b7952b892142bc691dd3e /net-misc/maestral
parentnet-misc/maestral: add 1.8.0 (diff)
downloadguru-b3d0eec4748d3a2ff3c83f075a603b24a694766a.tar.gz
guru-b3d0eec4748d3a2ff3c83f075a603b24a694766a.tar.bz2
guru-b3d0eec4748d3a2ff3c83f075a603b24a694766a.zip
net-misc/maestral: drop 1.8.0_rc0
Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'net-misc/maestral')
-rw-r--r--net-misc/maestral/Manifest1
-rw-r--r--net-misc/maestral/maestral-1.8.0_rc0.ebuild54
2 files changed, 0 insertions, 55 deletions
diff --git a/net-misc/maestral/Manifest b/net-misc/maestral/Manifest
index a0953d9cc..e980d0dcb 100644
--- a/net-misc/maestral/Manifest
+++ b/net-misc/maestral/Manifest
@@ -1,3 +1,2 @@
DIST maestral-1.7.3.gh.tar.gz 8124324 BLAKE2B 793ff423e356da1dd17fa9815a635b0d57e7665eb3024e9b2b8a30c3e37868b942de3ddeec66a5c76172c9c9635a5646f9ccb302397a5f318ed30df8898a24a5 SHA512 93d4ec06a0a612ecd270deb7b92a8d9e4895db0e835430569b46f09a2fd3a83af89dceffd52b3f2be2b0417a7a88700732412556ce1224a14d62226727daa0c1
DIST maestral-1.8.0.gh.tar.gz 8125310 BLAKE2B 14880a6ced1d1cea203741875f4eb4a8520daf7103efaca19476c21674f9a10edc2d8959d86fc916ba2cbafbca4e33dd393986f08e844b0e7f85d1c833ea7af6 SHA512 e6dff6b8685e78f10ea03b88cfc3d307d0a5873935b43cf4e04c5876009ca1ce88aa782da37a17b9ea092335a3835f2fe2fbf388c861c5da36500a781d10a17b
-DIST maestral-1.8.0_rc0.gh.tar.gz 8125327 BLAKE2B e019b08b78bac352152dbddadadfa3da74db4d962ad83b7a4789999becdfc35c7aa6ec1af243a461207525bae8f207c5dcb8285e6f5c5f4c681b30998a65248e SHA512 bcea5b58fab9a1d78d8566fc8be0e6fd7fea2bc942d96659821ce3bdfd0edd6927826abbc46d717e971c612414919b5e8e6a21c57627780c13f932eae9cd35b4
diff --git a/net-misc/maestral/maestral-1.8.0_rc0.ebuild b/net-misc/maestral/maestral-1.8.0_rc0.ebuild
deleted file mode 100644
index 772464ac1..000000000
--- a/net-misc/maestral/maestral-1.8.0_rc0.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 2021-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
-inherit distutils-r1 xdg
-
-MY_PV=${PV/_rc/.dev}
-DESCRIPTION="Maestral is an open-source Dropbox client written in Python"
-HOMEPAGE="https://maestral.app"
-SRC_URI="https://github.com/samschott/maestral/archive/refs/tags/v${MY_PV}.tar.gz -> ${P}.gh.tar.gz"
-S="${WORKDIR}"/${PN}-${MY_PV}
-
-LICENSE="MIT"
-SLOT="0"
-if [[ ${PV} != *_rc* ]]; then
- KEYWORDS="~amd64"
-fi
-
-RDEPEND="
- >=dev-python/click-8.0.2[${PYTHON_USEDEP}]
- >=dev-python/desktop-notifier-3.3.0[${PYTHON_USEDEP}]
- =dev-python/dropbox-11*[${PYTHON_USEDEP}]
- >=dev-python/fasteners-0.15[${PYTHON_USEDEP}]
- dev-python/importlib-metadata[${PYTHON_USEDEP}]
- >=dev-python/keyring-22.0.0[${PYTHON_USEDEP}]
- >=dev-python/keyrings-alt-3.1.0[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- >=dev-python/pathspec-0.5.8[${PYTHON_USEDEP}]
- >=dev-python/Pyro5-5.10[${PYTHON_USEDEP}]
- >=dev-python/requests-2.16.2[${PYTHON_USEDEP}]
- dev-python/rich[${PYTHON_USEDEP}]
- =dev-python/survey-4*[${PYTHON_USEDEP}]
- dev-python/typing-extensions[${PYTHON_USEDEP}]
- >=dev-python/watchdog-2.0.1[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/build[${PYTHON_USEDEP}]
-"
-
-EPYTEST_DESELECT=(
- # requires dev-python/pytest-benchmark not available for py3.11
- tests/offline/test_clean_local_events.py::test_performance
-
- # requires systemd
- tests/offline/test_cli.py::test_autostart
-
- # requires network
- tests/offline/test_main.py::test_check_for_updates
-)
-
-distutils_enable_tests pytest