aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDale Sweeney <agooglygooglr@gmail.com>2024-08-18 12:34:26 -0400
committerDale Sweeney <agooglygooglr@gmail.com>2024-08-18 12:35:53 -0400
commit78ec3637cd6614e0bf491560f4fe00bb80ae61f2 (patch)
treeb3dc1f307387af988519a9ad193ccb2b33702419 /net-misc
parentwww-client/nyxt: drop 3.11.4 (diff)
downloadguru-78ec3637cd6614e0bf491560f4fe00bb80ae61f2.tar.gz
guru-78ec3637cd6614e0bf491560f4fe00bb80ae61f2.tar.bz2
guru-78ec3637cd6614e0bf491560f4fe00bb80ae61f2.zip
net-misc/wlvncc: Add snapshot ebuild
Signed-off-by: Dale Sweeney <agooglygooglr@gmail.com>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/wlvncc/Manifest1
-rw-r--r--net-misc/wlvncc/wlvncc-20240818.ebuild25
-rw-r--r--net-misc/wlvncc/wlvncc-9999.ebuild14
3 files changed, 29 insertions, 11 deletions
diff --git a/net-misc/wlvncc/Manifest b/net-misc/wlvncc/Manifest
new file mode 100644
index 000000000..767cebcdd
--- /dev/null
+++ b/net-misc/wlvncc/Manifest
@@ -0,0 +1 @@
+DIST 174ad8aef7978c242861a66c481a7ca25dc04e37.tar.gz 163535 BLAKE2B 85bf0e34a26d449588538d09b507cdebb7294f560fa64d4f9bc1de490e873323bedec7cfebc0e514bef4f81d3d28cc8e4f3b3423c88380c5d2bfa27d48bc3a9e SHA512 83ca0d99b2ab3c81085242b5ae3004eef717b068f25abb370c775372e344907c8e4412bf76ccf77c8029e900adc406a935c94060930144edae241a139fa943b9
diff --git a/net-misc/wlvncc/wlvncc-20240818.ebuild b/net-misc/wlvncc/wlvncc-20240818.ebuild
new file mode 100644
index 000000000..287ac7f2e
--- /dev/null
+++ b/net-misc/wlvncc/wlvncc-20240818.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+COMMIT="174ad8aef7978c242861a66c481a7ca25dc04e37"
+
+inherit meson
+
+SRC_URI="https://github.com/any1/${PN}/archive/${COMMIT}.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+DESCRIPTION="A Wayland Native VNC Client"
+HOMEPAGE="https://github.com/any1/wlvncc"
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND="
+ dev-libs/wayland-protocols
+"
+RDEPEND="
+ dev-libs/aml
+ x11-libs/libxkbcommon
+ x11-libs/pixman
+ dev-libs/wayland
+"
diff --git a/net-misc/wlvncc/wlvncc-9999.ebuild b/net-misc/wlvncc/wlvncc-9999.ebuild
index 871ffe385..1caf58191 100644
--- a/net-misc/wlvncc/wlvncc-9999.ebuild
+++ b/net-misc/wlvncc/wlvncc-9999.ebuild
@@ -12,20 +12,12 @@ HOMEPAGE="https://github.com/any1/wlvncc"
LICENSE="GPL-2"
SLOT="0"
+DEPEND="
+ dev-libs/wayland-protocols
+"
RDEPEND="
dev-libs/aml
x11-libs/libxkbcommon
x11-libs/pixman
dev-libs/wayland
"
-BDEPEND="
- dev-libs/wayland-protocols
-"
-
-src_configure() {
- meson_src_configure
-}
-
-src_install() {
- meson_src_install
-}