aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna Vyalkova <cyber@sysrq.in>2021-05-16 19:41:42 +0500
committerAnna Vyalkova <cyber@sysrq.in>2021-05-16 21:11:06 +0500
commitfad0bd71a5e8db76b299a08c323999552f3acb59 (patch)
treeb9a31f126cb3a58c3e8d1b787a4e0fbe64eba340 /sci-mathematics
parentnet-news/sfeed: fix AR and RANLIB, drop old (diff)
downloadguru-fad0bd71a5e8db76b299a08c323999552f3acb59.tar.gz
guru-fad0bd71a5e8db76b299a08c323999552f3acb59.tar.bz2
guru-fad0bd71a5e8db76b299a08c323999552f3acb59.zip
sci-mathematics/frama-c: fix AR and RANLIB
Closes: https://bugs.gentoo.org/785163 Closes: https://bugs.gentoo.org/784944 Signed-off-by: Anna Vyalkova <cyber@sysrq.in>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/frama-c/frama-c-22.0.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/sci-mathematics/frama-c/frama-c-22.0.ebuild b/sci-mathematics/frama-c/frama-c-22.0.ebuild
index cb0c8334c..80111f49f 100644
--- a/sci-mathematics/frama-c/frama-c-22.0.ebuild
+++ b/sci-mathematics/frama-c/frama-c-22.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit autotools findlib
+inherit autotools findlib toolchain-funcs
DESCRIPTION="Framework for analysis of source codes written in C"
HOMEPAGE="https://frama-c.com"
@@ -53,6 +53,7 @@ src_prepare() {
mv configure.in configure.ac || die
sed -i 's/configure\.in/configure.ac/g' Makefile.generating Makefile || die
sed -i '/\$(CC)/s/-O2 -g3/$(CFLAGS)/' src/plugins/e-acsl/Makefile.in || die
+ sed -i "s/ranlib/$(tc-getRANLIB)/" src/plugins/e-acsl/Makefile.in || die
touch config_file || die
eautoreconf
eapply_user
@@ -96,3 +97,8 @@ src_configure() {
$(use_enable wp) \
--disable-wp-coq
}
+
+src_compile() {
+ tc-export AR
+ default
+}