aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Torokhov <torokhov-s-a@yandex.ru>2023-05-27 23:25:54 +0300
committerSergey Torokhov <torokhov-s-a@yandex.ru>2023-05-27 23:25:54 +0300
commitfd1dbc562b229032326d3cdb7664d6de4f53763b (patch)
tree12cf76988ba2c510f2cb859dadc06e2babbce1b2 /sys-cluster
parentsys-clyster/opencoarrays: drop old 2.9.2 (failed to build with gcc:12) (diff)
downloadguru-fd1dbc562b229032326d3cdb7664d6de4f53763b.tar.gz
guru-fd1dbc562b229032326d3cdb7664d6de4f53763b.tar.bz2
guru-fd1dbc562b229032326d3cdb7664d6de4f53763b.zip
sys-cluster/opencoarrays: fix -Wint-conversion CMake conf warning/error
Closes: https://bugs.gentoo.org/888009 Signed-off-by: Sergey Torokhov <torokhov-s-a@yandex.ru>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/opencoarrays/files/opencoarrays-2.10.1_fix_Wint-conversion_warning_error.patch14
-rw-r--r--sys-cluster/opencoarrays/opencoarrays-2.10.0.ebuild6
-rw-r--r--sys-cluster/opencoarrays/opencoarrays-2.10.1.ebuild4
-rw-r--r--sys-cluster/opencoarrays/opencoarrays-2.9.3.ebuild6
4 files changed, 28 insertions, 2 deletions
diff --git a/sys-cluster/opencoarrays/files/opencoarrays-2.10.1_fix_Wint-conversion_warning_error.patch b/sys-cluster/opencoarrays/files/opencoarrays-2.10.1_fix_Wint-conversion_warning_error.patch
new file mode 100644
index 000000000..840ef9809
--- /dev/null
+++ b/sys-cluster/opencoarrays/files/opencoarrays-2.10.1_fix_Wint-conversion_warning_error.patch
@@ -0,0 +1,14 @@
+Gentoo issue: https://bugs.gentoo.org/888009
+
+diff -Naur a/CMakeLists.txt b/CMakeLists.txt
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -422,7 +422,7 @@
+ char processor_name[MPI_MAX_PROCESSOR_NAME];
+ int name_len;
+ MPI_Get_processor_name(processor_name, &name_len);
+- printf('Hello world from processor %s, rank %d out of %d processors',
++ printf(\"Hello world from processor %s, rank %d out of %d processors\",
+ processor_name, world_rank, world_size);
+ MPI_Finalize();
+ }"
diff --git a/sys-cluster/opencoarrays/opencoarrays-2.10.0.ebuild b/sys-cluster/opencoarrays/opencoarrays-2.10.0.ebuild
index ca009c52c..483ed4d3c 100644
--- a/sys-cluster/opencoarrays/opencoarrays-2.10.0.ebuild
+++ b/sys-cluster/opencoarrays/opencoarrays-2.10.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -34,6 +34,10 @@ DEPEND="
${RDEPEND}
"
+PATCHES=(
+ "${FILESDIR}/${PN}-2.10.1_fix_Wint-conversion_warning_error.patch"
+)
+
src_configure() {
filter-lto # Bug 860765
diff --git a/sys-cluster/opencoarrays/opencoarrays-2.10.1.ebuild b/sys-cluster/opencoarrays/opencoarrays-2.10.1.ebuild
index 11781f87d..4080b13e9 100644
--- a/sys-cluster/opencoarrays/opencoarrays-2.10.1.ebuild
+++ b/sys-cluster/opencoarrays/opencoarrays-2.10.1.ebuild
@@ -37,6 +37,10 @@ DEPEND="
${RDEPEND}
"
+PATCHES=(
+ "${FILESDIR}/${PN}-2.10.1_fix_Wint-conversion_warning_error.patch"
+)
+
src_configure() {
filter-lto # Bug 860765
diff --git a/sys-cluster/opencoarrays/opencoarrays-2.9.3.ebuild b/sys-cluster/opencoarrays/opencoarrays-2.9.3.ebuild
index ca009c52c..483ed4d3c 100644
--- a/sys-cluster/opencoarrays/opencoarrays-2.9.3.ebuild
+++ b/sys-cluster/opencoarrays/opencoarrays-2.9.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -34,6 +34,10 @@ DEPEND="
${RDEPEND}
"
+PATCHES=(
+ "${FILESDIR}/${PN}-2.10.1_fix_Wint-conversion_warning_error.patch"
+)
+
src_configure() {
filter-lto # Bug 860765