aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfe İzbudak <efe.izbudak@metu.edu.tr>2023-07-13 10:21:49 -0400
committerEfe İzbudak <efe.izbudak@metu.edu.tr>2023-07-13 17:23:07 +0300
commitbd4613a133b2dbab999a57e048f7844136f3dec0 (patch)
tree9a44c2c05da2473590626d5aa37b2aa54ea0e713 /sys-process
parentwww-client/vimb: add 3.7.0 (diff)
downloadguru-bd4613a133b2dbab999a57e048f7844136f3dec0.tar.gz
guru-bd4613a133b2dbab999a57e048f7844136f3dec0.tar.bz2
guru-bd4613a133b2dbab999a57e048f7844136f3dec0.zip
sys-process/scron: new package, add 0.4
Signed-off-by: Efe İzbudak <efe.izbudak@metu.edu.tr>
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/scron/Manifest1
-rw-r--r--sys-process/scron/files/scron-0.4-initd12
-rw-r--r--sys-process/scron/scron-0.4.ebuild34
3 files changed, 47 insertions, 0 deletions
diff --git a/sys-process/scron/Manifest b/sys-process/scron/Manifest
new file mode 100644
index 000000000..b8b0ff725
--- /dev/null
+++ b/sys-process/scron/Manifest
@@ -0,0 +1 @@
+DIST scron-0.4.tar.gz 10263 BLAKE2B 87bcaa0157afd0fcf2eebfb3e17bad1eba187d503fe57089fe2fa9faa02f286ee5bc13c2ca216df31bdfd2a1700d82bb5ddfa161e451c31101e08be08339e38f SHA512 585c8dd1acab29d37890b62b4c8de2ae6a26bc67c3e95c1c8eaefc6672b6a1b0c3432a93b34d44eb693ba322f4b8f29495e1a825e87b376edb6c5c842da26f1f
diff --git a/sys-process/scron/files/scron-0.4-initd b/sys-process/scron/files/scron-0.4-initd
new file mode 100644
index 000000000..54d5401f0
--- /dev/null
+++ b/sys-process/scron/files/scron-0.4-initd
@@ -0,0 +1,12 @@
+#!/sbin/openrc-run
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+command="/usr/bin/crond"
+pidfile="/run/crond.pid"
+
+depend() {
+ use clock logger
+ need localmount
+ provide cron
+}
diff --git a/sys-process/scron/scron-0.4.ebuild b/sys-process/scron/scron-0.4.ebuild
new file mode 100644
index 000000000..d2d1250c5
--- /dev/null
+++ b/sys-process/scron/scron-0.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Simple cron daemon"
+HOMEPAGE="https://git.2f30.org/scron/"
+SRC_URI="https://dl.2f30.org/releases/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND=""
+RDEPEND="
+ !sys-process/cronie
+ !sys-process/bcron
+ !sys-process/dcron
+ !sys-process/fcron
+ !sys-process/systemd-cron
+"
+BDEPEND=""
+
+src_install() {
+ emake MANPREFIX="/usr/share/man" PREFIX="/usr" DESTDIR="${D}" install
+ einstalldocs
+ newinitd "${FILESDIR}/${PN}-0.4-initd" ${PN}
+}
+
+pkg_postinst() {
+ elog "Start scron as a system service with"
+ elog "'rc-service scron start'. Enable it at startup with"
+ elog "'rc-update add scron default'."
+}