aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarco Scardovi <marco@scardovi.com>2021-07-04 21:46:18 +0200
committerMarco Scardovi <marco@scardovi.com>2021-07-04 21:46:18 +0200
commitdd9c300aec695409a5d139a58eb4784fbb4cda01 (patch)
tree40aefdba20edc2aacbc196b2cf5f983de24ec141 /x11-terms
parentmove terminus-bin to tabby-bin (diff)
downloadguru-dd9c300aec695409a5d139a58eb4784fbb4cda01.tar.gz
guru-dd9c300aec695409a5d139a58eb4784fbb4cda01.tar.bz2
guru-dd9c300aec695409a5d139a58eb4784fbb4cda01.zip
x11-terms/tabby-bin: bump to 144 and update name
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Marco Scardovi <marco@scardovi.com>
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/tabby-bin/Manifest2
-rw-r--r--x11-terms/tabby-bin/metadata.xml12
-rw-r--r--x11-terms/tabby-bin/tabby-bin-1.0.144.ebuild62
3 files changed, 76 insertions, 0 deletions
diff --git a/x11-terms/tabby-bin/Manifest b/x11-terms/tabby-bin/Manifest
new file mode 100644
index 000000000..e0ed23835
--- /dev/null
+++ b/x11-terms/tabby-bin/Manifest
@@ -0,0 +1,2 @@
+DIST tabby-1.0.144-linux.tar.gz 96913007 BLAKE2B e2227735cdb027e57d4f8427ddcfde9addbc0d7309bcc36228ba99135c9a3fd8af49ed1292205fafea7fde3f64b0df79a709d2acd839fc68cd8b511982960005 SHA512 bfae32458320e10565dea499b1db3d7b81eabafe7da5f0944e88d61e36935116ae9bc3879ee9a538ffc1f59fb08ca8264981de9b8afbd51f48da44e15d36fcd1
+DIST tabby-icons.tar.gz 29664 BLAKE2B 61ac59cdf57c9f70b7ec33ee3d88f71ea5e16c87e84fdfa4452b9d6a38c8c5ffa5af261923bba91f2d6aa34f9fb7c2aa18358e50ce914b8992b91a4fc1dc11e3 SHA512 7ed5b5f0e78da655a13914933317f639a0656da9dce264e1c3f2eee9942f9b8c87f508ea275ea25b7bd0b850b47c8fd888fd90bdfe6b3ea3a8e579f9258545da
diff --git a/x11-terms/tabby-bin/metadata.xml b/x11-terms/tabby-bin/metadata.xml
new file mode 100644
index 000000000..ca63cb8f9
--- /dev/null
+++ b/x11-terms/tabby-bin/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marco@scardovi.com</email>
+ <name>Marco Scardovi</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">Eugeny/terminus</remote-id>
+ <remote-id type="github">scardracs/icons</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-terms/tabby-bin/tabby-bin-1.0.144.ebuild b/x11-terms/tabby-bin/tabby-bin-1.0.144.ebuild
new file mode 100644
index 000000000..43cbcc09f
--- /dev/null
+++ b/x11-terms/tabby-bin/tabby-bin-1.0.144.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop xdg
+
+MY_P="tabby-${PV}-linux"
+
+DESCRIPTION="A terminal for a more modern age"
+HOMEPAGE="https://eugeny.github.io/tabby"
+SRC_URI="
+ https://github.com/Eugeny/tabby/releases/download/v${PV}/${MY_P}.tar.gz
+ https://github.com/scardracs/icons/releases/download/release/tabby-icons.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+S="${WORKDIR}/${MY_P}"
+
+DEPEND="
+ app-accessibility/at-spi2-atk
+ app-accessibility/at-spi2-core
+ dev-libs/atk
+ dev-libs/nss
+ media-libs/alsa-lib
+ net-print/cups
+ media-libs/mesa
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+
+ x11-libs/libdrm
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXfixes
+ x11-libs/libxkbcommon
+ x11-libs/libXrandr
+ x11-libs/libxshmfence
+ x11-libs/pango
+"
+
+QA_PREBUILT="/opt/${PN}/*"
+
+src_prepare(){
+ default
+}
+
+src_install(){
+ insinto /opt/"${PN}"
+ doins -r "${S}"/*
+ dosym ../../opt/"${PN}"/"${PN}" "${EPREFIX}"/usr/bin/"${PN}"
+ fperms +x /opt/"${PN}"/"${PN}"
+ make_desktop_entry "/opt/${PN}/tabby %U" "Tabby" "tabby" \
+ "GNOME;GTK;Utility;" \
+ "GenericName=Tabby\n\nStartupNotify=true\nStartupWMClass=tabby"
+ doicon ../tabby.svg
+ doicon ../tabby.ico
+ for i in {16,24,32,48,64,72,96,128,512}; do
+ doicon -s "${i}" ../tabby-"${i}".png
+ done
+}