aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-doc/ford/ford-6.1.11.ebuild')
-rw-r--r--app-doc/ford/ford-6.1.11.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/app-doc/ford/ford-6.1.11.ebuild b/app-doc/ford/ford-6.1.11.ebuild
index 369eb1f96..66ccc5ab8 100644
--- a/app-doc/ford/ford-6.1.11.ebuild
+++ b/app-doc/ford/ford-6.1.11.ebuild
@@ -4,7 +4,7 @@
EAPI=8
PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
+inherit distutils-r1 toolchain-funcs
MY_PN="FORD"
DESCRIPTION="FORD, automatic documentation generator for modern Fortran programs"
@@ -36,6 +36,11 @@ DOCS=( CHANGELOG.md README.md README.rst )
distutils_enable_tests pytest
+src_prepare() {
+ default
+ sed -i -e 's/"cpp /"'"$(tc-getCPP)"' /' ford/__init__.py || die # bug: 839300
+}
+
python_test(){
# The 'test/test_projects' tests use subprocess, i.e. require FORD to be installed.
distutils_install_for_testing