aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-nim/cligen/cligen-1.6.2.ebuild')
-rw-r--r--dev-nim/cligen/cligen-1.6.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-nim/cligen/cligen-1.6.2.ebuild b/dev-nim/cligen/cligen-1.6.2.ebuild
new file mode 100644
index 000000000..2b47f85a4
--- /dev/null
+++ b/dev-nim/cligen/cligen-1.6.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit nimble
+
+DESCRIPTION="Infer & generate command-line interface/option/argument parser"
+HOMEPAGE="
+ https://c-blake.github.io/cligen/
+ https://nimble.directory/pkg/cligen
+ https://github.com/c-blake/cligen
+"
+SRC_URI="https://github.com/c-blake/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC MIT"
+SLOT="${PV}"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+DOCS=( configs {MOTIVATION,README,RELEASE-NOTES,TODO}.md )
+
+set_package_url "https://github.com/c-blake/cligen"
+
+src_test() {
+ emake V=1
+}
+
+src_install() {
+ if use examples; then
+ docompress -x /usr/share/doc/${PF}/examples
+ dodoc -r examples
+ fi
+
+ nimble_src_install
+}