aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-misc/cbonsai/files/cbonsai-respect-variables.patch')
-rw-r--r--games-misc/cbonsai/files/cbonsai-respect-variables.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/games-misc/cbonsai/files/cbonsai-respect-variables.patch b/games-misc/cbonsai/files/cbonsai-respect-variables.patch
new file mode 100644
index 000000000..3187e2847
--- /dev/null
+++ b/games-misc/cbonsai/files/cbonsai-respect-variables.patch
@@ -0,0 +1,13 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,9 +1,7 @@
+ .POSIX:
+-CC = cc
+ PKG_CONFIG ?= pkg-config
+ CFLAGS += -Wall -Wextra -Wshadow -Wpointer-arith -Wcast-qual -pedantic $(shell $(PKG_CONFIG) --cflags ncursesw panelw)
+-LDLIBS = $(shell $(PKG_CONFIG) --libs ncursesw panelw || echo "-lncursesw -ltinfo -lpanelw")
+-PREFIX = /usr/local
++LDLIBS = $(shell $(PKG_CONFIG) --libs ncursesw panelw || echo "-lncursesw -ltinfo -lpanelw") ${LDFLAGS}
+
+ cbonsai: cbonsai.c
+