aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-proxy/MTProxy/MTProxy-3.0.4-r1.ebuild')
-rw-r--r--net-proxy/MTProxy/MTProxy-3.0.4-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/net-proxy/MTProxy/MTProxy-3.0.4-r1.ebuild b/net-proxy/MTProxy/MTProxy-3.0.4-r1.ebuild
new file mode 100644
index 000000000..1c7d60122
--- /dev/null
+++ b/net-proxy/MTProxy/MTProxy-3.0.4-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Community fork of MTProxy"
+HOMEPAGE="https://github.com/GetPageSpeed/MTProxy"
+SRC_URI="https://github.com/GetPageSpeed/MTProxy/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ dev-libs/openssl
+ sys-libs/zlib
+"
+
+RDEPEND="${DEPEND}"
+
+PATCHES="
+ ${FILESDIR}/${P}-adjust_flags.patch
+ ${FILESDIR}/${P}-no_implicit_func.patch
+"
+
+src_install() {
+ dobin objs/bin/mtproto-proxy
+}