aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/forgejo/Manifest2
-rw-r--r--www-apps/forgejo/forgejo-1.21.11.1.ebuild137
-rw-r--r--www-apps/forgejo/forgejo-7.0.7.ebuild139
3 files changed, 0 insertions, 278 deletions
diff --git a/www-apps/forgejo/Manifest b/www-apps/forgejo/Manifest
index 72a3d39d3..0660af78e 100644
--- a/www-apps/forgejo/Manifest
+++ b/www-apps/forgejo/Manifest
@@ -1,4 +1,2 @@
-DIST forgejo-1.21.11.1.tar.gz 58893566 BLAKE2B cf3541682de609d63f079922610cc7ae338b7736634a6bc767e310f4ea9fc21fd8c6928b2de4693be6619b49d7e0cbf3b0effd58b681a0cd5e95d4ba21c29141 SHA512 c461d8690a7d2eb3a4955487223391daac58f3236481c0b963a208184ed06fc96372fe8082fbb4a7d9a64b01b2c468d43d1559dd081ec65e65c9f9bc043f9af4
-DIST forgejo-7.0.7.tar.gz 53549049 BLAKE2B af5b42ba2888a106b418a683c1f40d80d31e226608b699c6e6696ff3187c7f91c75cd53de490d464af12d2107e8cbaaa3662bca4b1a834aacfcbc3ca22d7f71a SHA512 6163f154afde2c804b601a083cff43b6f13677fa6181f4916e190ffba23a05d29ffc945a6a384f23eb72fb9a7e0d1d846657b01f0dce5c519a8919c73631f22a
DIST forgejo-7.0.9.tar.gz 53600572 BLAKE2B 2ef91a7e488562b6e4110769841f37265f26a277c67db0c154ba2e55a1809501c908cb35807e5514093ce3756441cbe25ad8dce7f74ed2c839e59136b0f9dd05 SHA512 45996bec03934fb26ef6d87fa8efc7c007f4ec683b29eb0a23c07a03ab35ea9c74c22f4d1f985ede71ef87430973c703d8b6efd17d04192fa00ad30366ad7f17
DIST forgejo-8.0.3.tar.gz 53477625 BLAKE2B 378183773d7e81cf4471f592bf0c992aa1ff3bb267a5e53c7ffad8d79b2fd9a91060ce42a0cc33c39ae629fa9e69077715a88a029a59b68c35dd2ada4396b35d SHA512 eb5c90679d073856bac4b67fd49a9d74de6c91d3627461e8426ed0c2de2ca4344d25fb559bd7f6f13e09b7e443c51c3b4d5ead32f23f3fe10c115eb9ee019999
diff --git a/www-apps/forgejo/forgejo-1.21.11.1.ebuild b/www-apps/forgejo/forgejo-1.21.11.1.ebuild
deleted file mode 100644
index 68c5354b8..000000000
--- a/www-apps/forgejo/forgejo-1.21.11.1.ebuild
+++ /dev/null
@@ -1,137 +0,0 @@
-# Copyright 2016-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit fcaps go-module tmpfiles systemd flag-o-matic
-
-MY_PV="$(ver_cut 1-3)-$(ver_cut 4)"
-DESCRIPTION="A self-hosted lightweight software forge"
-HOMEPAGE="https://forgejo.org/ https://codeberg.org/forgejo/forgejo"
-
-SRC_URI="https://codeberg.org/forgejo/forgejo/releases/download/v${MY_PV}/forgejo-src-${MY_PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${PN}-src-${MY_PV}"
-LICENSE="Apache-2.0 BSD BSD-2 ISC MIT MPL-2.0"
-SLOT="0"
-
-KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
-
-IUSE="+acct pam sqlite pie"
-
-DEPEND="
- acct? (
- acct-group/git
- acct-user/git[gitea] )
- pam? ( sys-libs/pam )"
-RDEPEND="${DEPEND}
- dev-vcs/git
- !www-apps/gitea" # until acct-user/git[forgejo]
-
-DOCS=(
- custom/conf/app.example.ini CONTRIBUTING.md README.md
-)
-FILECAPS=(
- -m 711 cap_net_bind_service+ep usr/bin/forgejo
-)
-
-RESTRICT="test"
-
-src_prepare() {
- default
-
- local sedcmds=(
- -e "s#^ROOT =#ROOT = ${EPREFIX}/var/lib/gitea/gitea-repositories#"
- -e "s#^ROOT_PATH =#ROOT_PATH = ${EPREFIX}/var/log/forgejo#"
- -e "s#^APP_DATA_PATH = data#APP_DATA_PATH = ${EPREFIX}/var/lib/gitea/data#"
- -e "s#^HTTP_ADDR = 0.0.0.0#HTTP_ADDR = 127.0.0.1#"
- -e "s#^MODE = console#MODE = file#"
- -e "s#^LEVEL = Trace#LEVEL = Info#"
- -e "s#^LOG_SQL = true#LOG_SQL = false#"
- -e "s#^DISABLE_ROUTER_LOG = false#DISABLE_ROUTER_LOG = true#"
- )
-
- sed -i "${sedcmds[@]}" custom/conf/app.example.ini || die
- if use sqlite ; then
- sed -i -e "s#^DB_TYPE = .*#DB_TYPE = sqlite3#" custom/conf/app.example.ini || die
- fi
-}
-
-src_configure() {
- # bug 832756 - PIE build issues
- filter-flags -fPIE
- filter-ldflags -fPIE -pie
-}
-
-src_compile() {
- local forgejo_tags=(
- bindata
- $(usev pam)
- $(usex sqlite 'sqlite sqlite_unlock_notify' '')
- )
- local forgejo_settings=(
- "-X code.gitea.io/gitea/modules/setting.CustomConf=${EPREFIX}/etc/forgejo/app.ini"
- "-X code.gitea.io/gitea/modules/setting.CustomPath=${EPREFIX}/var/lib/gitea/custom"
- "-X code.gitea.io/gitea/modules/setting.AppWorkPath=${EPREFIX}/var/lib/gitea"
- )
- local makeenv=(
- DRONE_TAG="${PV}"
- LDFLAGS="-extldflags \"${LDFLAGS}\" ${forgejo_settings[*]}"
- TAGS="${forgejo_tags[*]}"
- )
-
- GOFLAGS=""
- if use pie ; then
- GOFLAGS+="-buildmode=pie"
- fi
-
- # need to set -j1 or build fails due to a race condition between MAKE jobs.
- # this does not actually impact build parallelism, because the go compiler
- # will still build everything in parallel when it's invoked.
- env "${makeenv[@]}" emake -j1 EXTRA_GOFLAGS="${GOFLAGS}" backend
-}
-
-src_install() {
- cp gitea forgejo
- dobin forgejo
-
- einstalldocs
-
- newconfd "${FILESDIR}/forgejo.confd-r1" forgejo
- newinitd "${FILESDIR}/forgejo.initd-r3" forgejo
- newtmpfiles - forgejo.conf <<-EOF
- d /run/forgejo 0755 git git
- EOF
- systemd_newunit "${FILESDIR}"/forgejo.service-r3 forgejo.service
-
- insinto /etc/forgejo
- newins custom/conf/app.example.ini app.ini
- if use acct; then
- fowners root:git /etc/forgejo/{,app.ini}
- fperms g+w,o-rwx /etc/forgejo/{,app.ini}
-
- diropts -m0750 -o git -g git
- keepdir /var/lib/gitea /var/lib/gitea/custom /var/lib/gitea/data
- keepdir /var/log/forgejo
- fi
-}
-
-pkg_postinst() {
- fcaps_pkg_postinst
- tmpfiles_process forgejo.conf
-
- ewarn "${PN} ${MY_PV} will continue to use /var/lib/gitea as the default home,"
- ewarn "as acct-user/git[gitea] depends on it, and acct-user[forgejo] does not"
- ewarn "exist yet."
- ewarn ""
- ewarn "1.21.x includes changes that may require manual intervention when"
- ewarn "upgrading from 1.20.x:"
- ewarn ""
- ewarn "> Git branches are stored in the databases to reduce the calls to a"
- ewarn "> git process and improve performances. After upgrading, login as an"
- ewarn "> admin, go to the /admin page and click run Sync missed branches"
- ewarn "> from git data to databases. If this is not done there will be"
- ewarn "> messages such as LoadBranches: branch does not exist in the logs."
- ewarn ""
- ewarn "See https://codeberg.org/forgejo/forgejo/src/branch/forgejo/RELEASE-NOTES.md#1-21-1-0"
- ewarn "for more information"
-}
diff --git a/www-apps/forgejo/forgejo-7.0.7.ebuild b/www-apps/forgejo/forgejo-7.0.7.ebuild
deleted file mode 100644
index 2b2357dce..000000000
--- a/www-apps/forgejo/forgejo-7.0.7.ebuild
+++ /dev/null
@@ -1,139 +0,0 @@
-# Copyright 2016-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit fcaps go-module tmpfiles systemd flag-o-matic
-
-DESCRIPTION="A self-hosted lightweight software forge"
-HOMEPAGE="https://forgejo.org/ https://codeberg.org/forgejo/forgejo"
-
-SRC_URI="https://codeberg.org/forgejo/forgejo/releases/download/v${PV}/forgejo-src-${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${PN}-src-${PV}"
-LICENSE="Apache-2.0 BSD BSD-2 ISC MIT MPL-2.0"
-SLOT="0"
-
-KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
-
-IUSE="+acct pam sqlite pie"
-
-DEPEND="
- acct? (
- acct-group/git
- acct-user/git[gitea] )
- pam? ( sys-libs/pam )"
-RDEPEND="${DEPEND}
- dev-vcs/git
- !www-apps/gitea" # until acct-user/git[forgejo]
-
-DOCS=(
- custom/conf/app.example.ini CONTRIBUTING.md README.md
-)
-FILECAPS=(
- -m 711 cap_net_bind_service+ep usr/bin/forgejo
-)
-
-RESTRICT="test"
-
-src_prepare() {
- default
-
- local sedcmds=(
- -e "s#^ROOT =#ROOT = ${EPREFIX}/var/lib/gitea/gitea-repositories#"
- -e "s#^ROOT_PATH =#ROOT_PATH = ${EPREFIX}/var/log/forgejo#"
- -e "s#^APP_DATA_PATH = data#APP_DATA_PATH = ${EPREFIX}/var/lib/gitea/data#"
- -e "s#^HTTP_ADDR = 0.0.0.0#HTTP_ADDR = 127.0.0.1#"
- -e "s#^MODE = console#MODE = file#"
- -e "s#^LEVEL = Trace#LEVEL = Info#"
- -e "s#^LOG_SQL = true#LOG_SQL = false#"
- -e "s#^DISABLE_ROUTER_LOG = false#DISABLE_ROUTER_LOG = true#"
- )
-
- sed -i "${sedcmds[@]}" custom/conf/app.example.ini || die
- if use sqlite ; then
- sed -i -e "s#^DB_TYPE = .*#DB_TYPE = sqlite3#" custom/conf/app.example.ini || die
- fi
-}
-
-src_configure() {
- # bug 832756 - PIE build issues
- filter-flags -fPIE
- filter-ldflags -fPIE -pie
-}
-
-src_compile() {
- local forgejo_tags=(
- bindata
- $(usev pam)
- $(usex sqlite 'sqlite sqlite_unlock_notify' '')
- )
- local forgejo_settings=(
- "-X code.gitea.io/gitea/modules/setting.CustomConf=${EPREFIX}/etc/forgejo/app.ini"
- "-X code.gitea.io/gitea/modules/setting.CustomPath=${EPREFIX}/var/lib/gitea/custom"
- "-X code.gitea.io/gitea/modules/setting.AppWorkPath=${EPREFIX}/var/lib/gitea"
- )
- local makeenv=(
- DRONE_TAG="${PV}"
- LDFLAGS="-extldflags \"${LDFLAGS}\" ${forgejo_settings[*]}"
- TAGS="${forgejo_tags[*]}"
- )
-
- GOFLAGS=""
- if use pie ; then
- GOFLAGS+="-buildmode=pie"
- fi
-
- # need to set -j1 or build fails due to a race condition between MAKE jobs.
- # this does not actually impact build parallelism, because the go compiler
- # will still build everything in parallel when it's invoked.
- env "${makeenv[@]}" emake -j1 EXTRA_GOFLAGS="${GOFLAGS}" backend
-}
-
-src_install() {
- cp gitea forgejo
- dobin forgejo
-
- einstalldocs
-
- newconfd "${FILESDIR}/forgejo.confd-r1" forgejo
- newinitd "${FILESDIR}/forgejo.initd-r3" forgejo
- newtmpfiles - forgejo.conf <<-EOF
- d /run/forgejo 0755 git git
- EOF
- systemd_newunit "${FILESDIR}"/forgejo.service-r3 forgejo.service
-
- insinto /etc/forgejo
- newins custom/conf/app.example.ini app.ini
- if use acct; then
- fowners root:git /etc/forgejo/{,app.ini}
- fperms g+w,o-rwx /etc/forgejo/{,app.ini}
-
- diropts -m0750 -o git -g git
- keepdir /var/lib/gitea /var/lib/gitea/custom /var/lib/gitea/data
- keepdir /var/log/forgejo
- fi
-}
-
-pkg_postinst() {
- fcaps_pkg_postinst
- tmpfiles_process forgejo.conf
-
- ewarn "${PN} ${PV} will continue to use /var/lib/gitea as the default home,"
- ewarn "as acct-user/git[gitea] depends on it, and acct-user[forgejo] does not"
- ewarn "exist yet."
- ewarn ""
- ewarn "7.x includes changes that may require manual intervention when"
- ewarn "upgrading from 1.21.x, most prominently:"
- ewarn ""
- ewarn "> MySQL 8.0 or PostgreSQL 12 are the minimum supported versions. The"
- ewarn "> database must be migrated before upgrading. The requirements"
- ewarn "> regarding SQLite did not change."
- ewarn ">"
- ewarn "> The Gitea themes were renamed and the [ui].THEMES setting must be changed as follows:"
- ewarn "> - gitea is replaced by gitea-light"
- ewarn "> - arc-green is replaced by gitea-dark"
- ewarn "> - auto is replaced by gitea-auto"
- ewarn ""
- ewarn "See https://codeberg.org/forgejo/forgejo/src/branch/forgejo/RELEASE-NOTES.md#7-0-0"
- ewarn "for more information"
-}