aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/rofi-emoji/rofi-emoji-3.3.0.ebuild')
-rw-r--r--x11-misc/rofi-emoji/rofi-emoji-3.3.0.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/x11-misc/rofi-emoji/rofi-emoji-3.3.0.ebuild b/x11-misc/rofi-emoji/rofi-emoji-3.3.0.ebuild
new file mode 100644
index 000000000..90d627a43
--- /dev/null
+++ b/x11-misc/rofi-emoji/rofi-emoji-3.3.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Emoji selector plugin for Rofi"
+HOMEPAGE="https://github.com/Mange/rofi-emoji"
+SRC_URI="https://github.com/Mange/rofi-emoji/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="X wayland"
+
+DEPEND="
+ wayland? (
+ gui-apps/rofi-wayland
+ )
+ X? (
+ x11-misc/rofi
+ )
+"
+RDEPEND="
+ ${DEPEND}
+ wayland? (
+ gui-apps/wl-clipboard
+ gui-apps/wtype
+ )
+ X? (
+ || ( x11-misc/xsel x11-misc/xclip x11-misc/copyq )
+ x11-misc/xdotool
+ )
+"
+
+src_prepare() {
+ default
+ eautoreconf -i
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}