aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2024-10-22 09:49:45 -0700
committerorbea <orbea@riseup.net>2024-10-22 09:49:45 -0700
commit54ff07750f43a8fa2b22c0afce9a5a24dc19d649 (patch)
tree111071524c5ad6da78fc914dda9e12a688b1a59d
parentnet-dialup/ppp: add 2.5.1-r1, drop 2.5.1 (diff)
downloadlibressl-54ff07750f43a8fa2b22c0afce9a5a24dc19d649.tar.gz
libressl-54ff07750f43a8fa2b22c0afce9a5a24dc19d649.tar.bz2
libressl-54ff07750f43a8fa2b22c0afce9a5a24dc19d649.zip
net-dialup/ppp: drop unused patches
Signed-off-by: orbea <orbea@riseup.net>
-rw-r--r--net-dialup/ppp/files/ppp-2.4.9-fix-MPPE-sstpc.patch25
-rw-r--r--net-dialup/ppp/files/ppp-2.4.9-fix-clang-nested-functions.patch65
-rw-r--r--net-dialup/ppp/files/ppp-2.4.9-fix-openssl-sysroot-clang.patch14
-rw-r--r--net-dialup/ppp/files/ppp-2.4.9-pppol2tp-ipv6.patch28
4 files changed, 0 insertions, 132 deletions
diff --git a/net-dialup/ppp/files/ppp-2.4.9-fix-MPPE-sstpc.patch b/net-dialup/ppp/files/ppp-2.4.9-fix-MPPE-sstpc.patch
deleted file mode 100644
index 15a1298..0000000
--- a/net-dialup/ppp/files/ppp-2.4.9-fix-MPPE-sstpc.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-https://github.com/ppp-project/ppp/commit/d7e62a8499c4032d79e05afbd8fd3efd51c5b148
-https://bugs.launchpad.net/ubuntu/+source/ppp/+bug/1958196
-
-From: =?UTF-8?q?Eivind=20N=C3=A6ss?= <eivnaes@yahoo.com>
-Date: Thu, 3 Feb 2022 14:28:22 -0800
-Subject: [PATCH] pppd/eap: Fix bug causing incorrect response length (#334)
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Need to update the esp->ea_client.ea_namelen variable. A plugin can override the
-name of the user, and the variable is passed onto the eap_chap2_response generating
-the wrong response length.
-
-Signed-off-by: Eivind Næss <eivnaes@yahoo.com>
---- a/pppd/eap.c
-+++ b/pppd/eap.c
-@@ -2182,6 +2182,7 @@ eap_request(eap_state *esp, u_char *inp, int id, int len)
- eap_send_nak(esp, id, EAPT_SRP);
- break;
- }
-+ esp->es_client.ea_namelen = strlen(esp->es_client.ea_name);
-
- /* Create the MSCHAPv2 response (and add to cache) */
- unsigned char response[MS_CHAP2_RESPONSE_LEN+1]; // VLEN + VALUE
diff --git a/net-dialup/ppp/files/ppp-2.4.9-fix-clang-nested-functions.patch b/net-dialup/ppp/files/ppp-2.4.9-fix-clang-nested-functions.patch
deleted file mode 100644
index 0a089e9..0000000
--- a/net-dialup/ppp/files/ppp-2.4.9-fix-clang-nested-functions.patch
+++ /dev/null
@@ -1,65 +0,0 @@
-https://github.com/ppp-project/ppp/commit/6e6a48fe628b76ec368277fd52685428e3dc8766
-https://bugs.gentoo.org/831305
-
-From: =?UTF-8?q?Eivind=20N=C3=A6ss?= <eivnaes@yahoo.com>
-Date: Sun, 11 Jul 2021 14:36:44 -0700
-Subject: [PATCH] Compiling with clang encounters an error in eap-tls.c
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-This moves the inline functions to outside the function and declares them static.
-
-Signed-off-by: Eivind Næss <eivnaes@yahoo.com>
---- a/pppd/eap-tls.c
-+++ b/pppd/eap-tls.c
-@@ -285,6 +285,23 @@ ENGINE *eaptls_ssl_load_engine( char *engine_name )
- #endif
-
-
-+#ifndef OPENSSL_NO_ENGINE
-+static int eaptls_UI_writer(UI *ui, UI_STRING *uis)
-+{
-+ PW_CB_DATA* cb_data = (PW_CB_DATA*)UI_get0_user_data(ui);
-+ UI_set_result(ui, uis, cb_data->password);
-+ return 1;
-+}
-+
-+static int eaptls_UI_stub(UI* ui) {
-+ return 1;
-+}
-+
-+static int eaptls_UI_reader(UI *ui, UI_STRING *uis) {
-+ return 1;
-+}
-+#endif
-+
- /*
- * Initialize the SSL stacks and tests if certificates, key and crl
- * for client or server use can be loaded.
-@@ -578,20 +595,11 @@ SSL_CTX *eaptls_init_ssl(int init_server, char *cacertfile, char *capath,
- {
- UI_METHOD* transfer_pin = UI_create_method("transfer_pin");
-
-- int writer (UI *ui, UI_STRING *uis)
-- {
-- PW_CB_DATA* cb_data = (PW_CB_DATA*)UI_get0_user_data(ui);
-- UI_set_result(ui, uis, cb_data->password);
-- return 1;
-- };
-- int stub (UI* ui) {return 1;};
-- int stub_reader (UI *ui, UI_STRING *uis) {return 1;};
--
-- UI_method_set_writer(transfer_pin, writer);
-- UI_method_set_opener(transfer_pin, stub);
-- UI_method_set_closer(transfer_pin, stub);
-- UI_method_set_flusher(transfer_pin, stub);
-- UI_method_set_reader(transfer_pin, stub_reader);
-+ UI_method_set_writer(transfer_pin, eaptls_UI_writer);
-+ UI_method_set_opener(transfer_pin, eaptls_UI_stub);
-+ UI_method_set_closer(transfer_pin, eaptls_UI_stub);
-+ UI_method_set_flusher(transfer_pin, eaptls_UI_stub);
-+ UI_method_set_reader(transfer_pin, eaptls_UI_reader);
-
- dbglog( "Using our private key URI: '%s' in engine", privkeyfile );
- pkey = ENGINE_load_private_key(pkey_engine, privkeyfile, transfer_pin, &cb_data);
diff --git a/net-dialup/ppp/files/ppp-2.4.9-fix-openssl-sysroot-clang.patch b/net-dialup/ppp/files/ppp-2.4.9-fix-openssl-sysroot-clang.patch
deleted file mode 100644
index 2bf8c45..0000000
--- a/net-dialup/ppp/files/ppp-2.4.9-fix-openssl-sysroot-clang.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-https://bugs.gentoo.org/831305
-
-Upstream git has merged autotoolsification PR so no need for this.
---- a/pppd/Makefile.linux
-+++ b/pppd/Makefile.linux
-@@ -155,7 +155,7 @@ endif
-
- ifdef NEEDDES
- ifndef USE_CRYPT
--CFLAGS += -I$(shell $(CC) --print-sysroot)/usr/include/openssl
-+CFLAGS += -I$(INSTROOT)/usr/include/openssl
- NEEDCRYPTOLIB = y
- else
- CFLAGS += -DUSE_CRYPT=1
diff --git a/net-dialup/ppp/files/ppp-2.4.9-pppol2tp-ipv6.patch b/net-dialup/ppp/files/ppp-2.4.9-pppol2tp-ipv6.patch
deleted file mode 100644
index 40773b2..0000000
--- a/net-dialup/ppp/files/ppp-2.4.9-pppol2tp-ipv6.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-https://bugs.gentoo.org/904740
-https://github.com/ppp-project/ppp/pull/319
-
-From 44a70d6f9eb6d1843868da1d45de382134a03630 Mon Sep 17 00:00:00 2001
-From: str8fast <52187302+str8fast@users.noreply.github.com>
-Date: Thu, 28 Oct 2021 14:55:56 +0000
-Subject: [PATCH] pppol2tp.c add '#ifdef INET6' for optional ipv6
-
-Without it, l2tp daemon can't launch ppp, cuz undefined symbol ipv6_up_notifier.
----
- pppd/plugins/pppol2tp/pppol2tp.c | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/pppd/plugins/pppol2tp/pppol2tp.c b/pppd/plugins/pppol2tp/pppol2tp.c
-index ed2d7c79..c9902afe 100644
---- a/pppd/plugins/pppol2tp/pppol2tp.c
-+++ b/pppd/plugins/pppol2tp/pppol2tp.c
-@@ -509,8 +509,10 @@ void plugin_init(void)
- */
- add_notifier(&ip_up_notifier, pppol2tp_ip_up, NULL);
- add_notifier(&ip_down_notifier, pppol2tp_ip_down, NULL);
-+#ifdef INET6
- add_notifier(&ipv6_up_notifier, pppol2tp_ip_up, NULL);
- add_notifier(&ipv6_down_notifier, pppol2tp_ip_down, NULL);
-+#endif
- }
-
- struct channel pppol2tp_channel = {