aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2018-06-24 11:43:16 +0200
committerBart Ribbers <bribbers@disroot.org>2018-06-24 11:43:16 +0200
commitf0ffff9ec39d8f523f16df847568720a0de6f7b7 (patch)
tree93043b180b15cc8cff828e72c6df44d19662d12b /dev-libs
parentInitial Olm ebuild, to be used later on in nheko (diff)
downloadmatrix-f0ffff9ec39d8f523f16df847568720a0de6f7b7.tar.gz
matrix-f0ffff9ec39d8f523f16df847568720a0de6f7b7.tar.bz2
matrix-f0ffff9ec39d8f523f16df847568720a0de6f7b7.zip
More nheko ebuilds and update Riot to 0.15.5
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/matrix-structs/Manifest1
-rw-r--r--dev-libs/matrix-structs/matrix-structs-9999.ebuild22
-rw-r--r--dev-libs/mtxclient/Manifest1
-rw-r--r--dev-libs/mtxclient/mtxclient-9999.ebuild23
-rw-r--r--dev-libs/olm/Manifest2
-rw-r--r--dev-libs/olm/olm-2.2.2.ebuild6
6 files changed, 54 insertions, 1 deletions
diff --git a/dev-libs/matrix-structs/Manifest b/dev-libs/matrix-structs/Manifest
new file mode 100644
index 0000000..d79c715
--- /dev/null
+++ b/dev-libs/matrix-structs/Manifest
@@ -0,0 +1 @@
+EBUILD matrix-structs-9999.ebuild 475 BLAKE2B 351a83f1014ba9f83c175933ca98a68cc1453609c2d22c3c54553ce63517e026c96c0c6aba895b0e3dfc83e697197eb3aeff4a221eeafb639178ba97196b7aca SHA512 fa295a06bd654b4e6a7f9e6a992d7b7611b7c0372600b566127284fe852aa6463f6a5da1e9834b06914712bfd5b89399ddecf3291782213cabe4a1fdf7aed8aa
diff --git a/dev-libs/matrix-structs/matrix-structs-9999.ebuild b/dev-libs/matrix-structs/matrix-structs-9999.ebuild
new file mode 100644
index 0000000..28efa9f
--- /dev/null
+++ b/dev-libs/matrix-structs/matrix-structs-9999.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="An implementation of the Double Ratchet cryptographic ratchet in C++"
+HOMEPAGE="https://github.com/mujx/${PN}"
+
+inherit git-r3 eutils cmake-utils
+
+EGIT_REPO_URI="https://github.com/mujx/${PN}.git"
+if [[ ${PV} != "9999" ]]; then
+ EGIT_COMMIT="v{$PV}"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
diff --git a/dev-libs/mtxclient/Manifest b/dev-libs/mtxclient/Manifest
new file mode 100644
index 0000000..c1dc03b
--- /dev/null
+++ b/dev-libs/mtxclient/Manifest
@@ -0,0 +1 @@
+EBUILD mtxclient-9999.ebuild 511 BLAKE2B 97ac1ea3cd426a4ef71ed09b2f10deefac6fff9af7f65e5ac4b00205a417166ef035b40f3b3cf224a4bdd582397c94386f715407914d09a9b4e37e482da6002b SHA512 89ce226f9ff782c7fcd14c22a2b64cfa575c01e764f7b69e3e43ef40c2bb874bf7a30ce1135ce5c1091092dc732ae02ca76425fc4275157abf96207fda647296
diff --git a/dev-libs/mtxclient/mtxclient-9999.ebuild b/dev-libs/mtxclient/mtxclient-9999.ebuild
new file mode 100644
index 0000000..3eff031
--- /dev/null
+++ b/dev-libs/mtxclient/mtxclient-9999.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="An implementation of the Double Ratchet cryptographic ratchet in C++"
+HOMEPAGE="https://github.com/mujx/${PN}"
+
+inherit git-r3 eutils cmake-utils
+
+EGIT_REPO_URI="https://github.com/mujx/${PN}.git"
+if [[ ${PV} != "9999" ]]; then
+ EGIT_COMMIT="v{$PV}"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-libs/spdlog
+ dev-libs/olm"
+DEPEND="${RDEPEND}"
diff --git a/dev-libs/olm/Manifest b/dev-libs/olm/Manifest
index 476daff..dd6cf99 100644
--- a/dev-libs/olm/Manifest
+++ b/dev-libs/olm/Manifest
@@ -1,2 +1,2 @@
DIST olm-2.2.2.tar.bz2 421913 BLAKE2B 7415b9e280607a1274cf216b860d248eddeec364a7572c49125724db124beae3d7e8acaa97b5eac0b3b1f1b97ce203a64e4dfc73bce27dd6823f04a9f44d5d45 SHA512 b502d703886f0853c408b9c210bde038e915c3bbcd79f94291b4caa60de4c7ed264910f6bbb8e1914ba034f552d4d423151dcf6e5f510625bb4002e43bfb0e08
-EBUILD olm-2.2.2.ebuild 457 BLAKE2B e1921feb54ab72690c780cbb938b99d33e5f33910ff0980cc36b5caa858b6c6ae3656be63338023361c3eedce1389d6deab376dc9877972812c23c6544fe9126 SHA512 54dbeb6e8e09871596f47a09e892820e3875cbfac363d48566400eae489ac55f759914e326e2bc1e1884c7fa843022045cec87f6edbad809f87a5edb6c20e4ee
+EBUILD olm-2.2.2.ebuild 538 BLAKE2B 93bf7bcc18aa7394b533e7991e531feb24614bf01b4f409d44ac1285668994977b55c00a570e39137b51366299a08a45500ac74163a14b24feb38f981c8358d9 SHA512 05cd7e38e2e609398204ed2bb03acaf2c5ea776efb523a499de11892160c537b454de8d4d05f148ccf0918e727c012aa718d8c62e42c07ab9e4760f8993bce17
diff --git a/dev-libs/olm/olm-2.2.2.ebuild b/dev-libs/olm/olm-2.2.2.ebuild
index 7e55750..246813b 100644
--- a/dev-libs/olm/olm-2.2.2.ebuild
+++ b/dev-libs/olm/olm-2.2.2.ebuild
@@ -20,3 +20,9 @@ IUSE=""
RDEPEND=""
DEPEND="${RDEPEND}"
+
+src_prepare() {
+ eapply_user
+
+ sed -i 's@$(PREFIX)@/usr@g' Makefile
+}