summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2024-10-09 09:06:53 +0200
committerFabian Groffen <grobian@gentoo.org>2024-10-09 09:16:53 +0200
commitdff843372e572e30bd93e825c11e9d749fbbfbf8 (patch)
tree57cc58ff1b8132d2aab881c2bae2fb262c13b08a
parentdev-libs/libbsd: sync with gx86 (diff)
downloadprefix-dff843372e572e30bd93e825c11e9d749fbbfbf8.tar.gz
prefix-dff843372e572e30bd93e825c11e9d749fbbfbf8.tar.bz2
prefix-dff843372e572e30bd93e825c11e9d749fbbfbf8.zip
sys-devel/gcc-config-1.9.1: cleanup old
Signed-off-by: Fabian Groffen <grobian@gentoo.org>
-rw-r--r--sys-devel/gcc-config/files/gcc-config-1.9-usrbinenv-bash.patch18
-rw-r--r--sys-devel/gcc-config/files/gcc-config-1.9.0-ensure-env-update-for-prefix.patch46
-rw-r--r--sys-devel/gcc-config/gcc-config-1.9.1.ebuild62
3 files changed, 0 insertions, 126 deletions
diff --git a/sys-devel/gcc-config/files/gcc-config-1.9-usrbinenv-bash.patch b/sys-devel/gcc-config/files/gcc-config-1.9-usrbinenv-bash.patch
deleted file mode 100644
index 5df08b42f6..0000000000
--- a/sys-devel/gcc-config/files/gcc-config-1.9-usrbinenv-bash.patch
+++ /dev/null
@@ -1,18 +0,0 @@
---- gcc-config-1.9.0/gcc-config
-+++ gcc-config-1.9.0/gcc-config
-@@ -1,4 +1,4 @@
--#!/bin/bash
-+#!/usr/bin/env bash
- # Copyright 1999-2012 Gentoo Foundation
- # Distributed under the terms of the GNU General Public License v2
-
---- gcc-config-1.9.1/Makefile
-+++ gcc-config-1.9.1/Makefile
-@@ -26,7 +26,6 @@
-
- .gcc-config: gcc-config
- sed \
-- -e '1s:/:$(EPREFIX)/:' \
- -e 's:@GENTOO_EPREFIX@:$(EPREFIX):g' \
- -e 's:@GENTOO_LIBDIR@:$(SUBLIBDIR):g' \
- -e 's:@PV@:$(PV):g' \
diff --git a/sys-devel/gcc-config/files/gcc-config-1.9.0-ensure-env-update-for-prefix.patch b/sys-devel/gcc-config/files/gcc-config-1.9.0-ensure-env-update-for-prefix.patch
deleted file mode 100644
index 744d8a1bc3..0000000000
--- a/sys-devel/gcc-config/files/gcc-config-1.9.0-ensure-env-update-for-prefix.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-From 748d20380aa1b27149dc1b80c7eaf15fde7c6aba Mon Sep 17 00:00:00 2001
-From: Fabian Groffen <grobian@gentoo.org>
-Date: Fri, 15 Dec 2017 09:30:17 +0100
-Subject: gcc-config: ensure we run env-update for prefix too
-
-The intention of commit cfbb9e94ca23c360d5801946e39da29c7d422dfc was to
-disable running ldconfig and updating ld.so.conf for prefix, but the
-implementation was too greedy and also disabled env-update, which we
-need to activate a compiler, see bug #641096.
-
-Bug: https://bugs.gentoo.org/641096
----
- gcc-config | 12 +++++++-----
- 1 file changed, 7 insertions(+), 5 deletions(-)
-
-diff --git a/gcc-config b/gcc-config
-index 7fcde15..ff8d8ac 100755
---- a/gcc-config
-+++ b/gcc-config
-@@ -693,16 +693,18 @@ switch_profile() {
- [[ ${FORCE} == "yes" || ${envd_changed} -gt 0 ]]
- then
- # in case python is broken ...
-- if [[ -z ${EPREFIX} ]] && ! env-update ; then
-+ if ! env-update ; then
- echo ""
- ewarn "env-update failed to work properly; making sure ld.so.conf paths"
- ewarn "are setup properly. Please rerun gcc-config with the -f option."
- echo ""
-- if [[ ! -d /etc/ld.so.conf.d ]] ; then
-- show_var LDPATH "${ROOT}"/etc/env.d/05gcc-${CTARGET} \
-- | ${SED} -e 's|:|\n|g' >> /etc/ld.so.conf
-+ if [[ -z ${EPREFIX} ]] ; then
-+ if [[ ! -d /etc/ld.so.conf.d ]] ; then
-+ show_var LDPATH "${ROOT}"/etc/env.d/05gcc-${CTARGET} \
-+ | ${SED} -e 's|:|\n|g' >> /etc/ld.so.conf
-+ fi
-+ ldconfig
- fi
-- ldconfig
- fi
- else
- envd_changed=0
---
-cgit v1.1
-
diff --git a/sys-devel/gcc-config/gcc-config-1.9.1.ebuild b/sys-devel/gcc-config/gcc-config-1.9.1.ebuild
deleted file mode 100644
index 3746c85755..0000000000
--- a/sys-devel/gcc-config/gcc-config-1.9.1.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit toolchain-funcs
-
-if [[ ${PV} == 9999 ]]; then
- EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/gcc-config.git"
- inherit git-r3
-else
- SRC_URI="mirror://gentoo/${P}.tar.xz
- https://dev.gentoo.org/~dilfridge/distfiles/${P}.tar.xz"
- KEYWORDS="~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
-fi
-
-DESCRIPTION="Utility to manage compilers"
-HOMEPAGE="https://gitweb.gentoo.org/proj/gcc-config.git/"
-LICENSE="GPL-2"
-SLOT="0"
-IUSE=""
-
-RDEPEND=">=sys-apps/gentoo-functions-0.10"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.8-copy-gcc-libs-darwin.patch
- "${FILESDIR}"/${PN}-1.9-cygwin.patch
- "${FILESDIR}"/${PN}-1.9-usrbinenv-bash.patch
-)
-
-src_compile() {
- emake CC="$(tc-getCC)" \
- EPREFIX="${EPREFIX}" \
- PV="${PV}" \
- SUBLIBDIR="$(get_libdir)"
-}
-
-src_install() {
- emake \
- EPREFIX="${EPREFIX}" \
- DESTDIR="${D}" \
- PV="${PV}" \
- SUBLIBDIR="$(get_libdir)" \
- install
-}
-
-pkg_postinst() {
- # Scrub eselect-compiler remains
- rm -f "${EROOT}"/etc/env.d/05compiler &
-
- # We not longer use the /usr/include/g++-v3 hacks, as
- # it is not needed ...
- rm -f "${EROOT}"/usr/include/g++{,-v3} &
-
- # Do we have a valid multi ver setup ?
- local x
- for x in $(gcc-config -C -l 2>/dev/null | awk '$NF == "*" { print $2 }') ; do
- gcc-config ${x}
- done
-
- wait
-}