aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorgentoo90 <gentoo90@gmail.com>2020-07-28 23:54:45 +0300
committerMikhail Pukhlikov <cynede@gentoo.org>2020-08-03 10:25:59 +0400
commit2260083a38d1f0ba59ad649446ddf14974c6a6cb (patch)
treecf3fb0db057a9e0b874271be6e905ef584b660d7
parentdev-lang/rust-bin-9999: add "source" useflag (diff)
downloadrust-2260083a38d1f0ba59ad649446ddf14974c6a6cb.tar.gz
rust-2260083a38d1f0ba59ad649446ddf14974c6a6cb.tar.bz2
rust-2260083a38d1f0ba59ad649446ddf14974c6a6cb.zip
dev-lang/rust-bin-9999: add "rust-analyzer" useflag
RLS - old and busted. rust-analyzer - new hotness. Signed-off-by: Mikhail Pukhlikov <cynede@gentoo.org>
-rw-r--r--dev-lang/rust-bin/rust-bin-9999.ebuild17
1 files changed, 15 insertions, 2 deletions
diff --git a/dev-lang/rust-bin/rust-bin-9999.ebuild b/dev-lang/rust-bin/rust-bin-9999.ebuild
index 66bddf0..c17cd9f 100644
--- a/dev-lang/rust-bin/rust-bin-9999.ebuild
+++ b/dev-lang/rust-bin/rust-bin-9999.ebuild
@@ -27,7 +27,7 @@ SLOT="nightly"
KEYWORDS=""
RESTRICT="network-sandbox"
-IUSE="clippy cpu_flags_x86_sse2 doc libressl rls rustfmt source ${ALL_RUSTLIB_TARGETS[*]}"
+IUSE="clippy cpu_flags_x86_sse2 doc libressl rls rust-analyzer rustfmt source ${ALL_RUSTLIB_TARGETS[*]}"
CDEPEND="
>=app-eselect/eselect-rust-0.3_pre20150425
@@ -46,7 +46,8 @@ RDEPEND="${CDEPEND}
!dev-util/cargo
"
REQUIRED_USE="x86? ( cpu_flags_x86_sse2 )
- rls? ( source )"
+ rls? ( source )
+ rust-analyzer? ( source )"
QA_PREBUILT="
opt/${P}/bin/*-${PV}
@@ -96,6 +97,10 @@ src_install() {
local analysis=$(grep 'analysis' ./components)
components="${components},rls-preview,${analysis}"
fi
+ if use rust-analyzer; then
+ local analysis=$(grep 'analysis' ./components)
+ components="${components},rust-analyzer-preview,${analysis}"
+ fi
use rustfmt && components="${components},rustfmt-preview"
elog "installing components: ${components}"
@@ -140,6 +145,11 @@ src_install() {
mv "${D}/opt/${P}/bin/rls" "${D}/opt/${P}/bin/${rls}" || die
dosym "../../opt/${P}/bin/${rls}" "/usr/bin/${rls}"
fi
+ if use rust-analyzer; then
+ local rust_analyzer=rust-analyzer-bin-${PV}
+ mv "${D}/opt/${P}/bin/rust-analyzer" "${D}/opt/${P}/bin/${rust_analyzer}" || die
+ dosym "../../opt/${P}/bin/${rust_analyzer}" "/usr/bin/${rust_analyzer}"
+ fi
if use rustfmt; then
local rustfmt=rustfmt-bin-${PV}
local cargo_fmt=cargo-fmt-bin-${PV}
@@ -170,6 +180,9 @@ src_install() {
if use rls; then
echo /usr/bin/rls >> "${T}/provider-${P}"
fi
+ if use rust-analyzer; then
+ echo /usr/bin/rust-analyzer >> "${T}/provider-${P}"
+ fi
if use rustfmt; then
echo /usr/bin/rustfmt >> "${T}/provider-${P}"
echo /usr/bin/cargo-fmt >> "${T}/provider-${P}"