aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael L <mike@michaellawrenceit.com>2018-09-01 00:32:00 -0500
committercnd <cynede@gentoo.org>2018-09-01 09:32:00 +0400
commit93edf5adc200506014c735a0d1e2e4796d5b7905 (patch)
tree6f030ee439285b2038b58d361a0c3a9a5ddcfb91 /dev-rust
parentSplit extended flags like it done in gentoo tree. (#363) (diff)
downloadrust-93edf5adc200506014c735a0d1e2e4796d5b7905.tar.gz
rust-93edf5adc200506014c735a0d1e2e4796d5b7905.tar.bz2
rust-93edf5adc200506014c735a0d1e2e4796d5b7905.zip
few embeded os tools (#366)
* add helix A Bridge to rust and likewise rust to ruby. can also in time transpile ruby to rust by quick look... looks promising , as a faster metasp....somethin. makes my day.. or any other faster Sec-Ops toys.. * drop stub file via web. * drop helix demo deps from toml and gen ebuild
Diffstat (limited to 'dev-rust')
-rw-r--r--dev-rust/calculator/Manifest2
-rw-r--r--dev-rust/calculator/calculator-0.0.1.ebuild25
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-rust/calculator/Manifest b/dev-rust/calculator/Manifest
new file mode 100644
index 0000000..85462a9
--- /dev/null
+++ b/dev-rust/calculator/Manifest
@@ -0,0 +1,2 @@
+DIST calculator-0.0.1.crate 4044 SHA256 158de4fbe402cd542c4c58d907087faedc8a248af30a11f71cfa4c1bbde08ea7 SHA512 91e7ede23289da17f78cbec736bb8e81dc84dd7f6cb475e938c844e1cb57071c88196b84bd9283f76c2c27eaad7a3883d848701c330fa51fcb7b65e195f9c257 WHIRLPOOL 4f9faf5f9ad33245293239243a517654ebff38bf57d4466d339e5b251c3c0584ec7cebe7f3be12232bcee105e607986c26cffafd7d313455b7882728e4b8fb7f
+DIST vec_map-0.0.1.crate 17271 SHA256 c1bb124acecc79b9a7efcb36a6ab469a203f2121f0bf44c36dc2c3e66581dadd SHA512 97180c8c477da34c22ecb00d053257e7060f72b966633e2cacc2e40db97d9812a2f8080e15f1ab7419ce4bf4649ba7d1939b210a3a2f30c5da61ace55e6bcb75 WHIRLPOOL bf74857b7f16367359d44be85a265786043269e78ea2d443567d4b33651aa6c21c63c28ecf364b1456904c8ff022965fb55a9d334600e1ccbf65fe627ede2cd3
diff --git a/dev-rust/calculator/calculator-0.0.1.ebuild b/dev-rust/calculator/calculator-0.0.1.ebuild
new file mode 100644
index 0000000..d5c9fdc
--- /dev/null
+++ b/dev-rust/calculator/calculator-0.0.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2017-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+# Auto-Generated by cargo-ebuild 0.1.5
+
+EAPI=6
+
+CRATES="
+calculator-0.0.1
+vec_map-0.0.1
+"
+
+inherit cargo
+
+DESCRIPTION="calculator"
+HOMEPAGE=""
+SRC_URI="$(cargo_crate_uris ${CRATES})"
+RESTRICT="mirror"
+LICENSE="unknown license" # Update to proper Gentoo format
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""