summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2022-04-02 14:51:08 +0100
committerJames Le Cuirot <chewi@gentoo.org>2022-04-02 14:52:13 +0100
commit09bdb6811f97dd040d8854c1296580c9bea5a5a8 (patch)
tree12682a3e2fd58242eca2b0124b42dfe22b6e81b4
parentwww-apps/phpBB: Bump to 3.3.7 with PHP 8.1, drop old 3.3.5 (diff)
downloadgentoo-09bdb6811f97dd040d8854c1296580c9bea5a5a8.tar.gz
gentoo-09bdb6811f97dd040d8854c1296580c9bea5a5a8.tar.bz2
gentoo-09bdb6811f97dd040d8854c1296580c9bea5a5a8.zip
dev-cpp/sdbus-c++: Apply Gentoo musl patches to systemd
This downgrades systemd slightly but the precise version isn't too important. This is admittedly not tested against musl. Hopefully it's sufficient. Closes: https://bugs.gentoo.org/836414 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
-rw-r--r--dev-cpp/sdbus-c++/Manifest3
-rw-r--r--dev-cpp/sdbus-c++/sdbus-c++-0.9.0-r1.ebuild (renamed from dev-cpp/sdbus-c++/sdbus-c++-0.9.0.ebuild)13
-rw-r--r--dev-cpp/sdbus-c++/sdbus-c++-1.1.0-r1.ebuild (renamed from dev-cpp/sdbus-c++/sdbus-c++-1.1.0.ebuild)13
3 files changed, 24 insertions, 5 deletions
diff --git a/dev-cpp/sdbus-c++/Manifest b/dev-cpp/sdbus-c++/Manifest
index fd0c4fb8f9c5..a1645906706d 100644
--- a/dev-cpp/sdbus-c++/Manifest
+++ b/dev-cpp/sdbus-c++/Manifest
@@ -1,3 +1,4 @@
DIST sdbus-c++-0.9.0.tar.gz 198979 BLAKE2B 31cda7ce97aad05f93a015ca0f8bd93aa095f6abb6bc513343767c7221d2aeacc96ee2b6a1b0ecf50850f17506fc97aa3a9fead0332687d57bdbddf806502826 SHA512 8695d3efac5654cb28998cdd69c16f251654b2c95e0dc2a2f5a4b01b24dae7b04e1a1f2e9bc9fb96b99f099dd4a130ca980cb672f74829565fd0d48162a581c5
DIST sdbus-c++-1.1.0.tar.gz 201532 BLAKE2B 3dac74cb7fc6717db9d25463ddfb9122db54edcd3bc9d1e71d18c132ede1efaf12b514f335c3978f51277afff7e6ab5533cfd02241759f7e3d24cede8aa29c6d SHA512 ba6230c0d1019875d92a92f793278c528a01692dc70e7acee8bb289af5dae65c1ad7b1c139f859cb7a960c7b48501178bfdf755163c2bc4d3766e67f3aa9b883
-DIST systemd-stable-250.4.tar.gz 11132786 BLAKE2B 8fdfe1bad76e572dc1be0955f3d1c4080f2beb81a2f9670f80827899f5406ab8ed8675400c2f5e8ccef44cf1bceff42ceae12a42e1b67d46c0deb523e6495f25 SHA512 307ed0920da660b6c45d909fea66864fb98db8b2f6905d629fb2012fc4bf64dd25fd61168c22bf4098200be541be9b0e815fbde98806a99c85cb33d49d8b63d0
+DIST systemd-musl-patches-249.5-r1.tar.xz 25148 BLAKE2B 6717291b5335997dcc327764beffc4ded50a5ac0e777bb3c540b5e355bee419c3d9b4a5605c239392d4c1b0e70792bc87282fa15dc9c09a0465b5608f2909006 SHA512 4bb7566437c280e75402fc435a3437aedad127f7b94c9bd54b94e9e1e7507409ad0898681f23e813b9b47414f58e4ca413b6d4e520bbbf578faec09054bf7f9b
+DIST systemd-stable-249.5.tar.gz 10597897 BLAKE2B 5c573322ef9bcd9d019776d6e2d8625a741c1535c0d06661b5666c2438a70cfc4dc182919bb419829de27a4d93c16717ce24e668faf9bd6b09e57f8bd88be725 SHA512 d6f1a5a6f03f0ed05b111aee75da509c5868c523af6209f33e630724dd0c7e0d0abf16920795d587e6c31a5915d247ebc613cf26d4aecf39f82ebb0690fab75f
diff --git a/dev-cpp/sdbus-c++/sdbus-c++-0.9.0.ebuild b/dev-cpp/sdbus-c++/sdbus-c++-0.9.0-r1.ebuild
index 04f6c85c5a16..fde2a90c6d5e 100644
--- a/dev-cpp/sdbus-c++/sdbus-c++-0.9.0.ebuild
+++ b/dev-cpp/sdbus-c++/sdbus-c++-0.9.0-r1.ebuild
@@ -6,11 +6,19 @@ EAPI=8
PYTHON_COMPAT=( python3_{8..10} )
inherit python-any-r1 meson cmake
-SDP="systemd-stable-250.4"
+SDP="systemd-stable-249.5"
+MUSL_PATCHSET="249.5-r1"
+
DESCRIPTION="High-level C++ D-Bus library"
HOMEPAGE="https://github.com/Kistler-Group/sdbus-cpp"
SRC_URI="https://github.com/Kistler-Group/sdbus-cpp/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
- !systemd? ( https://github.com/systemd/systemd/archive/v${SDP##*-}/${SDP}.tar.gz )"
+ !systemd? (
+ https://github.com/systemd/systemd/archive/v${SDP##*-}/${SDP}.tar.gz
+ elibc_musl? (
+ https://dev.gentoo.org/~gyakovlev/distfiles/systemd-musl-patches-${MUSL_PATCHSET}.tar.xz
+ https://dev.gentoo.org/~soap/distfiles/systemd-musl-patches-${MUSL_PATCHSET}.tar.xz
+ )
+ )"
LICENSE="LGPL-2.1+ Nokia-Qt-LGPL-Exception-1.1" # Nothing to do with Qt but exception text is exactly the same.
SLOT="0/0"
KEYWORDS="~amd64"
@@ -56,6 +64,7 @@ pkg_setup() {
src_prepare() {
if ! use systemd; then
pushd "${SDS}" || die
+ use elibc_musl && eapply "${WORKDIR}"/musl-patches
eapply "${FILESDIR}"/${PN}-static-libsystemd.patch
popd || die
fi
diff --git a/dev-cpp/sdbus-c++/sdbus-c++-1.1.0.ebuild b/dev-cpp/sdbus-c++/sdbus-c++-1.1.0-r1.ebuild
index 7eee346da844..df550152fd34 100644
--- a/dev-cpp/sdbus-c++/sdbus-c++-1.1.0.ebuild
+++ b/dev-cpp/sdbus-c++/sdbus-c++-1.1.0-r1.ebuild
@@ -6,11 +6,19 @@ EAPI=8
PYTHON_COMPAT=( python3_{8..10} )
inherit python-any-r1 meson cmake
-SDP="systemd-stable-250.4"
+SDP="systemd-stable-249.5"
+MUSL_PATCHSET="249.5-r1"
+
DESCRIPTION="High-level C++ D-Bus library"
HOMEPAGE="https://github.com/Kistler-Group/sdbus-cpp"
SRC_URI="https://github.com/Kistler-Group/sdbus-cpp/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
- !systemd? ( https://github.com/systemd/systemd/archive/v${SDP##*-}/${SDP}.tar.gz )"
+ !systemd? (
+ https://github.com/systemd/systemd/archive/v${SDP##*-}/${SDP}.tar.gz
+ elibc_musl? (
+ https://dev.gentoo.org/~gyakovlev/distfiles/systemd-musl-patches-${MUSL_PATCHSET}.tar.xz
+ https://dev.gentoo.org/~soap/distfiles/systemd-musl-patches-${MUSL_PATCHSET}.tar.xz
+ )
+ )"
LICENSE="LGPL-2.1+ Nokia-Qt-LGPL-Exception-1.1" # Nothing to do with Qt but exception text is exactly the same.
SLOT="0/1"
KEYWORDS="~amd64"
@@ -60,6 +68,7 @@ pkg_setup() {
src_prepare() {
if ! use systemd; then
pushd "${SDS}" || die
+ use elibc_musl && eapply "${WORKDIR}"/musl-patches
eapply "${FILESDIR}"/${PN}-static-libsystemd.patch
popd || die
fi