summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-21 05:53:03 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-21 05:53:03 +0100
commit266f818d1518a9a3990307bc50c4c7fb3a8ae318 (patch)
tree601b322b616c3436154187d570e32a59ed13ee90
parentdev-python/uv: Remove old (diff)
downloadgentoo-266f818d1518a9a3990307bc50c4c7fb3a8ae318.tar.gz
gentoo-266f818d1518a9a3990307bc50c4c7fb3a8ae318.tar.bz2
gentoo-266f818d1518a9a3990307bc50c4c7fb3a8ae318.zip
dev-python/ensurepip-setuptools: Bump to 75.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/ensurepip-setuptools/Manifest1
-rw-r--r--dev-python/ensurepip-setuptools/ensurepip-setuptools-75.6.0.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/ensurepip-setuptools/Manifest b/dev-python/ensurepip-setuptools/Manifest
index 2e9b00d9507d..dc98a38c2fbe 100644
--- a/dev-python/ensurepip-setuptools/Manifest
+++ b/dev-python/ensurepip-setuptools/Manifest
@@ -1,2 +1,3 @@
DIST setuptools-74.1.3-py3-none-any.whl 1262070 BLAKE2B 967e581556dee96b068a762605e340a7dbdb7eedb62fc2224fa3cbff8c29c6dd8966831bf4d2c4714401c8beca6ff81ba64823ec55ce592ff3bf10ddee370975 SHA512 8dd7f782ccbfcef04462904f3211569a2ca0be7f370a75cd1d77b77c1f38fcfbea8fd401646bbf436c093ad4573e32f0a0eef030644df48817fde43ae59ce0aa
DIST setuptools-75.5.0-py3-none-any.whl 1222710 BLAKE2B 40359574a10a14fb6fdef3a5f5a1febe61446ae1510a96236f0cf93d7cd4dbf3c3904bd77729d0877bcceed3d4fc55bad6e1a6eba9800cd4bbe9a394a829b81f SHA512 3caee919ed5f352d6ca92d648f438c4a18a42cc3f4e1bbfe58dfa43e86ebcc9345476c2119c165d0aa07353e1a4e6c9fbc296d2e41d089084395f13678e80096
+DIST setuptools-75.6.0-py3-none-any.whl 1224032 BLAKE2B 7a91cf811611082234c0d4d52970f81126c5908f6ef1fe8455e33870c6872d86181447bdb052e21a145558cd259983e73b6e18128a7d9f42478c716816c74394 SHA512 2c80b0bbcfa0d09a8a380b60ef9512d387129fba233e1aab83279caa5ca53ecc252f060edaef9ed00eb6d79312cd10fed82dd2491b723d50940828d1766aee89
diff --git a/dev-python/ensurepip-setuptools/ensurepip-setuptools-75.6.0.ebuild b/dev-python/ensurepip-setuptools/ensurepip-setuptools-75.6.0.ebuild
new file mode 100644
index 000000000000..c48c6a133f1f
--- /dev/null
+++ b/dev-python/ensurepip-setuptools/ensurepip-setuptools-75.6.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit pypi
+
+DESCRIPTION="Shared setuptools wheel for ensurepip Python module"
+HOMEPAGE="https://pypi.org/project/setuptools/"
+SRC_URI="$(pypi_wheel_url "${PN#ensurepip-}")"
+S=${DISTDIR}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="
+ !<dev-python/ensurepip-wheels-100
+"
+
+src_install() {
+ insinto /usr/lib/python/ensurepip
+ doins "${A}"
+}